If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Can't update, "check for updates" is greyed out?

inopinatusinopinatus Posts: 12Members, Plex Pass Plex Pass

Mac Mini server running High Sierra 10.13.1, Plex Pass channel. On Plex version 1.9.7.4441, and 1.9.7.4460 is available but the update button is greyed out.

There's no explanation in the interface of what's preventing the update, any suggestions?

Tagged:

Best Answers

  • mwhite52mwhite52 Posts: 1Members, Plex Pass Plex Pass
    Accepted Answer

    I had the same problem on the exact same setup. The following worked for me:

    • Close Plex on your Mac Mini
    • Sign into the plex website in your web browser
    • Go to the plex downloads page
    • Choose Download PMS
    • Run the installer then open plex, it should be up to date and the "Check for Updates" button should no longer be greyed out.
«1

Answers

  • mwhite52mwhite52 Posts: 1Members, Plex Pass Plex Pass
    Accepted Answer

    I had the same problem on the exact same setup. The following worked for me:

    • Close Plex on your Mac Mini
    • Sign into the plex website in your web browser
    • Go to the plex downloads page
    • Choose Download PMS
    • Run the installer then open plex, it should be up to date and the "Check for Updates" button should no longer be greyed out.
  • AmazingRando24AmazingRando24 Posts: 1,077Members, Plex Pass Plex Pass

    @mwhite52 said:
    I had the same problem on the exact same setup. The following worked for me:

    • Close Plex on your Mac Mini
    • Sign into the plex website in your web browser
    • Go to the plex downloads page
    • Choose Download PMS
    • Run the installer then open plex, it should be up to date and the "Check for Updates" button should no longer be greyed out.

    Every once in a while an update rolls out that requires this sort of manual install.

    Check this list to compare your version to the most recent:
    https://forums.plex.tv/discussion/62832/plex-media-server#latest

    PMS Server: Intel i7-6700 16gb RAM Dedicated Windows 10 PC
    DVR Lineup: Dual HDHomeRun Extend Tuners
    NAS: Drobo 5n2-15tb / Drobo B800fs 24tb

    "It's amazing what replacing one faulty network cable will do for your Plex performance!"

  • BastardSheepBastardSheep Posts: 287Members, Plex Pass Plex Pass
    edited December 2017

    I've done a manual install about 4 times now. Immediately upon installing this way "check for updates" is fine, but after a while (can't say how long) it goes back to being greyed out. Currently downloading 1.11.something, going from 1.10.1.4561.

    Edit: You know what? I always install updates anyway so I'll just set it to run them during maintenance. That way I won't have to worry about the button being greyed out.

  • arm3narm3n Posts: 3Members, Plex Pass Plex Pass

    Same issue - has only reared its head in the past few weeks.

  • rhett.iphone@gmail.comrhett.iphone@gmail.com Posts: 2Members, Plex Pass Plex Pass

    Same issue on Version 1.9.6.4429. My server frequently says it is not available outside my network for no particular reason also. I wish they made older versions available for download as well.

  • chub_rock1chub_rock1 Posts: 12Members, Plex Pass Plex Pass

    Same issue on Windows 2012 R2 Server

  • BastardSheepBastardSheep Posts: 287Members, Plex Pass Plex Pass

    Looks like the automatic update didn't run. Still had to download the latest one manually.

    Looks like the "check for updates" button is usable when there is no update. As soon as there is an update, it greys itself out so you can't use that method to update. Have to just run updates manually, which is frustrating.

  • mojimbamojimba Posts: 11Members, Plex Pass Plex Pass

    Same with 1.9.7.4460 on Windows 7 x64... manually updated to 1.11.0.4666 and update checking is working again now...

  • e.esquire@gmail.come.esquire@gmail.com Posts: 2Members, Plex Pass Plex Pass

    Same issue here.

  • dhausmandhausman Posts: 13Members, Plex Pass Plex Pass

    same issue here. PMS on Mac OS. I am on 1.9.7.4730 on beta channel

  • pardonmepardonme Posts: 33Members, Plex Pass Plex Pass

    @dhausman This was the permanent fix for me as well, thank you!

  • rnd2004rnd2004 Posts: 4Members, Plex Pass Plex Pass

    @dhausman said:
    I fixed my issue on my Mac Plex server.

    • Quit Plex media server
    • Open the preferences plist ~/Library/Preferences/com.plexapp.plexmediaserver.plist
    • Backup your com.plexapp.plexmediaserver.plist just in case.
    • delete ButlerTaskSkippedVersion
    • Save
    • Restart Plex Media Server

    THIS.

    Manually installing does not fix, you have to manually install each time. However, this solution has permanently resolved it for me. THANKS!!!!

  • pardonmepardonme Posts: 33Members, Plex Pass Plex Pass

    Also for I've used the following app to edit the preference plist file:

    http://www.nightproductions.net/prefsetter.html

    It's free and worked like a charm. Hope this helps :)

  • pekingdutchpekingdutch Posts: 4Members, Plex Pass Plex Pass

    @dhausman has the correct solution for this issue. The answer should be changed to this one!

  • charlesacharlesa Posts: 4Members, Plex Pass Plex Pass
    edited March 5

    For those who want to tackle this from the commandline. (May require Xcode installed)

    defaults read ~/Library/Preferences/com.plexapp.mediaserver ButlerTaskUpdateVersionSkipped

    defaults delete ~/Library/Preferences/com.plexapp.mediaserver ButlerTaskUpdateVersionSkipped

  • keromeisterkeromeister Posts: 13Members, Plex Pass Plex Pass

    Actually its:

    defaults read ~/Library/Preferences/com.plexapp.plexmediaserver ButlerTaskUpdateVersionSkipped

    defaults delete ~/Library/Preferences/com.plexapp.plexmediaserver ButlerTaskUpdateVersionSkipped

    Minor typo in previous post.

  • carlos1001carlos1001 Posts: 3Members ✭✭

    @dhausman said:
    I fixed my issue on my Mac Plex server.

    • Quit Plex media server
    • Open the preferences plist ~/Library/Preferences/com.plexapp.plexmediaserver.plist
    • Backup your com.plexapp.plexmediaserver.plist just in case.
    • delete ButlerTaskSkippedVersion
    • Save
    • Restart Plex Media Server

    Did all this but as soon as I open Plex media server again the update button is still greyed out and if I reopen plexmediaserver.plist the ButlerTaskUpdateVersionSkipped is back again do you also need to delete the 2 underscores separating them from the next and beginning lines? I think I made sure there was no instances of Plex still running in activity monitor too ! Please help :)

  • rgruergrue Posts: 6Members, Plex Pass Plex Pass

    defaults will only work if the plist is registered globally. if that's not the case for you (it wasn't for me), then from terminal, you can run the following:

    /usr/libexec/PlistBuddy ~/Library/Preferences/com.plexapp.plexmediaserver.plist

    It's useful to run /usr/libexec/PlistBuddy -h first to get usage.

    Once in, use Print to display the plist, and Delete : ButlerTaskSkippedVersion to delete, then Save

  • carlos1001carlos1001 Posts: 3Members ✭✭

    @rgrue said:
    defaults will only work if the plist is registered globally. if that's not the case for you (it wasn't for me), then from terminal, you can run the following:

    /usr/libexec/PlistBuddy ~/Library/Preferences/com.plexapp.plexmediaserver.plist

    It's useful to run /usr/libexec/PlistBuddy -h first to get usage.

    Once in, use Print to display the plist, and Delete : ButlerTaskSkippedVersion to delete, then Save

    Mine is labeled ButlerTaskUpdateVersionSkipped and when I try to delete it as advised I get "Working container has become invalid. Setting to : " ignore quotations ;)

«1
Sign In or Register to comment.