If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Plex Refuses to Transcode

ethereal333ethereal333 Posts: 1Members, Plex Pass Plex Pass

Hello,

I updated my plexmediaserver plugin in FreeNAS 9.10.2-U6 to 1.9.6.4492 and Plex stopped transcoding files. Only Direct Play was possible. I could not test Direct Stream. I decided it is time to upgrade FreeNAS anyway and move the plugin to a standard jail so I updated from Freenas-9.10.2.U6 to FreeNAS-11.0-U4. I deleted the Plex plugin and created a standard jail. I installed the latest plexmediaserver_plexpass package in it. I mounted my Media folder to /mnt and the Plex media library folder to /usr/local/plexdata-plexpass because I have the Plex library folder backed up in a different folder than the jails. I am now runing Plex Version 1.10.0.4516 and the result is the same - Plex will not transcode. The orange circle spins forever. I tried to use different players and everywhere only the Direct Play was possible. There is plenty of space on the volume where the jail was created. I re-analyzed the libraries and it did not help. The FreeNAS reporting tab and Display System Processes both show high processor usage during the time when Plex tries to start playing a transcoded file. Only once I received some error message regarding shaka1001.

Is there anyone who can help me by looking at the attached logs?

Comments

  • patrick1227patrick1227 Posts: 6Members, Plex Pass Plex Pass

    hello @ethereal333 did you ever figure this out I am having the same problem

  • omsionomsion Posts: 5Members, Plex Pass Plex Pass
    edited January 5

    I have/had a similar problem with Plex in a BSD jail on FreeNAS - video transcoding will either never start (less common), or when it does start (most of the time), it will randomly give up after a few minutes and call it quits, requiring a restart of the stream. This got old real quick.

    I gave up and moved Plex to a bhyve VM running ubuntu server. Kind of sad that a virtualized solution works better than native.

Sign In or Register to comment.