If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Alexa cannot stream from plex server

zxchriszxchris Posts: 8Members, Plex Pass Plex Pass

I'm currently running the latest PMS (1.10.0.4523) and have just bought an Echo Dot specifically to use with Plex - and I am struggling to get to get working.

PMS remote access is fully configured and I can access from anywhere on the internet either through browser (https://plex.tv/....), iOS or Amazon Fire Stick. The Lovely green padlock shows against the server in all my clients. Secure connections on PMS are set to 'Preferred'. Only port 32400 is exposed through my router. Checking on the server, plex is listening on 32400, 32401, 32600.

Alex skill is linked, and Alexa is able to browse my library, list what is On Deck etc (when "preferred" secure connections set on PMS).

When I try to play a song, Alexa says "I cannot stream music unless you have enabled secure connections on your PMS". When I change my PMS secure settings from "Preferred" to "Required", Alexa fails completely and cannot connect at all, and errors with an "Uh oh, something went wrong".

When I access my PMS over https directly on the LAN (and not via https://plex.tv) I of course, get an untrusted certificate warning.

Is this a common problem?

Do I need to open additional ports for the Alexa Skill to use?

Thanks all..... it's driving me nuts !

Answers

  • stevem.uabstevem.uab Posts: 8Members, Plex Pass Plex Pass

    I am having the exact same problem. I have enabled secure connections and verified in other clients that Plex is connecting to them with a secure connection (green dot by the server name), but Echo Dot will not work. Hope you found a solution....I'm still hunting.

  • almontefalmontef Posts: 105Members, Plex Pass Plex Pass

    Did you guys ever find solution for this issue? Beyond pausing and playing something that is already playing Alexa fails to play a movie or show, check what's on deck, etc. I get the something went wrong message.

  • EJ JamesEJ James Posts: 1Members, Plex Pass Plex Pass

    Hoping a bump to this will get some attention. Having the same issue after enabling the Alexa skill today.

    Anyone? Bueller?

  • Dagger9903Dagger9903 Posts: 1Members

    I was having this secure connection issue and fixed it by changing the routing instructions to use TCP only for the Plex ports. It was both TCP/UDP before.

    Hope that helps.

  • zxchriszxchris Posts: 8Members, Plex Pass Plex Pass

    Okay, I've not changed anything firewall or network-wise (I was always using secure connections anyway) but since upgrading to server 1.12.3.4973 (ubuntu) it is working fine! :smile:

    My settings:
    Firewall is passing only TCP packets for the Plex ports (no UDP, as mentioned by @Dagger9903)
    Plex remote access is "fully available" with a nice green tick, and Network Secure Connections is "preferred".

    Hope that helps anyone who wanders in here....

Sign In or Register to comment.