If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

remote quality not working with v2.009

mazumazu Posts: 26Members, Plex Pass Plex Pass

hi
im trying to get remote quality to work with the latest samsung plex app v2.009 but no matter what i do i cannot get it to reduce the bitrate quality.
none of the options within the plex app seem to working.

ive tried setting the remote qaulity to 1 so i can at least prove that its reduce the 720p video to something smaller but no go.
in the player section i tried the "auto adjust transcoding quality" option but this does not seem to work either.

using my laptop as a test and the same network cable im able to reduce the quality of the videos i want to play and watch them without any buffering.
I was able to set the quality to 2.0 MB 720 and it worked fine.
that tells me that transcode method is working and the internet connectivity is fast enough to play a slightly lower bitrate... i just cant get it to stick on the samsung app.

so im completely stumped as to why the plex app on the samsung will not do any of this.

my server details

Win 2012R2
plex server version: Version 1.10.1.4561
samsung TV UA60F7100 F series 2013 model
plex app version: 2.009

ive checked the manual for help but couldnt find anything in there to resolve my issue.

the only option on the samsung plex app that i had any success with is to change the playback mode to "transcode"
this definitely seemed to change the bitrate but it kept changing quality on the fly and flickering the screen...

id like to set it to be 2MB all the time.. im not sure why this option isnt there.. find it a bit odd that it was removed?
seems like the auto options are not working very well or at all in my case

anybody have any suggestions on what i can try?

please let me know if you need any more info

cheers

Answers

  • OrcaOrca Plex for Samsung Developer Posts: 7,564Members, Plex Pass, Plex Ninja Plex Ninja

    The auto adjust transcoding quality has a visual bug, it looks like it's not staying on, but it actually does.
    The setting you made last, is the real setting. I will fix the visual bug in the next release.

    Please note that auto is not the same as "auto adjust transcoding quality".
    The normal auto checks if the video can be direct played or not.
    For "auto adjust transcoding quality" you need to selected Transcoding as default!
    As the setting implies, it only works for transcoding.
    If it doesn't work for you, because the connection is not stable enough, It might be best to set a fixed quality.

    Please check the manual, it lists the corresponding bitrates v.s. quality settings.

    Have you checked if your answer might be in the User Manual?
    My Samsung environment:

    2010 BD-C5500 Blu-Ray,
    2011 UE46D7000 LED-TV,

    2012 BD-ES6000 Blu-Ray,

    2014 UE55HU8500L UHD LED TV

    If you enjoy this free app, you can buy me a beer by making a Donation

  • mazumazu Posts: 26Members, Plex Pass Plex Pass

    hey Orca

    thanks for replying

    so i got the transcode settings working last night.. the auto adjust was doing its thing as i could see the video changing bitrate and quality on the fly.

    as mentioned above 2MB 720p works fine with the limited connection i have at my disposal at my mums place so i need to set a fixed quality here...

    ill check the manual for bitrates vs quality settings and see if i can get this sorted..
    is there any particular combination of settings that i should be using so i can see the fixed quality options.. i ask because i spent hours fidgeting around with settings last night and not once did i see a fixed quality option :neutral:
    except the remote quality section.. options 1-12.. but this wasnt working at all

    ill post back once ive sorted it out or if i have any more questions

    cheers

  • mazumazu Posts: 26Members, Plex Pass Plex Pass

    so on page 76 of the manual Plex_for_Samsung_App_Manual_v2.009.pdf it shows the Transcoding quality table

    5 Remote transcoding This setting will only affect streaming content from remote servers. Remote transcoding works the same as Local transcoding. The setting for remote transcoding can be found under Preferences > Advanced > Remote Quality

    so if i set the quality to 1 im expecting the transcode to be poor quality... but the transcode does not take effect and the quality is being played as the original file.
    now i know that 2MB works so according to the table the setting should be on 6.
    but as i just mentioned the setting is not working.

    so how do i get this to work?

    if i set playback mode to transcode and turn off auto adjust.... will the remote quality settings kick in?

    as you can see im struggling to understand what combination of settings are needed for remote quality to work.

    can you advise please?

    appreciate your help!

  • OrcaOrca Plex for Samsung Developer Posts: 7,564Members, Plex Pass, Plex Ninja Plex Ninja

    Yes, turn off auto adjust and set your quality for remote and local if needed.
    Those settings will be used when transcoding is enabled.
    BTW if you always need transcoding, then you might want to set it as default in Preferences > Player

    Have you checked if your answer might be in the User Manual?
    My Samsung environment:

    2010 BD-C5500 Blu-Ray,
    2011 UE46D7000 LED-TV,

    2012 BD-ES6000 Blu-Ray,

    2014 UE55HU8500L UHD LED TV

    If you enjoy this free app, you can buy me a beer by making a Donation

  • mazumazu Posts: 26Members, Plex Pass Plex Pass

    ok ill try that out and let you know how it goes...

    im sure i tried this combination of settings before but it didnt work :/
    i think ill uninstall and reinstall the app making sure everything is back to default

  • mazumazu Posts: 26Members, Plex Pass Plex Pass

    so ive reinstalled the app making sure its all set to default.

    i changed remote quality to 1 to make sure i can see the low bitrate
    played a file but the file was original quality.

    • auto adjust bitrate is turned off (*i assume this is default)
    • playback mode is set to auto
      when i look at the PMS now playing section i can see that the video is playing as direct play

    so i thought id change the playback mode to transcoding and see what happens
    on the PMS server i can see that file being played was transcoding video and audio but when it started playing it still looked normal .. meaning that the remote quality setting did not work and the video started buffering.

    i can confirm that remote quality is set to 1.

    what am i doing wrong...? :neutral:

    would the PMS verbose logs show anything?

  • OrcaOrca Plex for Samsung Developer Posts: 7,564Members, Plex Pass, Plex Ninja Plex Ninja

    Yep logs would help.
    Make sure you enable the "Send debug to PMS" option before you do your test, so it shows up in the log.

    Have you checked if your answer might be in the User Manual?
    My Samsung environment:

    2010 BD-C5500 Blu-Ray,
    2011 UE46D7000 LED-TV,

    2012 BD-ES6000 Blu-Ray,

    2014 UE55HU8500L UHD LED TV

    If you enjoy this free app, you can buy me a beer by making a Donation

  • mazumazu Posts: 26Members, Plex Pass Plex Pass

    i enabled send debug to PMS
    enabled verbose on the debug section on the server itself

    started playing a video that shouldve transcoded to remote quality 1 but it did not.
    it started buffering shortly after starting the video.
    i stopped the video and downloaded the logs from the server

    PMS logs attached

    let me know what you find

    thanks for looking into this

    cheers

  • OrcaOrca Plex for Samsung Developer Posts: 7,564Members, Plex Pass, Plex Ninja Plex Ninja
    edited December 2017

    The log is showing that you didn't enable Transcoding. It seems the app is set to Auto
    The app checks the used container and codecs and decides it's OK to direct play this.
    The server does a bandwidth check to see if the server admin has set any restrictions, and decides it's OK to direct play.

    Try this again, but now on the preview window, select the icon that looks like a movieframe and select Transcoding before starting the video.

    Extract from your log:

    Auto Mode is enabled
    Player playbackMode : 1 `(= Auto)`
    Player mode: 1 `(= Video)`
    DirectPlay profile check
    [Container  : mkv] --> OK
    [Video codec: h264] --> OK
    [Audio codec: ac3] --> OK
    [DirectPlay possible]
    Direct Play result: 1
    Server is remote, checking for allowed bandwidth
    Server decision: 1000: Direct play OK.
    Bandwidth result: 1
    Player Direct playing: http://xxx
    

    Have you checked if your answer might be in the User Manual?
    My Samsung environment:

    2010 BD-C5500 Blu-Ray,
    2011 UE46D7000 LED-TV,

    2012 BD-ES6000 Blu-Ray,

    2014 UE55HU8500L UHD LED TV

    If you enjoy this free app, you can buy me a beer by making a Donation

  • mazumazu Posts: 26Members, Plex Pass Plex Pass

    hmmm

    im sure ive tried having transcoding set as playback mode but it still didnt do what i wanted.
    ill check the preview window option and let you know how it goes

    thanks

  • mazumazu Posts: 26Members, Plex Pass Plex Pass

    i changed playback mode to transcoding
    checked the video option in the preview and made sure transcoding is selected.

    on the preview page it even says transcoding

    once the video started playing i pushed the up arrow on the remote to bring up the options and you can see that transcoding is being displayed.

    but the video was still playing at original quality and it was buffering.

    ive uploaded the logs which should contain the transcode details
    look for a tv show brooklyn nine nine and the big bang theory... been testing it on these 2 shows.

  • OrcaOrca Plex for Samsung Developer Posts: 7,564Members, Plex Pass, Plex Ninja Plex Ninja

    Actually setting it to 1 is a bit over the top, since that would only work for very low resolution videos.
    As soon as the transcoded bitrate goes above what you want it too be it will not be able to transcode it.
    In practice anything below 4 is not worth watching when we talk about a TV show on a TV.
    Also bare in mind that reducing the quality is harder when setting it very low so you PC will have more work to do.

    Other then that I can't find a reason why the stream would buffer constantly.

    Have you checked if your answer might be in the User Manual?
    My Samsung environment:

    2010 BD-C5500 Blu-Ray,
    2011 UE46D7000 LED-TV,

    2012 BD-ES6000 Blu-Ray,

    2014 UE55HU8500L UHD LED TV

    If you enjoy this free app, you can buy me a beer by making a Donation

  • mazumazu Posts: 26Members, Plex Pass Plex Pass

    ok thanks... i did change the setting back to 6 but still didnt see any difference
    as far as i can see the transcoding setting is not being activated properly.

    which log file contains the extract you posted up the other day?

    are there any particular settings required on the server for transcode to work?
    just wondering if theres a misconfiguration somewhere stopping it from doing what its meant to...

    appreciate your help

    cheers

  • OrcaOrca Plex for Samsung Developer Posts: 7,564Members, Plex Pass, Plex Ninja Plex Ninja

    The log you want is called Plex Media Server.log
    If you enabled "Send Debug to PMS"it should contain lines starting with [PlexForSamsung] which belong to the app.

    To confirm transcodng is working try this:

    • Disable the "Auto adjust quality"option
    • Set the local or remote quality to 3 under Preferences/Advanced , depending on which server you use
    • Make sure Transcoding is selected in the Preview window

    Start the video. It should look very blurry indicating the transcoder decreased the bitrate.
    Also note that 'Auto adjust quality" will not go beyond the quality you set as default.
    It will try to lower it when the connection goes bad and increase it when it goes up, but never beyond the quality setting.
    Auto adjust also takes a while before it will decide to make a change.

    Have you checked if your answer might be in the User Manual?
    My Samsung environment:

    2010 BD-C5500 Blu-Ray,
    2011 UE46D7000 LED-TV,

    2012 BD-ES6000 Blu-Ray,

    2014 UE55HU8500L UHD LED TV

    If you enjoy this free app, you can buy me a beer by making a Donation

  • mazumazu Posts: 26Members, Plex Pass Plex Pass

    thanks Orca

    ill keep working on this and ill check the logs to see what i can find...

    ill let you know what i find or if i have any more questions.

  • mazumazu Posts: 26Members, Plex Pass Plex Pass

    well ive tried all of the options and settings weve discussed and nothing is working.. i cant get remote quality to work

    the only option that is working is auto transcode, but this makes the video pretty blurry .. :(

    im out of ideas.

Sign In or Register to comment.