If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Play Music on Echo Dot

gapmountaingapmountain Posts: 12Members ✭✭

Big question, can plex play music on the Echo Dot? I see conflicting advice. From a news article I see this:
"If you have an Amazon Echo, Echo Dot, Amazon Fire TV, or other Alexa-enabled device, you can now use your voice to play your Plex music, movies, and TV shows."
Yet is see forum questions that says it can;t.

I have everything set up and linked and logged with plex and my echo dot. It understands commands, links to my library etc. etc. etc. The only thing it won't do is actually play any music. When I ask alexa what players I have it tells me I only have 1 which was set to default. That player is Plex on Chrome. If plex does indeed play music on the echo dot, how do I set it up as a player?

By the way, I don't really want to play music on the Dot, just use it as a bluetooth device to stream music to an old analog stereo.

Tagged:

Best Answers

  • gapmountaingapmountain Posts: 12Members ✭✭
    Accepted Answer

    Hi Cardy,
    I have given up for the time being.

    I found other threads on this issue which dates back to November. Here is what I found.

    It seems like the Plex developers added the Alexa skill to play music on Echo devices back in early November. Up until then music could not be played on the Dot (not sure about other Alexa enabled devices). For some people it works just fine but for others it either displays the symptoms we experience or it actually starts playing then stops after a short period of time.

    Several error logs and other bits of information were sent to the Plex people. As of today, nothing has been forthcoming as to a solution. The problem seems to be some type of router problem. If you have a router (or router settings, not sure which) that works then you are golden. If not, then you get the problems we are experiencing and no amount of jigging around is going to fix it until Plex comes up with a fix for the Alexa skill.

    Since I was told that the music will play on the Alexa device where the command was issued you have to believe that somewhere in the Plex skill is some coding that provides for this to happen. I believe that is where the problem is.

    I have an issue with the Plex people on this board. There is obviously a problem with Alexa and Plex integration, as can be seen by the number of people asking about this problem. It would be nice to have received a reply back a few days ago that indicated as such and saved days to resetting and restarting things trying to troubleshoot a problem that is in the underlying software. You know, just tell me, "Hey, we got a software problem. Bear with us while we try to resolve it".

  • gapmountaingapmountain Posts: 12Members ✭✭
    Accepted Answer

    @cardy said:
    @gapmountain I have seen the same behaviour which is in the logs I submitted. The IP trying to actually play whats requested seems to be any other active plex client (in my case web browser sessions, fire tv stick or my phone)

    Update:
    I was having problems with my DSL connection and after talking to my ISP (Fairpoint), they sent me a new router. The new router has a lot more flexibility, so I had a chance to play around with the settings.

    I tried the basic Plex setup and same issue, no music. I then went in and set up port forwarding. When setting up the NAT entry I noticed there was an option called "NAT Loopback". I remembered reading in another thread that they thought the problem had to do with "hairpinning", so I enabled the NAT Loopback.

    Success, everything is working now.

    I'm not sure if the Plex people are working on fixing this or even if it is possible for them to fix it. Your average Joe is not going to want to fool around with router settings in order to use Plex. So, if at all possible, find the NAT Loopback (or similar setting) and enable it on your port forwarding setting.

«1

Answers

  • BigWheelBigWheel Posts: 10,122Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    Yes. if you are playing music and the don't specifically choose another player in command it will play on Echo.

    ( playing back on echo itself it pretty recent update)

    Logs > https://support.plex.tv/articles/201869908-log-files/
  • gapmountaingapmountain Posts: 12Members ✭✭

    OK, so the answer seems to be that the Echo Dot can indeed be set up as a plex player.

    Now the $64K question how to actually get it to work. I have tried numerous commands trying to get the Dot set up as a plex player and nothing seems to work. When I Alexa about the plex players my Dot is not listed. .

    Here are the things I have tried:
    Powered off and on the Dot
    Powered off and on my router
    Restarted my system and the Plex Server
    Removed the Plex skill and added it again.
    Asked Alexa to set the Dot as a Plex Player (no response from Alexa)
    Asked Alexa to ask Plex to play an album on my dot (response: Playing the album).
    However, there is no sound on the Dot. The Plex status is : Nothing is currently being played.

    So, Alexa is obviously linked correctly as it finds the library and the songs I ask it to play. However, nothing plays. No sound. I can play music on my PC and my phone, so the plex server seems to be working correctly.

    Anyone come up with a solution as to how to get the Echo Dot setup as a plex player?

  • BigWheelBigWheel Posts: 10,122Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
    edited December 2017

    You don't need to tell it to play "on" anything when playing music and want it on echo. It will default to that.

    "Alexa tell plex to play X"

    Though it should not matter, what version of server are you running.

    Can you try unlinking then reauthorizing the skill in the Alexa set up.

    Logs > https://support.plex.tv/articles/201869908-log-files/
  • gapmountaingapmountain Posts: 12Members ✭✭

    Plex Version 1.10.1.4602 Check for Updates Up to date

    Yes, as I mentioned in my previous note, I tried removing the Alexa Plex skill and adding it again. In fact I have done that several times, once after restarting the server - still didn't work. once after restarting the router - still didn't work, etc. etc. etc.

    The trouble is, the Echo dot does not show up as a plex player when I ask Alexa what players are available. If you do not specify a player when requesting plex to play a song it defaults to the default player, which in my case is the plex chrome account. Obviously you cannot make the echo dot the default player if the echo dot does not show up in the list.

    Also as I stated before, if I give it this command: "Alexa, ask plex to play on " ..... then Alexa responds "playing . The trouble is, nothing comes out of he speaker. I know Alexa finds the song because when I ask it to play a song that is not in my library Alexa comes back with a message that it couldn't find the song and wants to know if she should play something else.

    There is obviously something wrong with the integration with Alexa somewhere, but dammed if I can figure it out.

    When I originally set up the plex server, to get the remote access to work I had to set port forwarding. Perhaps the problem has something to do with that? Here is what is displayed on plex remote access:

    Fully accessible outside your network
    You can access this server from signed-in Plex apps or in a browser at https://plex.tv/web.
    DISABLE REMOTE ACCESS
    You currently have Remote Access enabled through a manually-specified port. If you wish to disable Remote Access, you will need to remove your manual port forwarding from your router.

  • BigWheelBigWheel Posts: 10,122Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
    edited December 2017

    @hlindquist@gmail.com said:
    Plex Version 1.10.1.4602 Check for Updates Up to date

    The trouble is, the Echo dot does not show up as a plex player when I ask Alexa what players are available.

    It never will. It is hardcoded for music to always play on the echo you are talking to if a another actual Plex player is not specified. you cannot tell it to play on a different echo if you have multiple. (I know that is not what you are trying)

    i am trying to think of what could be causing this. it really sounds like your Echo is using a old version of the skill somehow

    Logs > https://support.plex.tv/articles/201869908-log-files/
  • gapmountaingapmountain Posts: 12Members ✭✭

    I found another thread on this forum with the same problem. Seems to be a common problem for some.

    https://forums.plex.tv/discussion/296231/says-playing-artist-but-instead-closes-and-doesnt-play/p1

    I'll try disabling and enabling the skill again and report back.

  • gapmountaingapmountain Posts: 12Members ✭✭

    I reset my router, disable the plex skill, waited several minutes, then asked "alexa, ask plex to play abbey road". Alexa responded, "Playing the album Abbey Road by the Beatles".

    Same problem, no sound.

  • cardycardy Posts: 20Members, Plex Pass Plex Pass

    Yep I have the exact same problem ask it to play and it goes through the motions with the debugging on the server turned on I can see the search for the music and it even attempting to play (although it always seems to try and send the music to one of my fire tv sticks rather than playing on the echo its self).

    Its a highly frustrating issue !

    Like comments above you ask for a song from plex and alexa says its playing but no sound.

    I have tried disabling the skill and re-authorizing I have also checked the server in debug and can see my request and it trying to do something but always with the wrong client.

  • gapmountaingapmountain Posts: 12Members ✭✭
    Accepted Answer

    Hi Cardy,
    I have given up for the time being.

    I found other threads on this issue which dates back to November. Here is what I found.

    It seems like the Plex developers added the Alexa skill to play music on Echo devices back in early November. Up until then music could not be played on the Dot (not sure about other Alexa enabled devices). For some people it works just fine but for others it either displays the symptoms we experience or it actually starts playing then stops after a short period of time.

    Several error logs and other bits of information were sent to the Plex people. As of today, nothing has been forthcoming as to a solution. The problem seems to be some type of router problem. If you have a router (or router settings, not sure which) that works then you are golden. If not, then you get the problems we are experiencing and no amount of jigging around is going to fix it until Plex comes up with a fix for the Alexa skill.

    Since I was told that the music will play on the Alexa device where the command was issued you have to believe that somewhere in the Plex skill is some coding that provides for this to happen. I believe that is where the problem is.

    I have an issue with the Plex people on this board. There is obviously a problem with Alexa and Plex integration, as can be seen by the number of people asking about this problem. It would be nice to have received a reply back a few days ago that indicated as such and saved days to resetting and restarting things trying to troubleshoot a problem that is in the underlying software. You know, just tell me, "Hey, we got a software problem. Bear with us while we try to resolve it".

  • BigWheelBigWheel Posts: 10,122Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
    edited December 2017

    I am the Plex staff and i am looking into it. it is just hard to nail down an issue we can't actually reproduce on our own devices., the server logs posted in other threads simply don't tell the story of why not working unfortunately.

    Logs > https://support.plex.tv/articles/201869908-log-files/
  • gapmountaingapmountain Posts: 12Members ✭✭

    A quick update on a couple of things I tried.

    I have a DSL connection to Fairpoint using a Westell 7500 router. I noticed a couple of things and thought, hey, maybe this is it.

    I had set up a static route (called port forwarding on my router) and thought it was being used. As I was checking around in my router I noticed that DHCP was still active for my PC. Come to find out I had to flush the cache on my pc and release the IP address to clear that up (ipconfig/flushdns and ipconfig/release). I also noticed that UPnP was still enabled even though I had disabled it on the router. I had to restart the router and clear all the old entries to clear that. After I cleared out everything I removed the Plex skill and added it back. Even after all that I still get the same error (ie Alexa acknowledges my quest and says it is playing my album but nothing comes out of the speaker).

    Even though I still do not have this working I wanted to post this to let people know that even though settings may have been changed, make sure you "free up" the old entries in your router. Otherwise your changes are not being used.

  • mikeselltmikesellt Posts: 1Members

    I am having the same isssue, and I can guarantee it has nothing to do with my router. It shouldn't have anything to do with anyone else's either unless you are trying to play music from your Plex server remotely. If you are on your home network where your Plex server resides, you should be fine unless you have a really complicated setup. I imagine most people using Plex and Alexa at their home don't have a complicated setup. If your Echo can see your Plex server, you should be fine.

    I have also been trying multiple things to resolve this issue, and I have gotten nowhere. Updated firmware/software, linked/unlinked, uninstalled/reinstalled skills, rebooted everything under my roof, etc... no dice.

    If there are any debugging logs from Alexa/echo and Plex which I can send in, I would be glad to do so to help get this issue fixed.

  • cardycardy Posts: 20Members, Plex Pass Plex Pass
    edited December 2017

    @BigWheel

    There seem to be 3 threads which are discussing similar issues:

    Say's playing artist but instead closes and doesn't play

    Can music on my Plex server be played through the Alexa Echo speaker?

    And this thread.

    In the "Say's playing artist but instead closes and doesn't play" thread I sent Vasinator a message on the 15th containing logs of the issue and the file i was trying to play. I'm happy to help diagnose the issue if you let me know what you need.

  • gapmountaingapmountain Posts: 12Members ✭✭

    @mikesellt said:
    I am having the same isssue, and I can guarantee it has nothing to do with my router. It shouldn't have anything to do with anyone else's either unless you are trying to play music from your Plex server remotely. If you are on your home network where your Plex server resides, you should be fine unless you have a really complicated setup. I imagine most people using Plex and Alexa at their home don't have a complicated setup. If your Echo can see your Plex server, you should be fine."

    I agree. Using my cell phone I can see all my albums and play any of them. Of course, I would need to enable the phone app to have them play for more than a minute but I am very hesitant to spend any money on this application if it doesn't work with Alexa, which is what I want. Almost ready to delete the app and try something else. I read that My Media works with Alexa but I haven't tried it yet.

  • gapmountaingapmountain Posts: 12Members ✭✭

    I'm not sure if this means anything, but when I scan the Plex Media Server log file I see IP entries for my server. I also see the IP address of my phone when I request a song to be played, but I don't see any IP address for my Alexa Dot when I request a song even though Alexa confirmed the album I was trying to play.

  • cardycardy Posts: 20Members, Plex Pass Plex Pass

    @gapmountain I have seen the same behaviour which is in the logs I submitted. The IP trying to actually play whats requested seems to be any other active plex client (in my case web browser sessions, fire tv stick or my phone)

  • donb130donb130 Posts: 3Members ✭✭

    i just got an echo spot and tried to link to plex. i have plex linked to 2 firesticks that work fine..the echo spot is linked, but it does not show up as a possible player. the spot says it is playing what i requested, but there is no sound. not sure if spot isn't supported, i am doing something wrong or there is a bug of some sort.

  • cardycardy Posts: 20Members, Plex Pass Plex Pass

    @donb130 There is definately a bug somewhere but since submitting logs I have yet to hear anymore about this being looked at.

  • akj850akj850 Posts: 5Members ✭✭

    @cardy @BigWheel As an additional data point, I installed plex server and the plex skill for Alexa today using a Mac and a Echo Dot (2nd generation). I experienced the same problem. Plex skill easily integrated with the plex server and Alexa agreed to play my album but no sound ever came out, I tried with multiple albums to no avail. It seems that given the reviews of the Alexa skill (and this discussion) this is a common problem. Please let me know if I can provide any details to help track down the bug.!

«1
Sign In or Register to comment.