If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

New release

jwrayjwray Posts: 1,268Members, Plex Pass Plex Pass
Hi,

A new release of the Roku private channel for Plex has just been pushed. Fixes a number of issues:

- Plex server management: allows you to manage a list of servers including adding them manually. Will allow remote servers to be added and implements a fix for those having issues with discovery
- Added fixes for transcoding timing out during playback and pause. Thanks to fugeelama for some very useful debug info there. Hopefully this is the cause, and fix, of the stop after X mins bug.
- Numerous UI fixes, including some great suggestions by samukas

thanks
Jonny
«1

Comments

  • samukassamukas Posts: 215Members, Plex Pass Plex Pass
    edited September 2011
    I really enjoy the UI enhancements, well done! I was also able to add a remote server with success!

    However, weirdly as it is, since the new version was pushed to my Roku, I'm getting frequent craches of the Plex channel immediately after pressing "Play". it starts retrieving and when it's done it crashes.

    I spend all afternoon catching up with a show on Plex (the old version) and it did not happen, now it's happening frequently but randomly, that is, the same file may play at times, and at others it won't. Any one else experiencing the same issue?

    It doesn't seem to be a home-network issue as I experienced this past week... :/

    Plex Setup (not at all up-to-date!):
    Synology DS415+, 713+ and EDS14

    Roku LT and HDMI Streaming Stick

    Amazon FireTV

  • jwrayjwray Posts: 1,268Members, Plex Pass Plex Pass
    Well that sucks - intermittent crash bugs are the worst to figure out. I'll see if I can replicate on my end.

    thanks,
    Jonny

    samukas wrote:

    I really enjoy the UI enhancements, well done! I was also able to add a remote server with success!

    However, weirdly as it is, since the new version was pushed to my Roku, I'm getting frequent craches of the Plex channel immediately after pressing "Play". it starts retrieving and when it's done it crashes.

    I spend all afternoon catching up with a show on Plex (the old version) and it did not happen, now it's happening frequently but randomly, that is, the same file may play at times, and at others it won't. Any one else experiencing the same issue?

    It doesn't seem to be a home-network issue as I experienced this past week... :/
  • samukassamukas Posts: 215Members, Plex Pass Plex Pass
    It doesn't seem to be happening with PMS for Windows. At least so far, all the crashes have been with the OSX build of PMS.

    Plex Setup (not at all up-to-date!):
    Synology DS415+, 713+ and EDS14

    Roku LT and HDMI Streaming Stick

    Amazon FireTV

  • jwrayjwray Posts: 1,268Members, Plex Pass Plex Pass
    samukas wrote:

    It doesn't seem to be happening with PMS for Windows. At least so far, all the crashes have been with the OSX build of PMS.


    Now that's even stranger. Fancy installing via the code and crashing it that way? The telnet terminal logs should tell you where it crashed then.

    thanks
    Jonny
  • fugeelamafugeelama Posts: 5Members, Plex Pass
    Jonny Wray wrote:

    Hi,

    A new release of the Roku private channel for Plex has just been pushed. Fixes a number of issues:

    - Plex server management: allows you to manage a list of servers including adding them manually. Will allow remote servers to be added and implements a fix for those having issues with discovery
    - Added fixes for transcoding timing out during playback and pause. Thanks to fugeelama for some very useful debug info there. Hopefully this is the cause, and fix, of the stop after X mins bug.
    - Numerous UI fixes, including some great suggestions by samukas

    thanks
    Jonny


    I'm famous! Woohoo!!!

    I'm glad I could help. Also no issues/crashes with PMS for Mac with this release (at least for me), and the 6-7 minute timeout bug hasn't appeared since the update.
  • jwrayjwray Posts: 1,268Members, Plex Pass Plex Pass
    That's great news - let's hope it was just that one timeout bug causing the stop after X mins and not others with the same symptoms. Your help was critical since I couldn't replicate - thanks again.

    Jonny

    fugeelama wrote:

    I'm famous! Woohoo!!!

    I'm glad I could help. Also no issues/crashes with PMS for Mac with this release (at least for me), and the 6-7 minute timeout bug hasn't appeared since the update.
  • riconsterriconster Posts: 29Members
    The update ruined Roku for me. Not load the stream. Before everything worked fine. Mac OS X Lion, Plex 0.9.3.4. Roku XDS old generation. Tell us how to get back to the previous version was better. Thank you.
  • samukassamukas Posts: 215Members, Plex Pass Plex Pass
    Hum... could it be the same issue I'm having? What behavior are you seeing exactly?

    I'm also running Lion, by the way. Forgot to mention that earlier.

    Plex Setup (not at all up-to-date!):
    Synology DS415+, 713+ and EDS14

    Roku LT and HDMI Streaming Stick

    Amazon FireTV

  • dnelmsdnelms Posts: 132Members, Plex Pass Plex Pass
    Using Plex on a Windows 7 setup. Updated the Roku client, double checked that all the 2.0 setting was still intact. On my N1000, I started a TV epiosode and it buffered, started and played about 5 seconds. Rather than just going back to the play screen, it started the "loading" screen while rebufferring. Did this 3 times in a row before playing about a 20 second clip, then it started rebuffering again. I did not have time to diagnose anything since I was actually trying to go to sleep (work alarm comes early at 2:50am). But I did change the Roku to Amazon VOD and had no problems streaming, so I do not think it was a a wireless issue causing my problems in Plex. I'm off the next couple of days, so I'll have some time to give it some more run thru's on both the N1000 and the Roku XS.
  • friedflixfriedflix Posts: 2,013Members, Plex Pass Plex Pass
    Awesome Jonny! Remote server addition is HUGE! Great work. Thanks a ton.
  • jwrayjwray Posts: 1,268Members, Plex Pass Plex Pass
    riconster wrote:

    The update ruined Roku for me. Not load the stream. Before everything worked fine. Mac OS X Lion, Plex 0.9.3.4. Roku XDS old generation. Tell us how to get back to the previous version was better. Thank you.


    As far as I know there's no way to go back to another version with the Roku distribution mechanism. What exactly is your behaviour? Most people have better experience with this version

    Jonny
  • jwrayjwray Posts: 1,268Members, Plex Pass Plex Pass
    All: thanks to help from samukas we've managed to identify a bug in some new code I added that implements mark as watched when the video playback gets to 90% (which is what other clients do). If a specific media item/video does not have a duration meta-data item then the channel with throw an exception putting the channel into a weird state.

    Nothing you can do but I've got a fix, it'll be pushed before long and hopefully that's the issue that everyone is encountering.

    thanks
    Jonny
  • brobotbrobot Posts: 8Members
    same problem here. plex on roku worked fine until i installed the update yesterday. i can see all my content, so the server is working but when i play something it just momentarily displays the "retrieving" message & returns the media page and does nothing.

    windows 7 w/ roku 2 hd on wireless network
  • jwrayjwray Posts: 1,268Members, Plex Pass Plex Pass
    brobot wrote:

    same problem here. plex on roku worked fine until i installed the update yesterday. i can see all my content, so the server is working but when i play something it just momentarily displays the "retrieving" message & returns the media page and does nothing.

    windows 7 w/ roku 2 hd on wireless network


    Does it do this every time or only after you have already played something?

    If you try to play multiple times will it sometimes play and sometimes not?

    thanks
    Jonny
  • sstevenson72sstevenson72 Posts: 20Members, Plex Pass Plex Pass
    You know what would be nice, not sure if you are wanting to do this, but create a Plex Roku Client(beta) channel which could be updated and get user inputs prior to updating the main channel. Maybe you already have this, but think it would be great to get feedback before mainstream in case there are problems. Especially with the roku distribution method like you mentioned above.
  • Fins160Fins160 Posts: 34Members
    Just some feedback that I had success watching a movie last night through Plex.

    Running latest PMS on OSX Snow Leopard with default ffmpeg, 3.0 beta wirelessly and new version of Plex channel.

    Quality was outstanding with 720p source.
  • stevej336stevej336 Posts: 14Members, Plex Pass Plex Pass
    edited September 2011
    I just installed the plex channel yesterday when i got my roku2 XS and it was a bit of a pain at first because it wouldn't pick up my plex media server but eventually it did. Im not sure if this is because i have the newest els and it was already fixed but i set the quality to the highest and was able to stream a 1080p mkv over wireless N without any issues at all.

    btw I'm on osx lion if that means anything.
  • brobotbrobot Posts: 8Members
    @jonny wray - the issue seems to be the media itself. after installing your update (mentioned in another thread) i was able to stream pretty much all the media to the roku w/ no problem. the media that did have an issue (retrieving... & then exit out to main screen)were .avi's encoded with the techsmith codec. these avi's streamed to the phone as expected, but not the roku. i winnFF'ed them with mp4 codec & now they stream to the roku fine.
  • jwrayjwray Posts: 1,268Members, Plex Pass Plex Pass
    Glad you sorted out your issue. Odd that the streaming works to the phone but not the roku, but happy you found a work around.

    Jonny

    brobot wrote:

    @jonny wray - the issue seems to be the media itself. after installing your update (mentioned in another thread) i was able to stream pretty much all the media to the roku w/ no problem. the media that did have an issue (retrieving... & then exit out to main screen)were .avi's encoded with the techsmith codec. these avi's streamed to the phone as expected, but not the roku. i winnFF'ed them with mp4 codec & now they stream to the roku fine.
  • kdawgkdawg Posts: 31Members, Plex Pass Plex Pass
    edited September 2011
    I've been having problems with remote servers. See here:
    http://forums.plexapp.com/index.php/topic/30279-roku-wan-support/

    Anyone have any tips? Security has been turned off. I've tried the Roku 2 and Roku 1 XDS. Both wired and wireless. I appear to be running the latest release version 1.4. I have firmware 2.9 on the Roku. Port forwarding works for other applications on my network so I'm sure it's set properly. Remote PMS works on my iPhone as well.

    Anyone, anyone?
«1
Sign In or Register to comment.