If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Error: Music (MP3) in folders only playing the first track

bridjeebridjee Posts: 39Members, Plex Pass Plex Pass

Hi Guys,
Have several Samsung TV's and only seeing this behaviour on the two J series TV's, 2015 JU7500 and J5500series. What I am seeing is that some folders (or most) will play all the tracks within the folder but some only play the first track. This only happens on this TV , not on the web browser and not on the F6400 (2013). The TV when you select shuffle or play on the folders that do not work shows track 1/1 rather then the 1/total number.

  • checked the tags etc and folder naming and all looks to follow the same standard, but happy to try ideas
  • Tried setting up the two different library types, Plex pass and standard library with the same unexpected behaviour.
  • The music plays through the native Samsung music player on the same set and it works fine.
  • I have set up several playlists that read from the folder and they work well. But don't want to set up playlists for every folder or album I have.
  • I have reset the the app, reset smart hub etc on the TV, still no luck.
  • If I select a different song to start on it will play that song but again only that song.

Any ideas?

Appreciate any help you may be able to give.

Answers

  • OrcaOrca Plex for Samsung Developer Posts: 7,483Members, Plex Pass, Plex Ninja Plex Ninja

    Which version of the app are you using on the TVs?
    Can you enable "Send debug to PMS" and then reproduce the problem and attached the "Plex Media server.log" here?

    Have you checked if your answer might be in the User Manual?
    My Samsung environment:

    2010 BD-C5500 Blu-Ray,
    2011 UE46D7000 LED-TV,

    2012 BD-ES6000 Blu-Ray,

    2014 UE55HU8500L UHD LED TV

    If you enjoy this free app, you can buy me a beer by making a Donation

  • bridjeebridjee Posts: 39Members, Plex Pass Plex Pass

    Thanks Orca,
    The app version is 2.009 and the PMS version is 1.10.1.4602. I have attached the log files. My libraries are in the middle of updating as I deleted and recreated the libraries to see if it was an issue with the library, so not sure if that will make it harder to look through.

    Thanks Again

  • bridjeebridjee Posts: 39Members, Plex Pass Plex Pass

    Sorry just double checked all the TV's the ones is isn't working are are JU7500 app version 2.09 and J5500 ver 2.08. The TV it is working on F6400 is app version 2.05.

    Apologies for that Orca.

  • OrcaOrca Plex for Samsung Developer Posts: 7,483Members, Plex Pass, Plex Ninja Plex Ninja
    edited December 2017

    Hmm, according to the log it only found one item. What happens if you click the Play icon on the left (no shuffle)?
    Does this only happen for "by folder', does it work for an album selection?
    Could you tell me your folder structure on disc? Is it nested multiple folders deep or something?

    [PlayQueue.js] - playQueue id: 609, items queued: 1 current item: 20537

    Have you checked if your answer might be in the User Manual?
    My Samsung environment:

    2010 BD-C5500 Blu-Ray,
    2011 UE46D7000 LED-TV,

    2012 BD-ES6000 Blu-Ray,

    2014 UE55HU8500L UHD LED TV

    If you enjoy this free app, you can buy me a beer by making a Donation

  • bridjeebridjee Posts: 39Members, Plex Pass Plex Pass

    Thanks Orca,

    Yes I only reproduced it once for you, can do it many times if that helps?

    When I click the play icon for any item in the folder the same behaviour it will only play the one item.

    Folder structure is/
    Share root -> Category (Folder) - > Album (folder) -> Track (file)
    e.g. \server\Music - VA -> Soundtracks -> Guardians of the Galaxy -> 10cc - I’m Not in Love (doesn't work)

    So it appears to be random, only several folders seem to be affected, but is consistent for those folders.
    Now paying more attention some of those that appeared to work are only showing some of the song for example the album has 12 songs but is only showing 1/6.

  • bridjeebridjee Posts: 39Members, Plex Pass Plex Pass

    Also made a new library and mapped it to the folder directly to see if that helped. That helped and it will then play shuffle and in order. If I then map only one level above it it will not work on the same folders again. i.e.
    map library to soundtracks, then select folder \guardians of the galaxy\track.... does not work
    map library to guardians of galaxy the shuffle or play works.

    In either case it see all the tracks, but will not play in some folders when there are any levels of nesting. Some folders but not all.

    Hope that helps.

  • OrcaOrca Plex for Samsung Developer Posts: 7,483Members, Plex Pass, Plex Ninja Plex Ninja

    The "by Folder" is a bit fiddly, it's a legacy thing.
    Plex was designed as an automatic indexer and works best when used that way.
    But selecting the album instead of the folder should work, could you try that?

    • On the grid view keep pushing left until the filter menu opens
    • Select All albums
    • Press the yellow button and select G to jump to the albums starting with G
    • Find the Guardian of the galaxy album
    • Select it and press enter
    • Play it from there , that should work

    Have you checked if your answer might be in the User Manual?
    My Samsung environment:

    2010 BD-C5500 Blu-Ray,
    2011 UE46D7000 LED-TV,

    2012 BD-ES6000 Blu-Ray,

    2014 UE55HU8500L UHD LED TV

    If you enjoy this free app, you can buy me a beer by making a Donation

  • bridjeebridjee Posts: 39Members, Plex Pass Plex Pass

    Thanks Orca,
    Happy Holidays to you and your family.
    I agree album view would be a way around it (and preferred). However, The album view never works on any device for me as I changed the albumartist tag to artist tag and apparently Plex uses this instead of just the Albumtitle tag to group albums. You need to change the tag as I did previously because of another bug in Plex. It reads the albumartist title instead of the artist title. So if I want to browse your VA library by artist you cannot, it just groups them under various artists as you can see below.

    I have and many others had numerous posts about this. When you do change the albumartist to artist tag it displays every single individually on the album instead of grouping them. This is also weird behaviour as it finds and matches all the singles in the album, downloads the covers and all the correct info / metadata, but just can't group the album. I got around all this by flattening files, grouping them into folders and changing the tags. So because of simple misread of a metatag it seems that there has been a lot of work arounds instead of fixing the problem.

    The funny thing is that the folder views and plays work on every device except these two samsungs and the older samsung with 2.05 works fine. Is there a way to try 2.05 on a the J series?

    thanks again orca

  • bridjeebridjee Posts: 39Members, Plex Pass Plex Pass

    Hi Orca,
    Any chance of trying an older version or seeing why the 2.05 version works and the 2.09 seems to have some issues?

    appreciate the help,
    Thanks

  • bridjeebridjee Posts: 39Members, Plex Pass Plex Pass

    Hi @Orca,
    Is this in anyway tied to the fact that the meta tags are reading album artist and not artist?
    Thanks

Sign In or Register to comment.