If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Plexamp Win10 - playback stops when seeking, requires restart.

evilmanimanievilmanimani Posts: 27Members, Plex Pass Plex Pass

Basically playback is fine, I can skip tracks & play/pause, however If I try to seek through a track the playback ends and all other controls stop working (skip,pause, play something from queue, etc) until the application is restarted. This line keeps repeating in server.log at the time:

Dec 28, 2017 15:34:34 ERROR - [MPD] Error connecting:Error: This socket is closed

Otherwise, great app, cheers :)

Comments

  • elanelan CTO and Co-founder MauiPosts: 6,978Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    OK, that means that the mpd.exe process is probably crashing. Is it only with certain file types? I can't trivially reproduce.

    instagram @elan // the wife's photography site.
    the Medium page // the dog's twitter feed.

  • evilmanimanievilmanimani Posts: 27Members, Plex Pass Plex Pass

    Seems to affect both FLAC and MP3, but a bit differently; with flac it stops playback immediately and never resumes. With mp3, I was able to seek to a different position with the first track, though it took about 5-10 seconds; then I switched tracks, on the second attempt with the new track it froze but seemed to keep playing the remainder of the track, though I was no longer able to seek, skip etc.

    Looks like it takes more attempts with mp3 to reproduce but I can reproduce the problem very consistently with a flac file.

  • elanelan CTO and Co-founder MauiPosts: 6,978Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    Thanks for sharing! We have others using FLAC internally w/o issues, anything else special about your scenario, e.g. Plex Cloud, remote access, slow access, etc?

    instagram @elan // the wife's photography site.
    the Medium page // the dog's twitter feed.

  • evilmanimanievilmanimani Posts: 27Members, Plex Pass Plex Pass
    edited December 2017

    Currently I have PMS installed on my home PC and it's being remote accessed through Plexamp on a work PC and so is installed to my user appdata folder as I don't have admin on the PC in question, not sure if that narrows things down at all. Music streaming and seeking works great via Plex Web though (without gapless sadly :'( )

  • muikradmuikrad Posts: 30Members, Plex Pass Plex Pass

    I have the same problem. I'm a musician and wanted to try plexamp for practicing, because that seek viz is totally awesome, I can see where the chrous/verses/bridges are, it's more productive. But unfortunately, when you combine seeking, pausing and playing, at some point the whole program just stops playing music and I have to relaunch it... It makes me lose my focus and concentration so I stopped using it for that purpose.

    This is on a win10 machine, plex is running on a linux server, and it's a combination of flac/aac/mp3/ogg/ALAC files.

  • elanelan CTO and Co-founder MauiPosts: 6,978Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    @muikrad ~ sorry about that, I'm sure we'll get it sorted :sweat_smile:

    We haven't been able to reproduce the issue yet on Windows; is this with remote access, local, or both?

    instagram @elan // the wife's photography site.
    the Medium page // the dog's twitter feed.

  • evilmanimanievilmanimani Posts: 27Members, Plex Pass Plex Pass
    edited January 30

    In my case this is via remote access, I haven't had a chance to test local. I've also been testing it a bit more, and it seems to crap out even if I just leave it playing, it doesn't actually appear to be related to seeking.

    I'll queue up a FLAC album and it'll play the first few tracks just fine, then just quits as I've described above, and I always get the same line in the server log:
    ERROR - [MPD] Error connecting:Error: This socket is closed

    This is on the latest version as well.

  • elanelan CTO and Co-founder MauiPosts: 6,978Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    @evilmanimani ~ that log line would seem to indicate an MPD crash. Any chance it's reproducible on a particular track? Also, make sure you try 1.0.2 if you haven't already.

    instagram @elan // the wife's photography site.
    the Medium page // the dog's twitter feed.

  • evilmanimanievilmanimani Posts: 27Members, Plex Pass Plex Pass
    edited February 2

    @elan So, doing some additional testing on 1.0.2, just playing through tracks, or even selecting a new track seems to work fine for the most part, however seeking fails to work for any track I attempt; I tested both FLAC files and 320k MP3s. The player will just hang for a bit, with the seek bar snapping back to the point the track was currently at, then after about 30 seconds it ends playback and kicks be back to the library view; I then can't play anything else until I close and re-open Plexamp, this happens every time regardless of track or filetype.

    These are the lines from the application log prior to be restarting the app though:

    Feb 01, 2018 15:49:39.818 INFO - METRICS: Sending event: client:click to https://analytics.plex.tv
    Feb 01, 2018 15:49:46.444 ERROR - PLAYER: Error issuing request to player Local: /player/timeline/poll?wait=1&includeMetadata=1&commandID=80 read ECONNRESET
    Feb 01, 2018 15:49:46.479 ERROR - PLAYER: Error issuing request to player Local: /player/playback/createPlayQueue?source=fb60d8f2c9498d1b16112d6fc2283fd201fab7f7&uri=library%3A%2F%2Fxxx%2Fdirectory%2F%252Flibrary%252Fmetadata%252F93898%252Fchildren&token=&state=playing&type=audio&protocol=https&address=192.168.0.10&port=32400&machineIdentifier=fb60d8f2c9498d1b16112d6fc2283fd201fab7f7&commandID=79 read ECONNRESET
    Feb 01, 2018 15:49:50.449 INFO - Starting app...

    It's showing the local address of my machine there, not sure if that's somehow relevant, since I'm playing remotely, I can send you full logs if that helps at all. Cheers.

  • elanelan CTO and Co-founder MauiPosts: 6,978Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    @evilmanimani ~ Interesting, from that error it sort of seems like the server process is having issues; anything interesting from the Server.log file in the same directory?

    instagram @elan // the wife's photography site.
    the Medium page // the dog's twitter feed.

  • evilmanimanievilmanimani Posts: 27Members, Plex Pass Plex Pass
    edited February 2

    @elan This is what I'm seeing from around the same timestamp in server.log:

    Feb 01, 2018 15:49:15 DEBUG - GET /player/playback/seekTo?offset=245926.26&commandID=71 200 2 - 0.606 ms
    Feb 01, 2018 15:49:21 DEBUG - GET /player/playback/seekTo?offset=343841.345&commandID=73 200 2 - 0.462 ms
    Feb 01, 2018 15:49:23 DEBUG - GET /player/playback/seekTo?offset=266420.115&commandID=74 200 2 - 0.467 ms
    Feb 01, 2018 15:49:26 DEBUG - GET /player/playback/skipTo?key=%2Flibrary%2Fmetadata%2F93922&playQueueItemID=55259&commandID=75 200 2 - 0.258 ms
    Feb 01, 2018 15:49:26 DEBUG - PlayQueue: Processing SKIP TO KEY
    Feb 01, 2018 15:49:26 DEBUG - METRICS: Ending last track forcefully with status skipped
    Feb 01, 2018 15:49:26 DEBUG - PlayQueue: Play queue: 55259,55260
    Feb 01, 2018 15:49:26 DEBUG - METRICS: Sending event: playback:itemend to https://analytics.plex.tv
    Feb 01, 2018 15:49:36 DEBUG - GET /player/playback/pause?commandID=77 200 2 - 0.556 ms
    Feb 01, 2018 15:49:37 DEBUG - GET /player/playback/play?commandID=78 200 2 - 0.514 ms
    Feb 01, 2018 15:49:39 DEBUG - HTTP: Issuing request to https://xx.xx.xx.xx:8090/playQueues?includeLoudnessRamps=1&uri=library://xxx/directory/%2Flibrary%2Fmetadata%2F93898%2Fchildren&type=audio&commandID=79
    Feb 01, 2018 15:49:39 DEBUG - Audio: Setting album mode parameters with normalize true.
    Feb 01, 2018 15:49:51 DEBUG - DEVICE: Loaded 6 devices.

    Not too sure what would be relevant here.

  • elanelan CTO and Co-founder MauiPosts: 6,978Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    Yeah, nothing obvious there...

    It seems like access to 127.0.0.1:20000 is getting ECONNRESET, and I'm not sure why that would be. Random thought: antivirus software????

    instagram @elan // the wife's photography site.
    the Medium page // the dog's twitter feed.

  • evilmanimanievilmanimani Posts: 27Members, Plex Pass Plex Pass

    Yeah no idea, it's on a work PC, and I've tried it on multiple machines, but presumably they're all using the same security suite, can't exactly turn it off. Not sure if it's possible but I wonder if being able to specify a different port would make a difference, I doubt it, but I can't really think of anything else :(

Sign In or Register to comment.