If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

"Cannot Connect to Server" When Playing MP3 Files only

bridjeebridjee Posts: 85Members, Plex Pass Plex Pass

Posting again to see if there are any options to try here. This is super frustrating and I cannot believe that Plex cannot perform this task or find an answer to this.

When playing music files, whether in playlist or in directory or by artist/album etc I get "cannot connect o server errors" I start playing again and it starts with no troubles. Until it fails again... I have tried rebooting the whole system with no luck.

I have a samsung 7500 series (2015) running from a qnap Ts-451+ with 8MB of ram. The network is GB and I can play UHD TV and Movies from the Qnap through plex with no issues ever. However Plex struggles to play more then 10 songs consecutively. The samsung standard player can play MP3 all day with no issues.

I have seen multiple similar postings with no answers. Is there something here that is missing? A simple setting? I have changed swtiches/ Qnap network config etc. with no luck. Happy to check everything again.

Answers

  • bridjeebridjee Posts: 85Members, Plex Pass Plex Pass

    Hi All,
    Is anybody able to help with the above? Are there any setting to extend time out?

    It only seems to happen when changing to the next song in the list and doesn't matter if shuuffle is on or off, a playlist or album.

    Appreciate any suggestions.

    All the best
    Tony

  • OrcaOrca Plex for Samsung Developer Posts: 7,564Members, Plex Pass, Plex Ninja Plex Ninja

    I wonder if this is maybe a Qnap specific issue. I haven't come across this but I'm running a Synology NAS.
    Have you tried the Qnap forum to see if others have this issue?

    Have you checked if your answer might be in the User Manual?
    My Samsung environment:

    2010 BD-C5500 Blu-Ray,
    2011 UE46D7000 LED-TV,

    2012 BD-ES6000 Blu-Ray,

    2014 UE55HU8500L UHD LED TV

    If you enjoy this free app, you can buy me a beer by making a Donation

  • bridjeebridjee Posts: 85Members, Plex Pass Plex Pass

    Hi Orca, not yet, I'll start a thread over there as well.

    Thanks again.
    Tony

  • bridjeebridjee Posts: 85Members, Plex Pass Plex Pass

    Hi @Orca,
    Just did some testing and it seems that I can run the plex client casting to chromecast with no issues all day. However the limitations of this are your interface is better, and cannot use the TV remote to change songs etc.
    I have posted to QNAP thread with no luck. https://forums.plex.tv/discussion/comment/1596105#Comment_1596105 where I attached the logs.

    It is wierd cause it happens only on music and when the next song is being "loaded" the background art loads and the poster artist name flash up for a second and then it "crashes"

    I checked the health of the all the MP3 files, rebuilt the libraries etc etc

    If you wouldn't mind having a look that would be much appreciated.

    All the best, Bridjee

  • bridjeebridjee Posts: 85Members, Plex Pass Plex Pass

    Hi @Orca
    Do you know any tech support at Plex that can assist? Can you point me in the right direction. This is getting beyond ridiculous and frustrating the hell out of me. The app will only play a few songs some times and the records max is 17 in a row before erroring out.

  • bridjeebridjee Posts: 85Members, Plex Pass Plex Pass

    Hi @Orca,
    Are you running IP6 on your network at all? Still looking for help with no luck on any thread.

  • bridjeebridjee Posts: 85Members, Plex Pass Plex Pass

    Hi @Orca,
    Still having the issues and was just wondering some of the behaviour of the application that may help me troubleshoot this. I have completely turned off IP6 and turned all DNS servers to use google's external servers. This has given some intermittent improvement and it seems I can now get to 20 concurrent songs at once pretty consistently and sometimes even up to 40, so some progress is being made.

    To achieve this I have,
    Uninstalled the server and client many times.
    Optimised databases, analysed libraries
    Experimented with different types of libraries
    Mapped static addresses to every involved device.
    Changed out switches and network cables.
    Error checked every MP3 file and retagged as per recommendations for plex.
    Change the directory structure of music files
    Reripped large amounts of my cd collection.

    Still getting the error though, wouldn't be so bad except shuffling then replays many songs already just heard and doesn't remember the played from the list.

    The behaviour of the error is, bottom left image and info load, background issue loads and then the error message appears, no music from that song is played. So not sure what is happening at that stage but whatever is being called at that point seems to cause the error.

    Again any help appreciated guys.

Sign In or Register to comment.