If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Plusnet and Xbox apps

happyhikerhappyhiker Posts: 17Members ✭✭

Hoping someone can help. I run plex on a nas. I had an asus router configured for opendns which worked, when I configured it to use plusnet dns server it didn't work. Asus router now broken so switched to plusnet hub 1 which does not allow dns editing so back on plusnet dns server, and plex broken again. It works on pc and via rasplex, but any app on PS3 or xbox1 or iPad etc can't find server. I understand these apps connect differently than pc by going out the network or something? Can anyone tell me how I get this to work? I thought maybe port forwarding, but I don't really know what that is. As hub1 and bt hub 5 are the same is this a common problem ? Getting it to work on Xbox one is my main concern rather than tablets and things, if that makes any difference ?


  • MoussaMoussa Posts: 1,636Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    Hi there. Is your Xbox One on the same network as the router? Is the server published correctly and reachable (you can check in the server settings page in Plex Web)?

Sign In or Register to comment.