If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Playback on Samsung UBD-M9500 - Audio Only Transcoding

Hi Everyone,

I've been working on setting up my PLEX server for the first time so I can watch 4k HEVC video files on my new TV. Sadly during this time I found out that my Samsung hardware for both my UBD-M9500 and QN49Q6F dose not support True HD audio playback in direct mode. So any video file that dose have this audio format, will be transcoded for audio only and video will playback direct. The issues I have that it will not stop buffering every second (audio only transcoding, video+audio transcoding works better, but eats resources) . I have change setting with transcoding and check resource usage on my server, which I'm barely using any of it. So I don't understand why this is happening, any help on this matter would be greatly appreciated.

Server:
HP DL380 G6 - 2x Intel Xeon CPU X5650 - 36GB of RAM - Raid SAS x6
OS: VMware ESXI 6.5 (Build7388607)
VM: FreeNAS-11.1 with Plexmediaserver 1.10.1.4602 - 8vCPU/24GB
2x Intel 82571EB Quad NIC/pfSense 2.4.2-RELEASE-p1 Switching

Player:
Samsung UBD-M9500 - Plex 3.1.0 (3.8.0) - Tizen 3.0
Gigbit Hardware - Local Playback Only

Media:

Transcoded Audio Only -

ID : 3
Format : TrueHD
Codec ID : A_TRUEHD
Duration : 1 h 46 min
Bit rate mode : Variable
Bit rate : 4 108 kb/s
Maximum bit rate : 6 483 kb/s
Channel(s) : 8 channels
Channel positions : Front: L C R, Side: L R, Back: L R, LFE
Sampling rate : 48.0 kHz
Frame rate : 1 200.000 FPS (40 SPF)
Compression mode : Lossless
Delay relative to video : -68 ms
Stream size : 3.07 GiB (7%)
Language : English
Default : No
Forced : No

Audio Doesn't Need Transcoding -

Audio #1
ID : 2
Format : DTS
Format/Info : Digital Theater Systems
Format profile : MA / Core
Codec ID : A_DTS
Duration : 2 h 21 min
Bit rate mode : Variable / Constant
Bit rate : 4 998 kb/s / 1 509 kb/s
Channel(s) : 8 channels / 6 channels
Channel positions : Front: L C R, Side: L R, Back: L R, LFE / Front: L C R, Side: L R, LFE
Sampling rate : 48.0 kHz
Frame rate : 93.750 FPS (512 SPF)
Bit depth : 24 bits
Compression mode : Lossless / Lossy
Stream size : 4.94 GiB (10%)
Language : English
Default : Yes
Forced : No

Note: If anyone got better way to handle True HD on Samsung OS or different hardware that support it I'm all ears. Do note, any hardware need to have separate HDMI audio out.

Answers

  • NeiloNeilo Posts: 12Members ✭✭

    Hello, I to have the M9500 and the New 2017 Q7 75" TV From what I'm hearing, neither of these will pass through True HD or DTS-MA both are 8 channel. The Tv ARC will never pass anything more than 5.1, the newer ARCe ( HDMI 2.1) will be able too but this is still a year away on most amplifiers and TV's. although i believe Xbox is available with the new HDMI standard. I think your best bet is to find a media streamer that can pass the audio like the NVIDIA (update 3.3) or wait for the newer HDMI 2.1 to be available. I may be incorrect on this if so, feel free to correct me.

  • starfoxACEFOX@yahoo.comstarfoxACEFOX@yahoo.com Posts: 3Members

    @Neilo said:
    Hello, I to have the M9500 and the New 2017 Q7 75" TV From what I'm hearing, neither of these will pass through True HD or DTS-MA both are 8 channel. The Tv ARC will never pass anything more than 5.1, the newer ARCe ( HDMI 2.1) will be able too but this is still a year away on most amplifiers and TV's. although i believe Xbox is available with the new HDMI standard. I think your best bet is to find a media streamer that can pass the audio like the NVIDIA (update 3.3) or wait for the newer HDMI 2.1 to be available. I may be incorrect on this if so, feel free to correct me.

    Well M9500 will passthrough DTS-MA just fine, base on Samsung SDK their no support for True HD. Which I can understand, but Plex Server dose offer audio only transcoding, but wont stop buffering during the transcoding. It will work fine with video+audio, but that very resources heavy task.

    I do want to clear up that HDMI audio from the M9500 goes into Pioneer Elite SC-25 AV

  • NeiloNeilo Posts: 12Members ✭✭

    After more testing with the Samsung UBD- M9500 i actually got it t pass the True HD/Atmos , The setting on the 4k player was set to bit-stream connected to my Pioneer SC-LX801 in Pure Direct via HDMI. Interesting though, if i started the movie off in True HD in the plex client, the AVR would only see 5.1 if i paused the movie and changed the audio on plex client to AC3 5.1 then back again to true HD 7.1 then the AVR pick up the True HD/Atmos. I've tried this on 10 Different 4k Streams ranging from 28Mbps to 60Mbps 50 GB MKV files and it worked every time. I'm very happy now. :) Try what i did and let me know your results. I'm running the Same version of plex on the m9500 as you are. I will test more later and post my results and the logs.

  • NeiloNeilo Posts: 12Members ✭✭

    What Firmware is loaded on your m9500?

  • starfoxACEFOX@yahoo.comstarfoxACEFOX@yahoo.com Posts: 3Members

    @Neilo said:
    After more testing with the Samsung UBD- M9500 i actually got it t pass the True HD/Atmos , The setting on the 4k player was set to bit-stream connected to my Pioneer SC-LX801 in Pure Direct via HDMI. Interesting though, if i started the movie off in True HD in the plex client, the AVR would only see 5.1 if i paused the movie and changed the audio on plex client to AC3 5.1 then back again to true HD 7.1 then the AVR pick up the True HD/Atmos. I've tried this on 10 Different 4k Streams ranging from 28Mbps to 60Mbps 50 GB MKV files and it worked every time. I'm very happy now. :) Try what i did and let me know your results. I'm running the Same version of plex on the m9500 as you are. I will test more later and post my results and the logs.

    My firmware is 1109, I try what you said and started the movie in AC3 and switch to TrueHD. Must be tricking the player to force direct mode. So big question is, how can I force Direct Play each time with the Plex Server. I'm really glad for the help here, my head was about to blow up from it.

    Thanks

  • NeiloNeilo Posts: 12Members ✭✭

    @starfoxACEFOX@yahoo.com said:

    @Neilo said:
    After more testing with the Samsung UBD- M9500 i actually got it t pass the True HD/Atmos , The setting on the 4k player was set to bit-stream connected to my Pioneer SC-LX801 in Pure Direct via HDMI. Interesting though, if i started the movie off in True HD in the plex client, the AVR would only see 5.1 if i paused the movie and changed the audio on plex client to AC3 5.1 then back again to true HD 7.1 then the AVR pick up the True HD/Atmos. I've tried this on 10 Different 4k Streams ranging from 28Mbps to 60Mbps 50 GB MKV files and it worked every time. I'm very happy now. :) Try what i did and let me know your results. I'm running the Same version of plex on the m9500 as you are. I will test more later and post my results and the logs.

    My firmware is 1109, I try what you said and started the movie in AC3 and switch to TrueHD. Must be tricking the player to force direct mode. So big question is, how can I force Direct Play each time with the Plex Server. I'm really glad for the help here, my head was about to blow up from it.

    Thanks

    How do you know what mode it's in when its playing? Do you see this on the PMS? There is an option in the app on the M9500 for direct play or stream Sorry can't remember what one. Here is a link to the differences between direct play and direct stream.

    https://support.plex.tv/articles/200250387-streaming-media-direct-play-and-direct-stream/

    I think the M9500 does direct Play unless you uncheck the option in the App. I also noted there is an option in the M9500 Settings for 24F on Streaming I have that set to Auto.

  • NeiloNeilo Posts: 12Members ✭✭

    In your picture you posted, where are you seeing that from?

  • NeiloNeilo Posts: 12Members ✭✭

    I checked my PMS while playing a movie and it was showing Direct Play. Make sure to check off Direct play & Direct Stream in the Plex app setting on the M9500.

Sign In or Register to comment.