If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

PMS fails to transcode randomly

jancsicsojancsicso Posts: 10Members, Plex Pass Plex Pass

Hello.

I'm running Plex Media Server version 1.11.0.4666 on headless Debian 9.3 with packages up to date. (kernel 4.9.0-5-amd64).

Whenever I try to play a movie in the Web Player (v. 3.31.1) which requires transcoding it randomly fails to transcode it. I can reproduce the issue with multiple files, it seems that it is not related to bad file encoding. The fail may occur at all length of the movie and it seems to be totally random.

When the playback stops I seek back to play that part again and it will fail to play at the same second. If I seek forward within the buffered area then it will continue to play the movie. If I seek outside the buffered area then back to the problematic part then the server tries to transcode that part again and it succeeds to transcode it and it wont fail.

I will attach the log (DEBUG mode enabled). I have also made a video about the issue. The playback is on the left and the Plex Media Server.log is tailed on the right. Maybe it helps to find the problem if you see the log in real time.

https://youtu.be/wFAlobAsIFo

I have found two errors in the log which concerns me:
WARN - NAT: PMP, got an error: Not Supported by gateway.
ERROR - [Transcoder] [dash @ 0x2115140] Cannot use rename on non file protocol, this may lead to races and temporary partial files

Any help would be much appreciated!

Answers

  • ChuckPAChuckPA Posts: 21,597Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    May I see the XML please?

    Also, did you purge the logs? There should be a lot more there

    Please DISABLE Verbose logging until requested

    Please search before posting

    Primary support forums: Linux, Synology, and QNAP

    Please remember to report back. This benefits others.

    Useful links

     Installation and Basic Setup |  Media Preparation (How to name your media files)  |  Linux Permissions 

     Handling TV Specials | Handling Movie extras  |  Nas Compatibility

     Reporting Plex Server issues | Plex Media Server FAQ | Linux Tips

     

    Other useful guides: Local Subtitles | The Plex "dance" | Synology FAQ | PMS Release Announcements

    Hosts: Fedora, QNAP, Synology, most Linux distros in VM

    No technical support via PM unless offered

    Please remember to mark the appropriate answer(s) which solved your issue.

     
  • jancsicsojancsicso Posts: 10Members, Plex Pass Plex Pass

    What kind of XML?

    Also yes, I have stopped the server, deleted all the logs, started the server (as you can see in the video), then replicated the issue.

  • ChuckPAChuckPA Posts: 21,597Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    Hover over the item, expose the ellipsis (...) then "Get Info"

    It will present "media info". In the lower left will be 'View XML"

    Copy/paste that text in your reply.

    Before you 'Post Comment', highlight all of it and, using the Paragraph formatting at the top of the reply window, Paragraph Format -> Code. You'll see it indent.
    That prevents the forum from 'eating' it. :)

    Please DISABLE Verbose logging until requested

    Please search before posting

    Primary support forums: Linux, Synology, and QNAP

    Please remember to report back. This benefits others.

    Useful links

     Installation and Basic Setup |  Media Preparation (How to name your media files)  |  Linux Permissions 

     Handling TV Specials | Handling Movie extras  |  Nas Compatibility

     Reporting Plex Server issues | Plex Media Server FAQ | Linux Tips

     

    Other useful guides: Local Subtitles | The Plex "dance" | Synology FAQ | PMS Release Announcements

    Hosts: Fedora, QNAP, Synology, most Linux distros in VM

    No technical support via PM unless offered

    Please remember to mark the appropriate answer(s) which solved your issue.

     
  • jancsicsojancsicso Posts: 10Members, Plex Pass Plex Pass
            <MediaContainer size="1" allowSync="1" identifier="com.plexapp.plugins.library" librarySectionID="4" librarySectionTitle="Sorozatok" librarySectionUUID="99ee7ce2-3d94-4946-ab75-0580478d8b06" mediaTagPrefix="/system/bundle/media/flags/" mediaTagVersion="1514439909">
            <Video ratingKey="122562" key="/library/metadata/122562" parentRatingKey="122558" grandparentRatingKey="122536" guid="com.plexapp.agents.thetvdb://73255/1/4?lang=hu" librarySectionTitle="Sorozatok" librarySectionID="4" librarySectionKey="/library/sections/4" type="episode" title="Anyaság" titleSort="Anyasag" grandparentKey="/library/metadata/122536" parentKey="/library/metadata/122558" grandparentTitle="Doktor House" parentTitle="Season 1" contentRating="TV-14" summary="Járvány tör ki a kórház szülészeti osztályán. Az egészségesen világra jött csecsemők néhány óra leforgása alatt válságos állapotba kerülnek. Doktor House szerint valamilyen fertőzésről lehet szó, csak éppen az a rendkívüli, hogy az újszülöttek nem is érintkeztek egymással. De vajon akkor mi okozhatja a betegségüket? Az orvosi csapat keresni kezdi a tűt a szénakazalban, miközben a kétségbeesett igazgatónő a támogatásáról biztosítja House-t. A differenciáldiagnózis felállítása után két fertőzés-fajtára kezdik el az antibiotikumos kezelést, ám a csecsemők állapota romlik. Az orvosok kényes etikai kérdés előtt állnak: mely babánál, mely gyógyszer adagolását szüntessék meg. A mindig hűvös és tárgyilagos Doktor House-t pedig lelkileg nagyon megviselik az események." index="4" parentIndex="1" rating="7.8" viewCount="1" lastViewedAt="1515626279" year="2004" thumb="/library/metadata/122562/thumb/1515549222" art="/library/metadata/122536/art/1515549245" parentThumb="/library/metadata/122558/thumb/1515549245" grandparentThumb="/library/metadata/122536/thumb/1515549245" grandparentArt="/library/metadata/122536/art/1515549245" grandparentTheme="/library/metadata/122536/theme/1515549245" duration="2502400" originallyAvailableAt="2004-12-07" addedAt="1515542020" updatedAt="1515549222">
            <Media videoResolution="sd" id="152634" duration="2502400" bitrate="1162" width="624" height="352" aspectRatio="1.78" audioChannels="2" audioCodec="mp3" videoCodec="mpeg4" container="avi" videoFrameRate="PAL" videoProfile="advanced simple">
            <Part accessible="1" exists="1" id="158485" key="/library/parts/158485/1515541920/file.avi" duration="2502400" file="/mnt/SEAGATE/Sorozatok/House/House.The.Complete.Series.BD-DVDRip.XviD.HUN-MixGRP/House.S01.WS.DVDRip.XviD.Hungarian-TvTiME/doktor.house.s01e04-tvtime.avi" size="363450368" container="avi" videoProfile="advanced simple">
            <Stream id="120958" streamType="1" codec="mpeg4" index="0" bitrate="1024" bitDepth="8" chromaSubsampling="4:2:0" frameRate="25.000" height="352" level="5" profile="advanced simple" refFrames="1" width="624"/>
            <Stream id="120959" streamType="2" selected="1" codec="mp3" index="1" channels="2" bitrate="128" audioChannelLayout="stereo" samplingRate="48000" streamIdentifier="1"/>
            </Part>
            </Media>
            <Director id="43954" filter="director=43954" tag="Newton Thomas Sigel"/>
            <Writer id="43953" filter="writer=43953" tag="Peter Blake (IV)"/>
            <Extras size="0"></Extras>
            </Video>
            </MediaContainer>
    
  • jancsicsojancsicso Posts: 10Members, Plex Pass Plex Pass

    What are these errors?

    WARN - NAT: PMP, got an error: Not Supported by gateway.
    ERROR - [Transcoder] [dash @ 0x2115140] Cannot use rename on non file protocol, this may lead to races and temporary partial files
    
  • jancsicsojancsicso Posts: 10Members, Plex Pass Plex Pass

    So, noone knows what is the problem?

  • ChuckPAChuckPA Posts: 21,597Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    NAT-PMP is because your modem/router is not responding to UPNP and NAT-PMP requests to open a port.

    The transcoder 'error' isn't an error. Dash is a streaming protocol and it knows that. It's falsely reporting. It's been addressed.

    As for the file giving you problems:

    1. Xvid format
    2. AVI container.

    I would like to suggest you perform a test encoding of this and try using it after converting to H.264.

    ffmpeg -i  filename.avi  -c:v h264 -b:v 1500K -c:a copy  outputfilename.mp4
    

    Copy the problem file to a test area, run the above command (editing as required), and put it in place of the AVI file (keep the AVI in your test directory as safe keeping.

    Have PMS Scan your library again and update.

    Now test playback.

    I ask this because AVI files, especially XviD encoded, are very fragile. Re-encoding to H.264 and putting in a MP4 or MKV will correct any damaged values.

    after playback complete and in position. test playback with PMS

    Please DISABLE Verbose logging until requested

    Please search before posting

    Primary support forums: Linux, Synology, and QNAP

    Please remember to report back. This benefits others.

    Useful links

     Installation and Basic Setup |  Media Preparation (How to name your media files)  |  Linux Permissions 

     Handling TV Specials | Handling Movie extras  |  Nas Compatibility

     Reporting Plex Server issues | Plex Media Server FAQ | Linux Tips

     

    Other useful guides: Local Subtitles | The Plex "dance" | Synology FAQ | PMS Release Announcements

    Hosts: Fedora, QNAP, Synology, most Linux distros in VM

    No technical support via PM unless offered

    Please remember to mark the appropriate answer(s) which solved your issue.

     
  • jancsicsojancsicso Posts: 10Members, Plex Pass Plex Pass

    I did what you asked above and the issue disappeared.
    Now I see that the plex transcoder can't transcode this type of file properly.

    But these files were playable without any issue before this "auto convert based on bandwith" feature was forced on us. It can't be turned off (unchecking it in the settings does nothing), also can't change transcoding to a specified bitrate, it jumps back instantly to auto convert. The bitrate drops drastically sometimes even at local area connection (gigabit) and the image becomes blurry.

    This auto convert thing should not be released, at least shouldn't be forced to us. I get the idea, it is a great feature, but it is not tested properly with all file formats...

Sign In or Register to comment.