If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Shows not starting, forcing restart of PMS

bwonishbwonish Posts: 12Members, Plex Pass Plex Pass

I have been having an issue over the past week with devices failing to be able to start a show. This is happening both within my home and remotely. For example, if i open Plex on my Fire TV box within my house on the same wired network, plex opens, shows my content. When i press play on a specific show, a message pops up, "talking to the server", "working" and the icon circles over and over until it times out. This has happened several nights in a row. PMS still appears to be running, can be logged in to, and will sometimes show activity that the device has connected. This error has been seen on fire tv boxes, sticks, iphone 7s, as well as android galaxy s8s.

At this point, the only way to get any device to access content is by restarting Plex Media Server. This has been done through restarting the machine it runs or by forcing PMS to stop through task manager.

My Plex set up has been up and running for a couple years and gets daily use locally and while out of the house. THe PC isn't perfect, but does great 99% of the time. Windows 10, AMD Athlon X4 860k quad core 4.00GHZ, 16 GB Ram, 64 bit, WIndows 10 Insider, Version 1709, OS Build 17046.1000, about 6 TB of content.

I have restarted and have plex streaming a show, but when attempting to get to the Plex Media Server settings on the PC running PMS, i am receiving an error that settings are unavailable.

I am running PMS version 1.10.1.4602. Plex Server crash logs are showing a "Error issuing curl_easy_perform(handle): 28" But no other errors are being logged. I have turned on verbose logging.

If anyone has any ideas on what to look for or where to dig in on the verbose logs, i would appreciate the help.

Answers

  • sa2000sa2000 Posts: 30,972Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    Need to look at logs

    Please make sure debug logging is enabled on the server - settings / Server / General / Show Advanced and check if debug logging is enabled, No need for verbose logging at this stage - so disable it

    Restart the server to get fresh logs created

    When the problem happens, on say iPhone, collect the server logs and iOS app logs
    For server, Settings / Server / Help / Download logs
    For iOS App, Settings / Help & Support / Debugging / Share Debug Data / and select Email to email to yourself

    Attach zip from the iOS app and the downloaded Plex Media Server logs zip and indicate the time of the error - preferably with a screenshot

    If it is happening on Fire TV and not the iPhone app, please see this support article for getting the logs from the app to go with the corresponding server logs
    https://support.plex.tv/articles/201573117-android-android-tv-fire-tv-logs/

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    Please do not send logs by Private Message unless specifically requested to
     
  • bwonishbwonish Posts: 12Members, Plex Pass Plex Pass

    problem just happened again and i have attached the logs. Issue happened right around 9:32 to 9:35 pm). PMS and FireTV Logs are attached.

    I greatly appreciate any help that is available.

    FYI - i posted in a second place, related to photos not uploading to PMS. camera upload starts, says it is synced up, but doesn't transfer any pictures. if i completely restart the process, create a new library, etc, it usually will upload a few pictures before saying everything is synced up (while failing to transfer the pictures). I have gained access to the logs with the info you sent for the iphones, so if any any help can be given to analyze that issue once the first one is handled, i would appreciate that too.

  • sa2000sa2000 Posts: 30,972Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    @bwonish said:
    problem just happened again and i have attached the logs. Issue happened right around 9:32 to 9:35 pm). PMS and FireTV Logs are attached.

    I greatly appreciate any help that is available.

    what was the issue between 21:32 and 21:35 ?
    What I can see is a lot of skipping back on the video

    01-21 21:33:02.448  i: [ExoVideoPlayer] Seeking to 1904411ms
    01-21 21:33:13.208  i: [ExoVideoPlayer] Seeking to 1903342ms
    01-21 21:33:13.522  i: [ExoVideoPlayer] Seeking to 1893342ms
    01-21 21:33:13.577  i: [ExoVideoPlayer] Seeking to 1883342ms
    01-21 21:33:13.756  i: [ExoVideoPlayer] Seeking to 1873342ms
    01-21 21:33:13.956  i: [ExoVideoPlayer] Seeking to 1863342ms
    01-21 21:33:14.117  i: [ExoVideoPlayer] Seeking to 1853342ms
    01-21 21:33:14.334  i: [ExoVideoPlayer] Seeking to 1843342ms
    01-21 21:33:14.580  i: [ExoVideoPlayer] Seeking to 1833342ms
    01-21 21:33:14.811  i: [ExoVideoPlayer] Seeking to 1823342ms
    01-21 21:33:15.003  i: [ExoVideoPlayer] Seeking to 1813342ms
    01-21 21:33:15.175  i: [ExoVideoPlayer] Seeking to 1803342ms
    01-21 21:33:15.736  i: [ExoVideoPlayer] Seeking to 1793397ms
    01-21 21:33:15.938  i: [ExoVideoPlayer] Seeking to 1783397ms
    01-21 21:33:16.108  i: [ExoVideoPlayer] Seeking to 1773397ms
    01-21 21:33:16.318  i: [ExoVideoPlayer] Seeking to 1763397ms
    01-21 21:33:16.532  i: [ExoVideoPlayer] Seeking to 1753397ms
    01-21 21:33:16.742  i: [ExoVideoPlayer] Seeking to 1743397ms
    01-21 21:33:18.039  i: [ExoVideoPlayer] Seeking to 1734220ms
    01-21 21:33:18.265  i: [ExoVideoPlayer] Seeking to 1724220ms
    01-21 21:33:18.510  i: [ExoVideoPlayer] Seeking to 1714220ms
    01-21 21:33:18.726  i: [ExoVideoPlayer] Seeking to 1704220ms
    01-21 21:33:18.893  i: [ExoVideoPlayer] Seeking to 1694220ms
    01-21 21:33:19.116  i: [ExoVideoPlayer] Seeking to 1684220ms
    01-21 21:33:19.519  i: [ExoVideoPlayer] Seeking to 1674220ms
    01-21 21:33:19.728  i: [ExoVideoPlayer] Seeking to 1664220ms
    01-21 21:33:19.942  i: [ExoVideoPlayer] Seeking to 1654220ms
    01-21 21:33:20.201  i: [ExoVideoPlayer] Seeking to 1644220ms
    01-21 21:33:20.411  i: [ExoVideoPlayer] Seeking to 1634220ms
    01-21 21:33:20.621  i: [ExoVideoPlayer] Seeking to 1624220ms
    01-21 21:33:20.786  i: [ExoVideoPlayer] Seeking to 1614220ms
    01-21 21:33:21.072  i: [ExoVideoPlayer] Seeking to 1604220ms
    01-21 21:33:33.501  i: [ExoVideoPlayer] Seeking to 1606196ms
    01-21 21:33:33.715  i: [ExoVideoPlayer] Seeking to 1596196ms
    01-21 21:33:33.934  i: [ExoVideoPlayer] Seeking to 1586196ms
    01-21 21:33:34.137  i: [ExoVideoPlayer] Seeking to 1576196ms
    01-21 21:33:34.490  i: [ExoVideoPlayer] Seeking to 1566196ms
    01-21 21:33:34.665  i: [ExoVideoPlayer] Seeking to 1556196ms
    01-21 21:33:34.916  i: [ExoVideoPlayer] Seeking to 1546196ms
    01-21 21:33:35.090  i: [ExoVideoPlayer] Seeking to 1536196ms
    01-21 21:33:35.298  i: [ExoVideoPlayer] Seeking to 1526196ms
    01-21 21:33:35.473  i: [ExoVideoPlayer] Seeking to 1516196ms
    01-21 21:33:35.680  i: [ExoVideoPlayer] Seeking to 1506196ms
    01-21 21:33:35.891  i: [ExoVideoPlayer] Seeking to 1496196ms
    01-21 21:33:36.123  i: [ExoVideoPlayer] Seeking to 1486196ms
    01-21 21:33:36.336  i: [ExoVideoPlayer] Seeking to 1476196ms
    01-21 21:33:36.556  i: [ExoVideoPlayer] Seeking to 1466196ms
    01-21 21:33:38.698  i: [ExoVideoPlayer] Seeking to 1457815ms
    01-21 21:33:38.939  i: [ExoVideoPlayer] Seeking to 1447815ms
    01-21 21:33:39.125  i: [ExoVideoPlayer] Seeking to 1437833ms
    01-21 21:33:39.400  i: [ExoVideoPlayer] Seeking to 1427833ms
    01-21 21:33:39.774  i: [ExoVideoPlayer] Seeking to 1417833ms
    01-21 21:33:39.984  i: [ExoVideoPlayer] Seeking to 1407833ms
    01-21 21:33:40.818  i: [ExoVideoPlayer] Seeking to 1397944ms
    01-21 21:33:41.070  i: [ExoVideoPlayer] Seeking to 1387944ms
    01-21 21:33:41.319  i: [ExoVideoPlayer] Seeking to 1377944ms
    01-21 21:33:41.529  i: [ExoVideoPlayer] Seeking to 1367944ms
    01-21 21:33:41.783  i: [ExoVideoPlayer] Seeking to 1357944ms
    01-21 21:33:42.033  i: [ExoVideoPlayer] Seeking to 1347944ms
    01-21 21:33:43.036  i: [ExoVideoPlayer] Seeking to 1338386ms
    01-21 21:33:43.239  i: [ExoVideoPlayer] Seeking to 1328386ms
    01-21 21:33:43.481  i: [ExoVideoPlayer] Seeking to 1318386ms
    01-21 21:33:43.731  i: [ExoVideoPlayer] Seeking to 1308386ms
    01-21 21:33:43.983  i: [ExoVideoPlayer] Seeking to 1298386ms
    01-21 21:33:45.381  i: [ExoVideoPlayer] Seeking to 1289311ms
    01-21 21:33:45.590  i: [ExoVideoPlayer] Seeking to 1279311ms
    01-21 21:33:45.741  i: [ExoVideoPlayer] Seeking to 1269311ms
    01-21 21:33:45.926  i: [ExoVideoPlayer] Seeking to 1259311ms
    01-21 21:33:46.300  i: [ExoVideoPlayer] Seeking to 1249311ms
    01-21 21:33:46.466  i: [ExoVideoPlayer] Seeking to 1239311ms
    01-21 21:33:46.641  i: [ExoVideoPlayer] Seeking to 1229311ms
    01-21 21:33:50.997  i: [ExoVideoPlayer] Seeking to 1223260ms
    01-21 21:33:51.256  i: [ExoVideoPlayer] Seeking to 1213286ms
    01-21 21:33:51.425  i: [ExoVideoPlayer] Seeking to 1203286ms
    01-21 21:33:51.598  i: [ExoVideoPlayer] Seeking to 1193286ms
    01-21 21:33:51.869  i: [ExoVideoPlayer] Seeking to 1183286ms
    01-21 21:33:52.044  i: [ExoVideoPlayer] Seeking to 1173286ms
    01-21 21:33:52.195  i: [ExoVideoPlayer] Seeking to 1163286ms
    01-21 21:33:52.414  i: [ExoVideoPlayer] Seeking to 1153286ms
    01-21 21:33:52.586  i: [ExoVideoPlayer] Seeking to 1143286ms
    01-21 21:33:52.817  i: [ExoVideoPlayer] Seeking to 1133286ms
    01-21 21:33:53.022  i: [ExoVideoPlayer] Seeking to 1123286ms
    01-21 21:33:53.210  i: [ExoVideoPlayer] Seeking to 1113286ms
    01-21 21:33:53.429  i: [ExoVideoPlayer] Seeking to 1103286ms
    01-21 21:33:53.603  i: [ExoVideoPlayer] Seeking to 1093286ms
    01-21 21:33:53.822  i: [ExoVideoPlayer] Seeking to 1083286ms
    01-21 21:33:54.043  i: [ExoVideoPlayer] Seeking to 1073286ms
    01-21 21:33:54.293  i: [ExoVideoPlayer] Seeking to 1063286ms
    01-21 21:33:54.443  i: [ExoVideoPlayer] Seeking to 1053286ms
    01-21 21:33:54.628  i: [ExoVideoPlayer] Seeking to 1043286ms
    01-21 21:33:54.865  i: [ExoVideoPlayer] Seeking to 1033286ms
    01-21 21:33:55.082  i: [ExoVideoPlayer] Seeking to 1023286ms
    01-21 21:33:55.301  i: [ExoVideoPlayer] Seeking to 1013286ms
    01-21 21:33:55.520  i: [ExoVideoPlayer] Seeking to 1003286ms
    01-21 21:33:55.697  i: [ExoVideoPlayer] Seeking to 993286ms
    01-21 21:33:55.963  i: [ExoVideoPlayer] Seeking to 983303ms
    01-21 21:33:56.142  i: [ExoVideoPlayer] Seeking to 973303ms
    01-21 21:33:56.303  i: [ExoVideoPlayer] Seeking to 963303ms
    01-21 21:33:56.530  i: [ExoVideoPlayer] Seeking to 953303ms
    01-21 21:33:56.751  i: [ExoVideoPlayer] Seeking to 943303ms
    01-21 21:33:57.006  i: [ExoVideoPlayer] Seeking to 933303ms
    01-21 21:33:57.233  i: [ExoVideoPlayer] Seeking to 923303ms
    01-21 21:33:57.395  i: [ExoVideoPlayer] Seeking to 913303ms
    01-21 21:33:57.656  i: [ExoVideoPlayer] Seeking to 903303ms
    01-21 21:33:57.811  i: [ExoVideoPlayer] Seeking to 893303ms
    

    and with regardless to playback state - this shows no errors and playback reaching the timeline seconds specified

    Jan 21, 2018 21:33:08.485 [16500] DEBUG - Client [68ac422f37f83238-com-plexapp-android] reporting timeline state playing, progress of 1904411/3720557ms for guid=com.plexapp.agents.thetvdb://305288/2/9?lang=en, ratingKey=776113 url=, key=/library/metadata/776113, containerKey=/playQueues/1910, metadataId=776113
    
    Jan 21, 2018 21:33:16.589 [2640] DEBUG - Client [68ac422f37f83238-com-plexapp-android] reporting timeline state playing, progress of 1912507/3720557ms for guid=com.plexapp.agents.thetvdb://305288/2/9?lang=en, ratingKey=776113 url=, key=/library/metadata/776113, containerKey=/playQueues/1910, metadataId=776113
    
    Jan 21, 2018 21:33:23.346 [16500] DEBUG - Client [68ac422f37f83238-com-plexapp-android] reporting timeline state buffering, progress of 1694220/3720557ms for guid=com.plexapp.agents.thetvdb://305288/2/9?lang=en, ratingKey=776113 url=, key=/library/metadata/776113, containerKey=/playQueues/1910, metadataId=776113
    
    Jan 21, 2018 21:33:26.573 [9996] DEBUG - Client [68ac422f37f83238-com-plexapp-android] reporting timeline state playing, progress of 1604980/3720557ms for guid=com.plexapp.agents.thetvdb://305288/2/9?lang=en, ratingKey=776113 url=, key=/library/metadata/776113, containerKey=/playQueues/1910, metadataId=776113
    
    Jan 21, 2018 21:33:36.583 [16500] DEBUG - Client [68ac422f37f83238-com-plexapp-android] reporting timeline state playing, progress of 1614977/3720557ms for guid=com.plexapp.agents.thetvdb://305288/2/9?lang=en, ratingKey=776113 url=, key=/library/metadata/776113, containerKey=/playQueues/1910, metadataId=776113
    
    Jan 21, 2018 21:33:46.596 [2640] DEBUG - Client [68ac422f37f83238-com-plexapp-android] reporting timeline state playing, progress of 1347944/3720557ms for guid=com.plexapp.agents.thetvdb://305288/2/9?lang=en, ratingKey=776113 url=, key=/library/metadata/776113, containerKey=/playQueues/1910, metadataId=776113
    
    Jan 21, 2018 21:33:56.582 [3384] DEBUG - Client [68ac422f37f83238-com-plexapp-android] reporting timeline state playing, progress of 1163286/3720557ms for guid=com.plexapp.agents.thetvdb://305288/2/9?lang=en, ratingKey=776113 url=, key=/library/metadata/776113, containerKey=/playQueues/1910, metadataId=776113
    
    Jan 21, 2018 21:34:06.576 [3384] DEBUG - Client [68ac422f37f83238-com-plexapp-android] reporting timeline state playing, progress of 897391/3720557ms for guid=com.plexapp.agents.thetvdb://305288/2/9?lang=en, ratingKey=776113 url=, key=/library/metadata/776113, containerKey=/playQueues/1910, metadataId=776113
    
    Jan 21, 2018 21:34:16.567 [9648] DEBUG - Client [68ac422f37f83238-com-plexapp-android] reporting timeline state playing, progress of 907387/3720557ms for guid=com.plexapp.agents.thetvdb://305288/2/9?lang=en, ratingKey=776113 url=, key=/library/metadata/776113, containerKey=/playQueues/1910, metadataId=776113
    

    Last being playback at position 907.387 seconds (ie 15 minutes 7 seconds)

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    Please do not send logs by Private Message unless specifically requested to
     
  • bwonishbwonish Posts: 12Members, Plex Pass Plex Pass

    The skipping of the video was as expected. But it was only able to occur after i restarted plex media server.

    The issue i have is i will be on a client, such as the fire tv client i provided the logs for last night. i was able to browse content, select a tv show, and when i clicked play, instead of going in to the show, a pop up shows up "Talking to server" "working". When this pop up shows up, my plex media server is 100% non-responsive. on the PC that runs the PMS, i cannot log in to the PMS. the login page will try to connect, but nothing will load. i have to either restart the PC, or going through Task Manager, kill the plex media server process and then restart it. Connections are immediately restored and playback is perfect (as in the example above). when it is working correctly, once i hit play, instead of seeing the "talking to server" message, the show loads very quickly with the control bar visible under the name of the show. when the issue occurred last night, i turned on logging on the fire tv client, recreated the issue, then restarted PMS and captured the logs.

    On the fire tv logs, this is the only indication of the error (right at the beginning):

    01-18 22:21:05.118 i: [Live] Timeline response didn't contain information about the capture buffer
    01-18 22:21:15.085 i: Fetching [method:GET] http://192.168.2.10:32400/:/timeline?bandwidth=3529&bufferedTime=69&containerKey=/playQueues/1894&duration=3387397&guid=com.plexapp.agents.thetvdb://279536/2/1?lang=en&key=/library/metadata/774160&machineIdentifier=b2075f170186e80b943e1d5fc481903b57661508&playQueueItemID=41867&ratingKey=774160&state=playing&time=3317611&X-Plex-Client-Identifier=68ac422f37f83238-com-plexapp-android&X-Plex-Token=...K5uW
    01-18 22:21:15.107 i: [Live] Timeline response didn't contain information about the capture buffer
    01-18 22:21:25.072 i: Fetching [method:GET] http://192.168.2.10:32400/:/timeline?bandwidth=3529&bufferedTime=59&containerKey=/playQueues/1894&duration=3387397&guid=com.plexapp.agents.thetvdb://279536/2/1?lang=en&key=/library/metadata/774160&machineIdentifier=b2075f170186e80b943e1d5fc481903b57661508&playQueueItemID=41867&ratingKey=774160&state=playing&time=3327606&X-Plex-Client-Identifier=68ac422f37f83238-com-plexapp-android&X-Plex-Token=...K5uW
    01-18 22:21:25.105 i: [Live] Timeline response didn't contain information about the capture buffer
    01-18 22:21:31.697 i: [UserAction] Navigate back.
    01-18 22:21:31.711 i: [TranscodeSession] Stopping...

    the information after this point was after PMS was restarted.

  • sa2000sa2000 Posts: 30,972Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member
    edited January 22

    You mentioned that the issue arose between 21:32 and 21:35 and my feeeback was for that period. You did not say which date and I assumed latest - being 21 Jan

    I need matching logs for the period of time you want me to look at. I understand from your response that the issue was 18th January 22:21 and not 21st January

    I will check this evening, as I am way from my pc now, if the server logs provided do go back to the 18th January

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    Please do not send logs by Private Message unless specifically requested to
     
  • bwonishbwonish Posts: 12Members, Plex Pass Plex Pass

    i apologize for any confusion - in my rush to respond, i copied from the beginning of the firetv log (which i assumed started logging after i turned logging on yesterday after the issue appeared). i didn't recognize the information i copied was from the 18th, instead of the 21st. the issue occurred again yesterday, 1/21, around the same time period (21:32 to 21:35).

    So, the two logs that i uploaded were for the same period of time. in the firetv logs, search for: "01-21 21:23:14.485" this is the first part of yesterday's incident. My wife opened up the app at that time. the actions taken at that time were to go to a show, try to start it. When it failed to start, she notified me. I turned on logging:

    01-21 21:24:44.521 i: [Amazon] Enabling verbose logging

    This appears to be the actual error that is logged:

    01-21 21:26:31.991 i: Time out fetching http://192.168.2.10:32400/playQueues?repeat=0&includeChapters=1&shuffle=0&key=/library/metadata/776113&type=video&uri=library://b6a3441b-32b2-4331-aab9-944ecbede560/item/%2Flibrary%2Fmetadata%2F776103&continuous=0&X-Plex-Token=...K5uW.
    01-21 21:26:31.992 e: [PlayQueueAPIHelperBase] Unable to create play queue
    01-21 21:26:32.024 i: Showing toast: Unable to play media
    01-21 21:31:39.299 i: [FocusService] App focus lost.
    01-21 21:32:22.022 e: [ServerWebSocket] Websocket error
    01-21 21:32:22.043 e: An exception occurred: java.net.SocketException: recvfrom failed: ECONNRESET (Connection reset by peer)
    01-21 21:32:22.061 e: Stacktrace: java.net.SocketException: recvfrom failed: ECONNRESET (Connection reset by peer)
    at libcore.io.IoBridge.maybeThrowAfterRecvfrom(IoBridge.java:592)
    at libcore.io.IoBridge.recvfrom(IoBridge.java:556)
    at java.net.PlainSocketImpl.read(PlainSocketImpl.java:485)
    at java.net.PlainSocketImpl.access$000(PlainSocketImpl.java:37)
    at java.net.PlainSocketImpl$PlainSocketInputStream.read(PlainSocketImpl.java:237)
    at okio.n$2.a(SourceFile:139)
    at okio.a$2.a(SourceFile:211)
    at okio.p.b(SourceFile:71)
    at okio.p.a(SourceFile:64)
    at okio.p.i(SourceFile:77)
    at com.squareup.okhttp.internal.c.c.b(SourceFile:110)
    at com.squareup.okhttp.internal.c.c.a(SourceFile:99)
    at com.squareup.okhttp.internal.c.a.a(SourceFile:97)
    at com.squareup.okhttp.a.b.a(SourceFile:169)
    at com.squareup.okhttp.a.b.a(SourceFile:42)
    at com.squareup.okhttp.a.b$1.a(SourceFile:100)
    at com.squareup.okhttp.k.b(SourceFile:168)
    at com.squareup.okhttp.internal.i.run(SourceFile:33)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1112)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:587)
    at java.lang.Thread.run(Thread.java:818)
    Caused by: android.system.ErrnoException: recvfrom failed: ECONNRESET (Connection reset by peer)
    at libcore.io.Posix.recvfromBytes(Native Method)
    at libcore.io.Posix.recvfrom(Posix.java:186)
    at libcore.io.BlockGuardOs.recvfrom(BlockGuardOs.java:250)
    at libcore.io.IoBridge.recvfrom(IoBridge.java:553)
    ... 19 more

    01-21 21:32:27.716 e: [ServerWebSocket] Websocket error
    01-21 21:32:27.719 e: An exception occurred: java.net.SocketException: recvfrom failed: ECONNRESET (Connection reset by peer)
    01-21 21:32:27.729 e: Stacktrace: java.net.SocketException: recvfrom failed: ECONNRESET (Connection reset by peer)
    at libcore.io.IoBridge.maybeThrowAfterRecvfrom(IoBridge.java:592)
    at libcore.io.IoBridge.recvfrom(IoBridge.java:556)
    at java.net.PlainSocketImpl.read(PlainSocketImpl.java:485)
    at java.net.PlainSocketImpl.access$000(PlainSocketImpl.java:37)
    at java.net.PlainSocketImpl$PlainSocketInputStream.read(PlainSocketImpl.java:237)
    at okio.n$2.a(SourceFile:139)
    at okio.a$2.a(SourceFile:211)
    at okio.p.a(SourceFile:306)
    at okio.p.a(SourceFile:300)
    at okio.p.s(SourceFile:196)
    at com.squareup.okhttp.internal.http.g.g(SourceFile:191)
    at com.squareup.okhttp.internal.http.r.b(SourceFile:79)
    at com.squareup.okhttp.internal.http.o.n(SourceFile:909)
    at com.squareup.okhttp.internal.http.o.i(SourceFile:745)
    at com.squareup.okhttp.i.a(SourceFile:277)
    at com.squareup.okhttp.j.a(SourceFile:234)
    at com.squareup.okhttp.i.a(SourceFile:196)
    at com.squareup.okhttp.i.a(SourceFile:34)
    at com.squareup.okhttp.k.b(SourceFile:162)
    at com.squareup.okhttp.internal.i.run(SourceFile:33)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1112)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:587)
    at java.lang.Thread.run(Thread.java:818)
    Caused by: android.system.ErrnoException: recvfrom failed: ECONNRESET (Connection reset by peer)
    at libcore.io.Posix.recvfromBytes(Native Method)
    at libcore.io.Posix.recvfrom(Posix.java:186)
    at libcore.io.BlockGuardOs.recvfrom(BlockGuardOs.java:250)
    at libcore.io.IoBridge.recvfrom(IoBridge.java:553)
    ... 21 more

    Hopefully this info will make it easier to identify the issue on the client and server equivalent. Again, my apologies for pasting the wrong log info earlier.

  • ArmoredCavalryArmoredCavalry Posts: 18Members, Plex Pass Plex Pass
    edited January 22

    I am having the exact same issue! The timeout is occurring on the network call to "playQueues" endpoint. Nothing except rebooting the Plex Server process will fix it and allow me to watching video again, very annoying... This only started happening in the last few days I believe.

    I noticed the issue also affects Live TV viewing, the "tune" endpoint times out when trying to start a stream. So, I believe whatever is hanging on the server is the common piece between "playQueues" and "tune" endpoints. Perhaps it can't start the transcoder process properly?

    I'm on Windows Server 2012 R2, and the media is located on Stablebit Drive Pool partition. Not sure if either of those is related, as Plex itself I don't think has updated recently, so I feel like it must be something else that changed.... Either that or perhaps something w/ the Plex main servers? Let me know if you find anything out @bwonish , I will do the same.

  • ArmoredCavalryArmoredCavalry Posts: 18Members, Plex Pass Plex Pass

    Another update on this. Along with not being able to start a video, there is also a timeout whenever you try to mark an item as watched/unwatched. So, perhaps the root issue is somehow related to setting progress on media?

    Again, a reboot seems to fix, but only for a very short time.

  • sa2000sa2000 Posts: 30,972Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member
    edited January 23

    @bwonish said:
    i apologize for any confusion - in my rush to respond, i copied from the beginning of the firetv log (which i assumed started logging after i turned logging on yesterday after the issue appeared). i didn't recognize the information i copied was from the 18th, instead of the 21st. the issue occurred again yesterday, 1/21, around the same time period (21:32 to 21:35).

    So, the two logs that i uploaded were for the same period of time. in the firetv logs, search for: "01-21 21:23:14.485" this is the first part of yesterday's incident. My wife opened up the app at that time. the actions taken at that time were to go to a show, try to start it. When it failed to start, she notified me. I turned on logging:

    That is good info - thank you

    It is a problem that has been seen recently where some requests hang. The problem actually started at 19:44:23 on 21st January. I have already referred it to the development team for investigation

    It is the same issue as on this forum topic
    http://forums.plex.tv/discussion/303474/media-server-crashing-and-hanging

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    Please do not send logs by Private Message unless specifically requested to
     
  • sa2000sa2000 Posts: 30,972Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    @ArmoredCavalry said:
    Another update on this. Along with not being able to start a video, there is also a timeout whenever you try to mark an item as watched/unwatched. So, perhaps the root issue is somehow related to setting progress on media?

    Again, a reboot seems to fix, but only for a very short time.

    The more evidence I have of the issue the better. So please ensure debug logging is enabled. restart the server anyway to get fresh logs and as soon as the issue arises restart and collect the logs and attach here

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    Please do not send logs by Private Message unless specifically requested to
     
  • azinckazinck Posts: 16Members, Plex Pass Plex Pass

    I'm also seeing this issue. All the descriptions line up perfectly with the symptoms I'm seeing. I've enabled debug logging in the hopes I can catch it in the act. It happened to me last night and again tonight. The client in both cases was a Roku not on my local network. A restart of the Plex server was the only thing I could get to fix it.

    FYI I'm running PMS 1.10.1.4602 on Debian Linux.

  • bwonishbwonish Posts: 12Members, Plex Pass Plex Pass

    sa2000, - interesting note about the time you said the issue appears to start at (19:44:23 on the 21st). This is most likely the time the Fire TV was woken up (i.e. the TV was turned on, but not set to the FireTV input, which is externally powered). So i am assuming the FireTV woke up, was probably still loaded in Plex. So, this could potentially be tied to the client waking back up, but that is the extent of my ability to guess at causes or connections.

    By the way, thank you for the help. its appreciated.

  • azinckazinck Posts: 16Members, Plex Pass Plex Pass

    FWIW, this seems to have magically resolved on its own for me. I haven't really changed anything but where I was seeing this issue daily I haven't seen it in about a week.

  • sa2000sa2000 Posts: 30,972Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    @bwonish

    A build of Plex Media Server with extra diagnostics and potential fix will be available shortly which I would like you to use and try to break !

    I will send you private message with download link when available
    It is a 1.11.2 build

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    Please do not send logs by Private Message unless specifically requested to
     
Sign In or Register to comment.