Hey folks, there is a new Podcast category for forums https://forums.plex.tv/categories/podcasts
If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Movies are played only for a minute

l4t3b0l4t3b0 Posts: 22Members, Plex Pass Plex Pass

Hi

Apple TV 4K
PMS (Windows): 1.10.1.4602
tvOS: 11.2.1
Plex client version: 1.22 (7788)

I'm having a problem if i play any movie, than for the first 45-55 seconds everything is just perfect. Quality is great.
After that movie is not playing any longer and plex client tells me that it tries to connect to my server.
That is indeed true, because in the settings menu that status of my server is either offline, or connecting, depending on the actual state.

I have just upgraded to Apple TV 4K from version Apple TV 4th generation - because of the 24Hz support.

Currently i have 2 Apple TVs. The same server works just perfect with Apple TV 4th generation (same version numbers). Movies are not stopped and the server is "nearby" as it should.

Back to Apple TV 4K.
After reproducing the problem the windows pms cannot be connected for an approximate 3-5 minutes. After that the server is nearby and i can start to play the movie. 1 minute and the server is lost again. Not possible to play any movie with that client.

When the Apple TV 4K reports that the server is unavailable than with my iphone i can browse the pms and play any movie.

I have turned on the "Send logs to plex" on Apple TV 4K about 20-25 minutes ago, so logs should be uploaded to your server.

I would like to emphasize that the windows firewall is turned off and the apple tvs and the pms are running on the same wired network (no wifi used)

Please help me to solve this bug or let me know how i can help you to locate it.

Thanks in advance.

Comments

  • l4t3b0l4t3b0 Posts: 22Members, Plex Pass Plex Pass

    Client logs are uploaded as previously mentioned.
    My server log is attached here.

  • l4t3b0l4t3b0 Posts: 22Members, Plex Pass Plex Pass

    PMS (Windows): 1.11.3.4803
    Plex client version: 1.24

    Still the same :(

    Please fix it!

  • elanelan CTO and Co-founder MauiPosts: 6,981Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    There's nothing in the log which indicates any issues.

    The only thing which comes to mind is some sort of networking issue with the new Apple TV. Have you tried using WiFi vs wired, or using another networking cable?

    instagram @elan // the wife's photography site.
    the Medium page // the dog's twitter feed.

  • chfredricksonchfredrickson Plex iOS Developer Posts: 36Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    Sorry we missed this, could you turn on the send logs to plex setting again and reply back after you've reproduced it again? (https://support.plex.tv/articles/212639598-apple-tv-logs/)

    Also if you have a wireless network I'd be curious if the problem still happened if you switched to it on the Apple TV temporarily. Also if you restart the Apple TV when the problem is happening does it make any difference?

  • l4t3b0l4t3b0 Posts: 22Members, Plex Pass Plex Pass

    Hi chfredrickson

    First of all: thanks for your help in advance.

    I have just reproduced the problem a couple of minutes ago.

    I attach my server logs.
    I have started a film and stopped it on purpose and with the second one i have reproduced the problem.
    This time it took 1:43sec to play on my apple tv 4k.

    I have attached all the logs, but the "Plex Update Service.log".

    Logs.zip 960.1K
  • l4t3b0l4t3b0 Posts: 22Members, Plex Pass Plex Pass

    Please keep in mind, that i have 2 apple tvs at the same time. If you want i can play the same movie with both of them.
    For example if it makes sense to compare the logs with the same server and movie with different version of apple tv.
    I'm a software engineer, so i can help you with more technical tasks to execute on my side to provide you more information.
    I'm motivated to solve this issue. :)

  • l4t3b0l4t3b0 Posts: 22Members, Plex Pass Plex Pass

    With wifi, the same :(
    This time it was only 53secs.

  • l4t3b0l4t3b0 Posts: 22Members, Plex Pass Plex Pass

    Almost 2 weeks have passed.

    Did you have a chance to take a look at the logs?

    Is there anything i can help you with to localize the problem?

  • l4t3b0l4t3b0 Posts: 22Members, Plex Pass Plex Pass

    Almost 2 weeks have passed.

    Did you have a chance to take a look at the logs?

    Is there anything i can help you with to localize the problem?

  • l4t3b0l4t3b0 Posts: 22Members, Plex Pass Plex Pass

    One of the movie to play stops to work at 0:53 sec using wired ethernet.
    No matter how many times i play the movie, always stops at that location.

    The Plex server is running on a Windows machine using an Intel gigabit network card.

    If in the device manager i change the link speed of my network card to 100 Mbit full duplex, than it stops at a different location ... constantly (Somewhere around between 2-3 minutes). Changing the link speed back to gigabit, than 0:53 sec again.

  • l4t3b0l4t3b0 Posts: 22Members, Plex Pass Plex Pass

    I did the following:

    • started the movie to play on my iPhone
    • started the same movie on Apple TV 4K
    • at 0:53 the movie stopped on the Apple TV 4K
    • the iPhone kept playing the movie without any hiccups
    • Apple TV 4K reports that my server is not available (on the server selection screen, it is either connecting, or offline)
    • i have unplugged the Apple TV 4K from the outlet socket and plugged it in again.
    • Apple TV 4K boots and starting the Plex client reports that my server is still not available - altogether an approximate 1 minute has been elapsed since the movie stopped playing
    • iPhone is still playing the movie

    If there is no persistent data used after restarting the client on the Apple TV 4K, than it tells me that something has to do with the server.

    Is it possible that you send me a special version of the plex with a lot of verbose logging that might help you finding the problem?

  • l4t3b0l4t3b0 Posts: 22Members, Plex Pass Plex Pass
    edited March 10

    Problem solved :)

    The reason was because of the firewall of the windows server.

    How on earth is it possible that i have no problem with Apple TV 4th gen and have problem with Apple TV 4K?!?!?

    The reason is easy after checking the firewall logs.

    The network behavior is different between the 2 Apple TV devices.

    The firewall was detecting a SYN Flood attack attempt with 4K and nothing with the 4th gen.

    Because the SYN Flood attack attempt the firewall created automatically a temporary rule to block the Apple TV 4K - therefore the server was not accessible from the Apple TV 4K device but working fine with the iPhone.

Sign In or Register to comment.