Hey folks, there is a new Podcast category for forums https://forums.plex.tv/categories/podcasts
If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

MPG Video fails with Straka(2016) error

mbarylskimbarylski Posts: 574Members, Plex Pass Plex Pass

I tried to play an MPG video today that plays fine on my PC, but it failed immediately with a Straka(2016) error. Not sure why it won't play. Here are the log files.

Best Answers

Answers

  • mbarylskimbarylski Posts: 574Members, Plex Pass Plex Pass

    @Moussa Can you please look at my logs? This failed again today with a different mpg file. I got a straka(2014) and straka(2016) error. These are DVR'd files that have always worked in the past.

  • MoussaMoussa Posts: 1,634Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    Sorry for the late response. Your most recent log shows that there is something fatally wrong with the source file. [13448] ERROR - [Transcoder] [mpeg2video @ 0458ac00] Invalid frame dimensions 0x0. is the transcoder falling over because the file is corrupt. Do these recordings work in another player (like MPV or VLC) on your computer?

  • mbarylskimbarylski Posts: 574Members, Plex Pass Plex Pass

    Yes, they work fine on my computer in VLC. I even tried videos that I know I've played in Plex on Xbox One in the past, and those had the same error. I gave you access to my library if you want to try and reproduce. Try Teen Titans Go - Season 1, Episode 37. That's one that I've played in the past that used to work, but now throws an error.

  • mbarylskimbarylski Posts: 574Members, Plex Pass Plex Pass

    @Moussa One more thing...the videos also work on Android.

  • MoussaMoussa Posts: 1,634Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    Thanks, will investigate.

  • mbarylskimbarylski Posts: 574Members, Plex Pass Plex Pass

    Great, thanks. I tried 2 more players, Web player and Plex Media Player on same PC as PMS, and they both play the video fine with direct play/stream on or off.

  • mbarylskimbarylski Posts: 574Members, Plex Pass Plex Pass

    @Moussa said:
    Right, so the frame size error on the video stream was a red herring. That's usually harmless. The real issue is with the audio track. There's something about it the Xbox One player stack doesn't like and it's throwing an error. It plays back fine on other apps because they're either transcoding the track or the player decoder is more lenient.

    We're going to add a fix for this, which will likely land later this month. Unfortunately there is no way exposed in the app to disable direct stream for audio alone. You can work around this by forcing the audio track to transcode by disabling Allow Direct Play and Allow Direct Stream and lowering the quality to anything below Original Quality.

    Ok, thanks. I already had Direct Play and Direct Stream disabled, but once I switched to a lower quality the video started to play back correctly. I had to drop down to 12 Mbps instead of 20 Mbps, but it's a decent workaround until it's fixed. Thanks for getting back to me with a workaround so quickly.

  • MoussaMoussa Posts: 1,634Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    This issue should be fixed in the latest update.

  • mbarylskimbarylski Posts: 574Members, Plex Pass Plex Pass

    @Moussa said:
    This issue should be fixed in the latest update.

    The latest update didn't fix it for me. Although, I get a Straka(3014) error now.

  • MoussaMoussa Posts: 1,634Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    @mbarylski I tried it again with your problematic fine and it played fine for me post-fix. Mind turning on logging and sending some playback attempt logs?

  • mbarylskimbarylski Posts: 574Members, Plex Pass Plex Pass

    @Moussa said:
    @mbarylski I tried it again with your problematic fine and it played fine for me post-fix. Mind turning on logging and sending some playback attempt logs?

    Yep, PMS logs attached. It works if I have direct play and direct stream enabled, but not if they're turned off. So, I guess it's partially fixed.

    I always keep direct play and direct stream off, because I still have problems with artifacting/banding on high quality videos. I'll test those again too though, and if I'm still getting artifacting/banding I'll start another thread with logs.

  • MoussaMoussa Posts: 1,634Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    Thanks for the logs, will investigate.

  • mbarylskimbarylski Posts: 574Members, Plex Pass Plex Pass

    @Moussa Any status on this issue? Are the devs still investigating?

  • MoussaMoussa Posts: 1,634Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    We're still looking into the issue.

  • mbarylskimbarylski Posts: 574Members, Plex Pass Plex Pass

    Ok, thanks for the update.

  • mbarylskimbarylski Posts: 574Members, Plex Pass Plex Pass

    @Moussa This still isn't working. Can you add it to the known issues list?

  • mbarylskimbarylski Posts: 574Members, Plex Pass Plex Pass

    @Moussa said:
    This is fixed in the next update.

    Awesome, thanks! Look forward to it.

  • mbarylskimbarylski Posts: 574Members, Plex Pass Plex Pass

    @Moussa This is fixed now. Thanks!

Sign In or Register to comment.