If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Plex for Kodi (Android) - missing Settings options

colin5colin5 Posts: 4Members, Plex Pass Plex Pass

I'm using Plex for Kodi on an Android box (Himedia Q10 Pro), and I've had some problems with getting direct play for video and sound. I know there are potential transcoding issues that I need to look into, but one thing I've noticed in my googling is that there are suggestions that there are configuration settings that need to be set. (For example here: https://forums.plex.tv/discussion/274546/4k-file-plays-fine-directly-in-kodi-but-wants-to-transcode-via-plex-addon)

But when I look at the Settings for the PfK add-on, I have a window titled "Settings - Plex" and the ONLY option I have is Debug Logging. This is quite different from the Settings screen shown in the link I quoted. Is there something I need to do in order to see those more detailed Settings?

I should add that on the Himedia box there's a "wrapper" that gets installed for Kodi so that the native Himedia media player is used instead of the Kodi player - it solves some problems but perhaps it's causing some other issue?

My specific problem is that movies seem to play fine, but I don't get Dolby Atmos sound when I play via the PfK add-on. When I look at the Plex server, it tells me that the movie is being played directly and there's no mention of transcoding. When I play the same movie from the Kodi movie selection screen, the movie is fine AND I get Dolby Atmos.


  • fab2000fab2000 Posts: 1Members

    Hi i am in the same situation i have a Himedia Q10 Pro with the plex addon and i have also tried the plex app from the google play store.
    If i play the movies through Kodi it plays the files with the proper audio. Once i use plex it no longer will play in the proper audio only in dolby digital. Also people are talking about the audio option in plex to pass through it doesnt give me that option but plex thats on my LG tv does.
    Anyone have any ideas what the reason could be?

Sign In or Register to comment.