Hey folks, there is a new Podcast category for forums https://forums.plex.tv/categories/podcasts
If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

DNLA Between PMS on Synology to Samsung TV

Major_DanbyMajor_Danby Posts: 5Members ✭✭

Hi,

I'm very new at this but so far haven't been able to find an answer in the forums to this particular issue. I'm currently using Plex as a media server on both my MacBook and on my Synology NAS. The main DNLA client I am using is a Samsung TV.

In order to get the DNLA service working correctly I've had to create a user DNLA profile for the Samsung TV (I say write - I nicked it off GitHub). This has been installed on both the MacBook and the NAS.

The strange thing is that the PMS on my Mac via DNLA to the TV is working perfectly but the same can't be said from my NAS.

Stranger still is that the DNLA from my NAS will play films fine but fails when trying to access TV programs. I'm pretty stumped - any help will be appreciated. Attached is the most recent log file and the DNLA profile I am using.

Cheers all

Answers

  • Major_DanbyMajor_Danby Posts: 5Members ✭✭

    Oops DLNA rather

  • OttoKernerOttoKerner Posts: 30,853Members, Plex Pass, Plex Ninja Plex Ninja
    edited February 2

    As far as I can see this is the default device profile which is included with Plex Server anyway.

    It instructs the Plex Server to transcode if the source file exceeds certain parameters or uses an unsupported codec.
    While your macbook has enough cpu power to perform transcoding,
    your NAS has not enough power.
    This would be an explanation for the differences.

    So please post the Plex XML info of the file you were testing to playback.

    Do you know that there is also a native Plex app for your tv model?
    https://forums.plex.tv/categories/samsung-smart-hub

    Got help? Help others too - by reporting back with your results!
    Have you checked the Documentation before posting a question in the forums?
    Use the SEARCH function before starting a new thread!
    No PMs unless requested, please! Do not use 'verbose' logging
  • Major_DanbyMajor_Danby Posts: 5Members ✭✭

    Hi Otto,

    Thanks for the response, my apologies, I should have been more specific.

    Via the NAS I am not even able to open the TV programs directory, yet I can open the films directory and play movies. We are not talking about an issue with an individual file or transcoding issue. I have the native Plex app (this actually connects fine to PMS on the NAS and plays the required files) but as it’s a relatively old TV the menus are extremely slow so I’d prefer not to use it. Not a show stopper but any means but a great annoyance.

    Incidentally I don’t think it is the default profile as before updating with the attached version I couldn’t get the TV to playback from either server!

    Cheers

  • OttoKernerOttoKerner Posts: 30,853Members, Plex Pass, Plex Ninja Plex Ninja

    @Major_Danby said:
    Via the NAS I am not even able to open the TV programs directory, yet I can open the films directory and play movies.

    Do you happen to have many tv shows?

    I have the native Plex app (this actually connects fine to PMS on the NAS and plays the required files) but as it’s a relatively old TV the menus are extremely slow so I’d prefer not to use it. Not a show stopper but any means but a great annoyance.

    The native Plex app has a preference where you can disable some animations or reduce the resolution of graphics, which should help with that.

    Got help? Help others too - by reporting back with your results!
    Have you checked the Documentation before posting a question in the forums?
    Use the SEARCH function before starting a new thread!
    No PMs unless requested, please! Do not use 'verbose' logging
  • Major_DanbyMajor_Danby Posts: 5Members ✭✭

    No not really, there’s probably 20 episodes in there at the moment. It just seems strange that the film directory is working fine but the TV directory is not...

  • Major_DanbyMajor_Danby Posts: 5Members ✭✭

    Just an update - it now just seems to be the All Shows filter in the TV directory where I am encountering this issue. Viewing by folder appears to work as expected

  • OttoKernerOttoKerner Posts: 30,853Members, Plex Pass, Plex Ninja Plex Ninja
    edited February 2

    Then I assume it has to do with the number of items to be sent to the client.
    There is nothing that can be done about it, I'm afraid.

    Got help? Help others too - by reporting back with your results!
    Have you checked the Documentation before posting a question in the forums?
    Use the SEARCH function before starting a new thread!
    No PMs unless requested, please! Do not use 'verbose' logging
Sign In or Register to comment.