If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Over-Under 3D issues

jdbowerjdbower Posts: 266Members, Plex Pass Plex Pass

Plex VR works great for 2D content and I haven't had any issues with HSBS content either. But I've been playing with some OU files recently and Plex VR seems to appropriately flag them as 3D, I've named them "Title_(Year)_3D-OU.mkv" but when I play them the right eye sees the bottom half of the image and the left sees the top half. Thus far I've only tried three, of them one worked and two did not. Exploring the mkvinfo data for each I don't see any nominal differences, both a working and non-working one show:
| + A track
| + Track number: 1 (track ID for mkvmerge & mkvextract: 0)
| + Track UID: 1
| + Track type: video
| + Lacing flag: 0
| + MinCache: 1
| + Codec ID: V_MPEG4/ISO/AVC
| + CodecPrivate, length 171 (h.264 profile: High @L4.1)
| + Default duration: 41.708ms (23.976 frames/fields per second for a video track)
| + Video track
| + Pixel width: 1920
| + Pixel height: 1080
| + Display width: 1920
| + Display height: 1080

Screens from each also don't show anything weird like FOU vs. HOU, all three look appropriately vertically compressed. There is an offset between top and bottom on two of the three, but the odd man out is not working. Similarly, 2 of the 3 have a large black border, but it's not the third that's working either.

Any other data I can grab for you?

Best Answer


  • jdbowerjdbower Posts: 266Members, Plex Pass Plex Pass
    edited February 2

    I found the problem. Plex was choosing the wrong file, it was happily converting the non-3D version into OU.

    The video itself is fine. I broke it into 50MB chunks and they play normally in other libraries. On a whim thinking it was a transcoding artifact that the split fixed I moved the original to another library (first an "Other Videos" library and then a "Movies" library) and both worked fine as well.

    This could be because the two that failed were 1080p (well, 1920x800 and 1920x796) with 1080p 3D versions while the one that worked was 720p with a 1080p 3D version. I may also just be "lucky" that it was the OU content that this happened with, I'll try to experiment with having a lower or equal resolution SBS content paired with 2D content.

    The workaround is actually necessary anyway, as I found out. I need to split these paired movies into two, this makes them show up as two independent copies and more deterministically selects the proper one (one has a 3D tag in Plex VR, the other doesn't). I need to do this anyway because I don't see any way to force Plex to play the non-3D content from my browser - even the 720p vs. 1080p video selector in the working movie seems broken, so this may be a new bug? Alternatively I can just create a 3D-only library I suppose.

    Certainly looking at the autoplay selection algorithm when there are multiple files and 3D content is probably worthwhile, but I think making sure that the 3D type is represented in the video drop down as a separate entity would be more globally useful, and allow me to watch the 2D version on my computer or phone but cast the 3D version to my TV.

    Thanks, and let me know if I can provide any more information!

  • ManuelPGManuelPG Plex Dev Team Posts: 348Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    Thanks for the thorough report. We are aware that the current situation when it comes to version selection is not ideal. We plan to do something to improve this, but can't offer an ETA at the moment. So as you correctly point out the workaround is to have a separate library for 3D content.

    even the 720p vs. 1080p video selector in the working movie seems broken, so this may be a new bug

    You mean in Plex Web? Maybe something to report in http://forums.plex.tv/categories/plex-web if you're able to reliably reproduce the problem?

  • jdbowerjdbower Posts: 266Members, Plex Pass Plex Pass

    I found it now, I was probably misremembering the UI - rather than a dropdown under the Web UI by Video it's the "..." menu and Play Version. It would still be nice to include something like "3D-SBS" there since that data is now in the database, but this should be across all clients. Would it still be appropriate to request in plex-web, or do you guys own that 3D tag and it would be better to have a client-wide internal message on how to use it?

    In the example below, I took three video samples and named them all "title_(date)_resolution.mp4" and then copied the 1080p version to include a _3D-SBS" - my hope is for one of the 1080p versions to have some indication of 3D content.

    In the mean time, I've created a dedicated 3D library, suboptimal but there isn't much content in it.

  • ManuelPGManuelPG Plex Dev Team Posts: 348Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    Yeah not a bad idea... I'll make sure to raise it internally, thanks!

Sign In or Register to comment.