Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

reFocus for Plex "Back to Blue" Edition

1246728

Comments

  • sandman4suresandman4sure Posts: 788Members, Plex Pass, Plex Ninja Plex Ninja
    edited November 2011
    Duy wrote:

    I certainly have fan art enabled. All my entries have fan art, all movies in the first entry have fan arts (if i re-select the first entry, fan arts will show, but not the very first time when the home screen is loaded...). Some of the tv shows in my 3rd entry don't have fan arts though, but as I said, I have not experienced this with any other skins. Is there anyway we can force Plex to automatically select the first entry?


    Weird… Well I will take a look at it when I have some time. Hopefully it will be an easy fix.

    I will add it to the TODO

    P.S. with default Plex background, do you mean just black or something else?
  • duyvan82duyvan82 Posts: 109Members ✭✭
    the default refocus black/blue background
  • sandman4suresandman4sure Posts: 788Members, Plex Pass, Plex Ninja Plex Ninja
    edited November 2011
    I need a bit more information.

    The first entry in my menu is "Animation"
    That is the one that gets selected when the menu is loaded.

    My Animation section only has a couple of fanart pictures.
    So the first time it gets selected it will be black, after a while I will see first fanart and then black and then second and so on.

    With skins like the default Plex skin, I think the first entry you will see when the menu loads is not a library section but for instance "Search"
    When a non-library section is selected the slideshow will just show all your fanart, but this will never be the case with reFocus (all entries in menu are Library entries)
    (With the default skin I also won't get a proper slideshow with the Animation section)

    So my question is, is your first entry that gets selected populated with a lot of movies with fanart?
    When you select that entry in the default skin, do you see a proper slideshow?
    Does the slideshow start after a while, or doesn't it start at all?

    EDIT:
    I made some small changes to the slideshow so it is the same now as the original skin.
    Only thing different is the entry that gets selected when the menu is loaded.
    I'm afraid I can't do anything to change this…

    If you still have issues, maybe you can use your own slideshow folder?
    Go to www.themoviedb.org, download a lot of great looking fanart pictures, and put them in one folder.
    Set this folder as your slideshow folder in the refocus homescreen settings, and you will have a slideshow with only great looking pictures! :)
  • martzukmartzuk Posts: 514Members, Plex Pass Plex Pass
    I'm not sure if it defeats the object of the 'back to blue' edition but I think it would be great if we could select a custom colour a bit like in Blur, I would love to be able to set it to purple :)
  • martzukmartzuk Posts: 514Members, Plex Pass Plex Pass
    one other thing, I just happened to notice that you've mis-spelled Vietnamese under region
  • sandman4suresandman4sure Posts: 788Members, Plex Pass, Plex Ninja Plex Ninja
    marty wrote:

    one other thing, I just happened to notice that you've mis-spelled Vietnamese under region


    I think those are taken directly from Plex. Is it also misspelled using another skin?
  • sandman4suresandman4sure Posts: 788Members, Plex Pass, Plex Ninja Plex Ninja
    marty wrote:

    I'm not sure if it defeats the object of the 'back to blue' edition but I think it would be great if we could select a custom colour a bit like in Blur, I would love to be able to set it to purple :)



    I'm afraid skin color selection is not possible at the moment. The skin used to have 2 colors for the fonts (yellow and blue) but it doesn't seem to work in Laika.



  • duyvan82duyvan82 Posts: 109Members ✭✭
    @sandman4sure: thanks a lot for looking into this. To answer your question

    if I don't do anything upon launch or after going back from another screen, the black/blue refocus background stays and no fan art is shown (even if the first entry is selected). As soon as I move the cursor down and back up again, fan arts start to show up.

    Another thing I notice is that it only shows fan arts belonging to the selected entry, which is not what it used to be with refocus in Plex 9.3.4.

    An interesting note that fan art slideshow works perfectly with MediaStream skin. As soon as the home screen is shown, the slideshow starts no matter what entry is selected, also if you select anything but your library (i.e. Applications, video channels or music channels) the slideshow actually picks fan arts from all sections. Perhaps you could take a look into MediaStream and implement the same thing? I think it would be best if we could get the old slideshow control from Plex 9.3.4. I really like its implementation.
  • sandman4suresandman4sure Posts: 788Members, Plex Pass, Plex Ninja Plex Ninja
    Duy wrote:

    @sandman4sure: thanks a lot for looking into this. To answer your question

    if I don't do anything upon launch or after going back from another screen, the black/blue refocus background stays and no fan art is shown (even if the first entry is selected). As soon as I move the cursor down and back up again, fan arts start to show up.

    Another thing I notice is that it only shows fan arts belonging to the selected entry, which is not what it used to be with refocus in Plex 9.3.4.

    An interesting note that fan art slideshow works perfectly with MediaStream skin. As soon as the home screen is shown, the slideshow starts no matter what entry is selected, also if you select anything but your library (i.e. Applications, video channels or music channels) the slideshow actually picks fan arts from all sections. Perhaps you could take a look into MediaStream and implement the same thing? I think it would be best if we could get the old slideshow control from Plex 9.3.4. I really like its implementation.



    The old slideshow is not possible anymore. Now (and this is a bit technical) you will have to make a container with id 10101, which will get auto populated by Plex.
    I have no control over what slides it will use. Normally it will take the slides of the selected entry, and if it is not a library entry, it will shuffle through all the slides.

    That is why I think it works with MediaStream, the first entry that gets selected is "Search" (at least, it is here) and so all slides will show.

    I don't see the problem with no slideshow at all here. So I think there is something wrong with the way Plex fills the container.
    What is the name of the first entry in your menu? Is it possible to change the name, so an entry with a lot of movies will be first? (Just to test it out)

  • duyvan82duyvan82 Posts: 109Members ✭✭
    my first entry is indeed the movies section, in which every single one item has fan art :|
    only my last entry that contains some items without fan art.
  • sandman4suresandman4sure Posts: 788Members, Plex Pass, Plex Ninja Plex Ninja
    Duy wrote:

    my first entry is indeed the movies section, in which every single one item has fan art :|
    only my last entry that contains some items without fan art.


    Really weird…
    I'm not sure if I can do anything at the moment, because I can't reproduce it here..
    But I will keep looking.

    Until then, maybe my suggestion about your own folder is something you can use?
  • duyvan82duyvan82 Posts: 109Members ✭✭

    Really weird…
    I'm not sure if I can do anything at the moment, because I can't reproduce it here..
    But I will keep looking.

    Until then, maybe my suggestion about your own folder is something you can use?


    I've attached a short screen recording of the exact behaviour I'm experiencing. Maybe that'll help you diagnose the problem and potentially find a 'cure' for it :)

    Let me know if this is what you're having with your setup (both my Macs experience this).

    Screen capture
  • sandman4suresandman4sure Posts: 788Members, Plex Pass, Plex Ninja Plex Ninja
    Duy wrote:

    I've attached a short screen recording of the exact behaviour I'm experiencing. Maybe that'll help you diagnose the problem and potentially find a 'cure' for it :)

    Let me know if this is what you're having with your setup (both my Macs experience this).

    Screen capture


    Yes, I see, but at the moment I really don't know what the problem can be…
    If I find a workaround I will include it in an update.

    Weird thing is, that here it is working as it should… Any other people experiencing this problem?
  • martzukmartzuk Posts: 514Members, Plex Pass Plex Pass

    I think those are taken directly from Plex. Is it also misspelled using another skin?


    you're right, it is a plex bug
  • martzukmartzuk Posts: 514Members, Plex Pass Plex Pass
    also, I've noticed that the channel 4 logo is quite old, 90's if I remember correctly, here's the new one http://upload.wikimedia.org/wikipedia/en/c/c0/Channel_4_New_Logo.svg

    :)
  • GSXGSX Posts: 133Members ✭✭
    I'm not sure if this has been asked before. If it has sorry.

    Would it be possible to add the ability to customize the fan art for different sections?

    For example in Aeon it's possible to select different folders of fan art for the different main menu sections(movies, tv shows, etc.)

    I think this would be a nice addition to reFocus.
  • marklightmarklight Posts: 1,006Members, Plex Pass Plex Pass
    GSX wrote:

    I'm not sure if this has been asked before. If it has sorry.

    Would it be possible to add the ability to customize the fan art for different sections?

    For example in Aeon it's possible to select different folders of fan art for the different main menu sections(movies, tv shows, etc.)

    I think this would be a nice addition to reFocus.


    You can already do this by going into PMS and setting the fan art for each section there.
  • sandman4suresandman4sure Posts: 788Members, Plex Pass, Plex Ninja Plex Ninja
    marty wrote:

    also, I've noticed that the channel 4 logo is quite old, 90's if I remember correctly, here's the new one http://upload.wikime..._4_New_Logo.svg

    :)



    I take all the logo's from the original reFocus and so I don't have a template to make it from .svg

    I think on the XBMC forum there are some threads about the logo's. Maybe they have already posted a new one there?

  • sandman4suresandman4sure Posts: 788Members, Plex Pass, Plex Ninja Plex Ninja
    GSX wrote:

    I'm not sure if this has been asked before. If it has sorry.

    Would it be possible to add the ability to customize the fan art for different sections?

    For example in Aeon it's possible to select different folders of fan art for the different main menu sections(movies, tv shows, etc.)

    I think this would be a nice addition to reFocus.


    You mean show all the fanart pictures for the movies you have when you select the movie entry in the main menu?
    That already is working if you don't supply your own folder but use the default Plex slideshow


  • fletchnifletchni Posts: 34Members

    Yes, I see, but at the moment I really don't know what the problem can be…
    If I find a workaround I will include it in an update.

    Weird thing is, that here it is working as it should… Any other people experiencing this problem?


    Hi,

    Yes, I am having this precise problem. No slide show until I move the cursor. So, even though Refocus for Laika opens (for met at least) on my "movies" library, I get no slide show. If I then move the cursor to TV Shows the slide show starts, and if I move back to Movies I get Movies slide show art (as it should).

    However, I can also confirm that this is an issue with ALL my skins. So, this suggests that it is not directly a Refocus problem, but a problem with my setup of Plex (although I have really played with all the settings and can't find anything to indicate a problem).

    It was actually your comment earlier, sandman4sure, when you said that in MediaStream, which opens by default on Search, your slide show starts. But mine doesn't… and starts only once I move the cursor to a PMS library.

    So, while not your problem, if you, or anyone else comes across the solution I (and your other correspondent) would be really appreciative. I will post, later, in a general forum about this.

    Nic.
Sign In or Register to comment.