Our forum migration to Discourse is underway and scheduled to last through June 21. During the migration, the forums will be read-only, except for a single temporary forum (contents of which will not be getting transferred). Read our announcement post for more information about the forum migration.
Hey folks, there is a new Podcast category for forums https://forums.plex.tv/categories/podcasts
If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

working FreeNAS installation can't play transcodes after moving to iocage

mrMuppetmrMuppet Members, Plex Pass Posts: 12 Plex Pass

Hi,
i'm using a plex installation for many years in a FreeNAS warden jail. This works without any problem. Due to the fact that FreeNAS (and FreeBSD) changes its jails from warden to iocage i'm trying to move all my jails to that system. I don't have a problem to install my Plexpass via pkg in that jail. Then i move my setup to the new system and adjust the fstab entries.
In a first try saw problems in the log to write in the transcoder folder. So i set /tmp to 777 and the error was gone. The transcoder seems to work: it is writing many files to that folder (as it should). I can play movies that don't need to be trancoded without problems. But when i try to view a movie that has to be transcoded, then the player stopps working with a rotating wheel...
I would put in here some of my log, but i'm not sure which one would help here. Please tell me.
Thanks

Answers

  • mrelceemrelcee Members, Plex Pass Posts: 3 Plex Pass
    edited February 12

    I can report the exact same issue. any playback requiring transcoding Is now impossible for me. I have the same configuration - freenas 11.1u1, iocage jails..

    attached are server logs: https://pastebin.com/hXbvY68Q

    curiously transcoder DOES work for non streaming. I can sync a video to my iOS device it will convert and download for me.. but real time playback Is dead..

  • BillyPrefectBillyPrefect Members, Plex Pass Posts: 109 Plex Pass

    Second, or third, this issue. Went from being able to fire up 4 to 8 transcode streams with warden jail, to not fully able to play one small SD transcode under iocage. I used portsnap to install, thinking that would pick up any weird or odd other files it needed.

    Plex Media Server Plex-Pass.

  • mrMuppetmrMuppet Members, Plex Pass Posts: 12 Plex Pass

    tried it again, exactly as written here: https://forums.freenas.org/index.ph...phones-jackett-ombi-transmission-organizr.58

    And suddenly it worked!

    Gesendet von meinem ONEPLUS A3003 mit Tapatalk

  • BillyPrefectBillyPrefect Members, Plex Pass Posts: 109 Plex Pass

    bad link up there. trying to figure out where you want to point to to see what's there.

    Plex Media Server Plex-Pass.

  • BillyPrefectBillyPrefect Members, Plex Pass Posts: 109 Plex Pass

    I am reading already !! I hate this crippled thing I have running now, useless to me unless I am plugged directly in, and even then some grief with larger files.

    Plex Media Server Plex-Pass.

  • nick.kubiaknick.kubiak Members, Plex Pass Posts: 1 Plex Pass

    This is most likely a permissions issue.

    In short: permissions are assigned via uid; even though each jail creates it's own plex user during the pms installation, the uid's are most likely different (i.e. 1001 vs 1002) and thus the permissions don't transfer. This usually presents itself in permissions by showing the uid where you'd expect to see a username; an associated user can't be found in the system and thus it just shows the assigned uid.

    SSH (or iocage console) into your new iocage jail and check the following locations are accessible by the plex user:

    • Any media files/folders (i.e. most likely your fstab mount points as seen from within the iocage jail)
    • Your plexdata directory (especially if you copied it from your warden jail)

      in a jail this is most likely /usr/local/share/plexdata[-plexpass]

    • Your transcode folder. If you don't set a custom one the default location is in the plexdata directory so not being able to transcode media could be an indication your entire plexdata directory needs to be checked

      /usr/local/share/plexdata[-plexpass]/Plex Media Server/Cache/Transcode

    Here's a similar thread: https://forums.plex.tv/discussion/300476/plex-will-not-play-media-error-shaka1001-network

  • durin42durin42 Members Posts: 4

    Do any of you have this working in a jail? I've been running down mysterious transcode-for-streaming problems today (testing in a pristine VM), and I've determined that transcodes for streaming work fine outside a jail, but will not work at all inside a jail.

  • lordcantidelordcantide Members, Plex Pass Posts: 11 Plex Pass

    I just tried to migrate from warden to iocage. I'm experiencing the same issue. Photos (containing video and pictures) and music seem to work normally immediately. Live TV (HDHR), Movies, and TV libraries seem to have trouble. I sampled removing and adding back a few movies and the problem seemed to be fixed on those files, but the agents are no longer pulling information down for those movies.
    Not sure if this provides any data-points someone can pick up on

Sign In or Register to comment.