Hey folks, there is a new Podcast category for forums https://forums.plex.tv/categories/podcasts
If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

4K HDR Video Artifacts w/ Latest Version of Roku Client

Dale LovingoodDale Lovingood Posts: 32Members, Plex Pass Plex Pass
edited February 8 in Roku

I updated my TCL Roku TV with the latest Roku Plex client (with ScreenGraph functionality) last night. 1080p / low-bitrate direct-play H.265 video seems to play fine as before. However, almost all 4K HDR / high-bitrate direct-play H.265 video now produces extreme artifacts, with multi-colored checker patterns (similar to analog noise) taking over the screen for several seconds periodically, I assume during higher-bitrate scenes. These are all videos that played fine with no artifacts under the previous version. I even rebooted the Roku TV, but the problem persisted. Is anyone else experiencing this with the new client version? Does ScreenGraph usage imply the use of an entirely different rendering engine?

Best Answer

«1

Answers

  • kfarr2009kfarr2009 Posts: 34Members ✭✭

    I updated the plex app on my roku ultra last night and have the exact same problem. 1080p HEVC plays ok but i am having the same issues as you with 4K HDR movies..It seems to be a problem when the audio has to be transcoded. I am getting the picture problems you described when i select the DTS HD 7.1 audio track on a movie (the video is being copied so the HDR will still work and the audio is being transcoded to aac5.1). The same movie plays ok if i select the ac3 5.1 audio track. This is a movie that was playing ok (with the video copying and the DTS 7.1 audio transcoding to aac 5.1) for me a few hour earlier, before i updated the PLEX app. There hasnt been a roku firmware update in the meantime so this is certainly an issue with the new plex roku app. I have tested multiple movies that all worked last week and any 4K HDR movies where the audio needs to be transcoded now break up with checkered colour patterns. I have also tried replacing the HDMI. Everything was fine before i updated the app so would appreciate help to downgrade to the previous version if anyone knows how. Please fix this Plex Team so we can get back to watching 4k HDR as we could previously!!!

  • Dale LovingoodDale Lovingood Posts: 32Members, Plex Pass Plex Pass

    FWIW, I’m definitely seeing the artifacts on 4K HEVC HDR videos with direct play video AND direct play AC-3 audio, not just those involving transcoding. All of my 4K movies have HEVC 10-bit HDR video with a 5.1-ch AC-3 audio track and a stereo AAC audio track, in an M4V container.

  • kfarr2009kfarr2009 Posts: 34Members ✭✭

    Oh ok. It has to be the new Plex app that messed things up. Everything played ok for me before updating as I assume it did for you? Any idea how to downgrade to the previous app or get them to fix this one. Do we just have to wait and hope one of the team see this thread?

  • Dale LovingoodDale Lovingood Posts: 32Members, Plex Pass Plex Pass

    I don’t know of any way to downgrade to the previous version of the Plex app. I feel confident the Plex Roku team will reproduce the issue and figure out the cause. I just hope it’s not strictly a ScreenGraph problem that is entirely in Roku’s hands.

  • kfarr2009kfarr2009 Posts: 34Members ✭✭

    I dont know much about Screen Graph. I just assumed since there was no upgrade to my roku firmware and the only update was to my plex channel that caused 4K HDR to stop playing correctly that it must be a problem with the new Plex channel but maybe i'm wrong?

  • Dale LovingoodDale Lovingood Posts: 32Members, Plex Pass Plex Pass

    Yes, but the Plex client received a major update to use the new Roku ScreenGraph playback engine rather than the previous playback mechanism. It’s described in the Plex release notes.

  • coolhandscoolhands Posts: 9Members, Plex Pass Plex Pass

    I'm having this issue too. All of my HVEC-encoded 4K content is unwatchable.

    This, coupled with the DTS audio sync issue which Roku refuses to address has left me cold on them over the last week or so.

  • Sebastian87Sebastian87 Posts: 22Members, Plex Pass Plex Pass

    I even have these since the latest update with H264 files. The latest update is really making a lot of things worse.

  • gharris3gharris3 Posts: 1Members, Plex Pass Plex Pass

    I'm also having this issue, any 4k movie that needs to transcode audio I have the exact same issues as mentioned above. TCL 55 inch P-series. Everything was working perfectly before the latest PLEX update.

  • jordanclark1993jordanclark1993 Posts: 5Members ✭✭

    Also having the same issue. Hopefully this will get sorted fairly quickly... frustrating not being able to watch any 4K content.

  • Joey BarclayJoey Barclay Posts: 1Members

    Also having this problem, videos will play fine as long as the audio is not being transcoded.

  • coolhandscoolhands Posts: 9Members, Plex Pass Plex Pass

    @Joey Barclay said:
    Also having this problem, videos will play fine as long as the audio is not being transcoded.

    I'm the opposite. If the 4K file is transcoded in any way, it will play fine. Direct Play of 4K HVEC-encoded files are a disaster.

  • coolhandscoolhands Posts: 9Members, Plex Pass Plex Pass
    edited February 21

    So is the Plex tem just ignoring this issue then?

  • kfarr2009kfarr2009 Posts: 34Members ✭✭

    @coolhands said:
    So is the Plex tem just ignoring this issue then?

    seems like they are. 2 weeks now. ridiculous

  • danulldanull Posts: 39Members, Plex Pass Plex Pass

    I'm seeing issues with 4K and artifacts on Roku Ultra too - still nothing?

  • jordanclark1993jordanclark1993 Posts: 5Members ✭✭

    It seems they are looking into this. Check one of the recent replies here: https://forums.plex.tv/discussion/comment/1616451#Comment_1616451

  • jeffcat1949@gmail.comjeffcat1949@gmail.com Posts: 1Members

    I am having this issue as well..

    I noticed that the transcode container option has been removed, and now defaults to HLS, instead of MKV.

    If I use Direct Stream (Forced) the file will playback correctly, because it goes back into MKV.

    I believe this has to do with the File Container HLS being the problem..

    Please bring back the file container selection from 5.1.0

    I am using a roku built in 4k tv.

  • jeffmdjeffmd Posts: 102Members ✭✭

    So glad to see I found this thread quickly. New 4k TV so I am starting to copy some 4k movies onto the plex server. My first test bed is interstellar and it seems like wih the non-english tracks which are AC3.. it plays fine (TCL P series TV) but I switch to the english track in DTS-MA and the video is all corrupted. I am sad to see this is several weeks old and a "new" issue.

  • Dale LovingoodDale Lovingood Posts: 32Members, Plex Pass Plex Pass

    Great news! Looking forward to the update.

«1
Sign In or Register to comment.