If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Performance Issues and "Network Change" logs with Plex on Nighthawk X10

danwestnessdanwestness Posts: 2Members, Plex Pass Plex Pass

So I just bought the Netgear Nighthawk X10 route due to it's ability to run Plex without a computer.
Initial setup went well but the loading of meta data is taking a long time and performce overall is flaky at best in my case. I have done a completely factory reset on the router and reinstalled plex fresh (for the 3rd time now) and am just scaning on one libray that contain 265 movies. IT has been running for 14 hours now and has still only discovered 162 of the movies and is still trying to download metadata for the ones it has discovered. Obviously ridicuous to still be doing this 14 hours later. Playback is also problematic as it shows unavailable half the time when i attempt.

I decided to go poke around the logs and i see all my logs are basically just full of this:
Feb 08, 2018 17:41:11.971 [0xb36e9530] DEBUG - Network change.
Feb 08, 2018 17:41:11.971 [0xb36e9530] DEBUG - NetworkInterface: Notified of network changed (force=0)
Feb 08, 2018 17:41:11.972 [0xb36e9530] DEBUG - Network change notification but nothing changed.
Feb 08, 2018 17:41:11.996 [0xb36e9530] DEBUG - NetworkInterface: received Netlink message len=164, type=RTM_NEWLINK, flags=0x0
Feb 08, 2018 17:41:11.996 [0xb36e9530] DEBUG - NetworkInterface: Netlink information message family=0, type=1, index=24, flags=0x11043, change=0x0
Feb 08, 2018 17:41:11.996 [0xb36e9530] DEBUG - Network change.
Feb 08, 2018 17:41:11.996 [0xb36e9530] DEBUG - NetworkInterface: Notified of network changed (force=0)
Feb 08, 2018 17:41:11.997 [0xb36e9530] DEBUG - Network change notification but nothing changed.
Feb 08, 2018 17:41:11.997 [0xb36e9530] DEBUG - NetworkInterface: received Netlink message len=164, type=RTM_NEWLINK, flags=0x0
Feb 08, 2018 17:41:11.998 [0xb36e9530] DEBUG - NetworkInterface: Netlink information message family=0, type=1, index=24, flags=0x11043, change=0x0
Feb 08, 2018 17:41:11.998 [0xb36e9530] DEBUG - Network change.
Feb 08, 2018 17:41:11.998 [0xb36e9530] DEBUG - NetworkInterface: Notified of network changed (force=0)
Feb 08, 2018 17:41:11.998 [0xb36e9530] DEBUG - Network change notification but nothing changed.
Feb 08, 2018 17:41:12.006 [0xb36e9530] DEBUG - NetworkInterface: received Netlink message len=156, type=RTM_NEWLINK, flags=0x0
Feb 08, 2018 17:41:12.006 [0xb36e9530] DEBUG - NetworkInterface: Netlink information message family=0, type=1, index=24, flags=0x11043, change=0x0

As you can see it is indicating some kind of network change every 500ms or so. Now this makes sense on why it's running so poorly, but i have no real insight into what the "Network Change" is... especially since the entire network is the router itself plugged into a cable modem.

The router itself seems to be operating just fine and no connection issues with any device connected to it for internet, so i'm not thinking it's the router itself, but perhaps something in the plex application itself?

Answers

  • danwestnessdanwestness Posts: 2Members, Plex Pass Plex Pass

    I ended up getting this resolved (sort of).

    I decided to disable debug logging (which was on by default in my install) and then i was able to see in the logs that there were a number of database lock issues. I decided that the flash media (Samsung 128GB USB3.0 Stick) was not doing well keeping up with all the read/writes that occur during the metadata download. I went out and got a Sandisk Extreme Pro SSD USB stick to replace it and now my library scanned in very quick and metadata download is working as expected.

    Although, with debug logging on I am still getting flooded with the Network change messages that still baffle me. I have disabled debug logging since it's obnoxious.

Sign In or Register to comment.