If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

New version of Linux, same old problem of Plex not being able to add files from a mounted ntfs drive

zyggiezyggie Posts: 29Members ✭✭

I've correctly mounted the drive and fstab is edited and testing correctly.
Permissions should specifically permit Plex to access the mount point.
Is there something I'm missing about Ubuntu 17.10?
Is there any difference between chown to plex or plex:plex?

Answers

  • uglymagoouglymagoo Posts: 648Members, Plex Pass Plex Pass

    @zyggie said:
    I've correctly mounted the drive and fstab is edited and testing correctly.
    Permissions should specifically permit Plex to access the mount point.

    I saw that you recommended the guide [1] to another user, so I have to assume you have read it :) Please check the file permissions manually, i.e. open a terminal and look at the output of ls -al <path of one of your movies>.

    Is there something I'm missing about Ubuntu 17.10?

    It's recommended to not use a mount point in /media . Ubuntu handles "internal" disks and "external" NTFS disks differently and only the login user has access to "external" disks, that are mounted at /media.

    Is there any difference between chown to plex or plex:plex?

    The first one only sets the owner while the second one also sets the group.

    [1] https://forums.plex.tv/discussion/279063/using-ext-or-ntfs-drives-internal-or-external-on-linux#latest

    PMS on the Raspberry Pi 2 and 3 / Banana Pi / ODROID / many more : Debian repository for armhf and arm64
    My PMS hardware: RPi 2, NVIDIA Shield TV, Intel Xeon
    My Plex DVR setup: tvheadend, tvhProxy on RPi 2 with Hauppauge WinTV-DualHD; Plex DVR on Shield TV for recordings and Tvheadend Live Channel for live TV

  • zyggiezyggie Posts: 29Members ✭✭

    Thanks for the quick response.

    I created a new mount point in /disks/PLEX
    Edited fstab to that mount point
    All of the directories and files in the mount point have plex plex in the permissions
    Plex still can't see /disks/ when attempting to add files

    BTW the documentation that I originally cited and that you referenced specifically says to use /media/ for ntfs secondary disk mount points.

  • zyggiezyggie Posts: 29Members ✭✭

    I seem to remember using the device location rather than the UUID the last time I set this up in fstab. I'm using UUID now, should I go back to device location?

  • uglymagoouglymagoo Posts: 648Members, Plex Pass Plex Pass
    edited February 11

    @zyggie said:
    Thanks for the quick response.

    BTW the documentation that I originally cited and that you referenced specifically says to use /media/ for ntfs secondary disk mount points.

    The current version of the document uses /disks and discusses the problem with /media.

    I seem to remember using the device location rather than the UUID the last time I set this up in fstab. I'm using UUID now, should I go back to device location?

    UUID is the correct choice.

    Are you sure your Plex server is running as user plex? You might have changed that.

    Edit: Also, I would have assumed that all files on your external NTFS drive are owned by root:root but everybody has read / write permissions. That's the default setting on Linux IF you use the same options in your /etc/fstab entry, that are used in the above mentioned document.

    PMS on the Raspberry Pi 2 and 3 / Banana Pi / ODROID / many more : Debian repository for armhf and arm64
    My PMS hardware: RPi 2, NVIDIA Shield TV, Intel Xeon
    My Plex DVR setup: tvheadend, tvhProxy on RPi 2 with Hauppauge WinTV-DualHD; Plex DVR on Shield TV for recordings and Tvheadend Live Channel for live TV

  • ChuckPAChuckPA Posts: 20,188Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    @zyggie said:
    Thanks for the quick response.

    I created a new mount point in /disks/PLEX
    Edited fstab to that mount point
    All of the directories and files in the mount point have plex plex in the permissions
    Plex still can't see /disks/ when attempting to add files

    BTW the documentation that I originally cited and that you referenced specifically says to use /media/ for ntfs secondary disk mount points.

    Please see the Linux Tips section I created at the top of this forum for issues such as this.

    For your issue, please see: https://forums.plex.tv/discussion/279063/using-ext-or-ntfs-drives-internal-or-external-on-linux

    Please DISABLE Verbose logging until requested

    Please search before posting

    Primary support forums: Linux, Synology, and QNAP

    Please remember to report back. This benefits others.

    Useful links

     Installation and Basic Setup |  Media Preparation (How to name your media files)  |  Linux Permissions 

     Handling TV Specials | Handling Movie extras  |  Nas Compatibility List

     Reporting Plex Server issues | Plex Media Server FAQ | Linux Tips

     

    Other useful guides: Local Subtitles | The Plex "dance" | Synology FAQ | PMS Release Announcements

    Hosts: Fedora, QNAP, Synology, most Linux distros in VM

    No technical support via PM unless offered

    Please remember to mark the appropriate answer(s) which solved your issue.

     
  • zyggiezyggie Posts: 29Members ✭✭

    ??? Here is the screen shot of the current document specifying /media/
    https://www.dropbox.com/s/f1v025h6qfp0g4a/Screenshot 2018-02-11 16.39.56.png?dl=0
    That is the one the I used in the past. It is tagged as being current.

    The document that specifies /disks/ shows many differences in the fstab line.
    The /media/ version specifies:
    UUID /media/mount_name ntfs-3g permissions,auto 0 0
    as opposed to the /disks/ version
    UUID /disks/mount_name ntfs defaults,auto,rw,nofail 0 1

    I've now tried it both ways with no joy.

    To change the user it seems that I would have needed to edit /etc/default/plexmediaserver which I did not.

  • ChuckPAChuckPA Posts: 20,188Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    @zyggie

    Please read and follow the example for using UUID= shown here. https://forums.plex.tv/discussion/279063/using-ext-or-ntfs-drives-internal-or-external-on-linux

    It

    Please DISABLE Verbose logging until requested

    Please search before posting

    Primary support forums: Linux, Synology, and QNAP

    Please remember to report back. This benefits others.

    Useful links

     Installation and Basic Setup |  Media Preparation (How to name your media files)  |  Linux Permissions 

     Handling TV Specials | Handling Movie extras  |  Nas Compatibility List

     Reporting Plex Server issues | Plex Media Server FAQ | Linux Tips

     

    Other useful guides: Local Subtitles | The Plex "dance" | Synology FAQ | PMS Release Announcements

    Hosts: Fedora, QNAP, Synology, most Linux distros in VM

    No technical support via PM unless offered

    Please remember to mark the appropriate answer(s) which solved your issue.

     
  • zyggiezyggie Posts: 29Members ✭✭

    @ChuckPA

    The article you cite is the one from which I quoted the fstab example using the /disks/... mount point.
    The failure for me occurs at your item E. when PMS cannot see the /disks/... mount point.
    The permissions seem correct.

    I seem to remember reading something about making plex a user than is not under my login. Is that a clue?

  • ChuckPAChuckPA Posts: 20,188Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    @zyggie

    That's a big clue :) Did you create an override file and place it in /etc/systemd/system/plexmediaserver.service.d/override.conf ?
    If so:

    What username did you create?
    What group(s) did you assign that username to?
    Lastly, what permissions did you assign to the /disks directory?

    Please DISABLE Verbose logging until requested

    Please search before posting

    Primary support forums: Linux, Synology, and QNAP

    Please remember to report back. This benefits others.

    Useful links

     Installation and Basic Setup |  Media Preparation (How to name your media files)  |  Linux Permissions 

     Handling TV Specials | Handling Movie extras  |  Nas Compatibility List

     Reporting Plex Server issues | Plex Media Server FAQ | Linux Tips

     

    Other useful guides: Local Subtitles | The Plex "dance" | Synology FAQ | PMS Release Announcements

    Hosts: Fedora, QNAP, Synology, most Linux distros in VM

    No technical support via PM unless offered

    Please remember to mark the appropriate answer(s) which solved your issue.

     
  • zyggiezyggie Posts: 29Members ✭✭

    @ChuckPA

    No, I did not create an override file. I didn't in the past either.

    Should I create one now? If so, what needs to be in there?

    I assigned plex:plex as owner of /disks

  • ChuckPAChuckPA Posts: 20,188Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member
    edited February 13

    For /disks, and /disks/mount_name, if only NTFS volumes, put yourself as owner and set directory permission to 755 prior to mounting the volume.

    I have one question about your fstab entry

    UUID /disks/mount_name ntfs defaults,auto,rw,nofail 0 1

    Does this expand, in fstab, to be of the forum

    UUID=ntfs_uuid_value_here /disks/mount_name .... remainder here

    Please DISABLE Verbose logging until requested

    Please search before posting

    Primary support forums: Linux, Synology, and QNAP

    Please remember to report back. This benefits others.

    Useful links

     Installation and Basic Setup |  Media Preparation (How to name your media files)  |  Linux Permissions 

     Handling TV Specials | Handling Movie extras  |  Nas Compatibility List

     Reporting Plex Server issues | Plex Media Server FAQ | Linux Tips

     

    Other useful guides: Local Subtitles | The Plex "dance" | Synology FAQ | PMS Release Announcements

    Hosts: Fedora, QNAP, Synology, most Linux distros in VM

    No technical support via PM unless offered

    Please remember to mark the appropriate answer(s) which solved your issue.

     
  • zyggiezyggie Posts: 29Members ✭✭

    @ChuckPA

    Yes. The first entry is the alphanumeric UUID for the ntfs drive

    So chown /disks/ and, in my case, /disks/PLEX to root:root, unmount, set permissions to 755, mount?

  • zyggiezyggie Posts: 29Members ✭✭

    @ChuckPA

    The permissions for /disks/ is changed from root to my username but the ntfs volume permissions within /disks/ cannot be changed from root

  • ChuckPAChuckPA Posts: 20,188Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    @zyggie said:
    @ChuckPA

    Yes. The first entry is the alphanumeric UUID for the ntfs drive

    So chown /disks/ and, in my case, /disks/PLEX to root:root, unmount, set permissions to 755, mount?

    I personally set them to my username with 755. You will notice below how the mount asserts the exported permissions from the NAS.

    [chuck@lizum /vie.109]$ sudo umount movies
    [chuck@lizum /vie.110]$ ls -la | grep movies
    drwxr-xr-x.   2 chuck chuck  4096 Nov 10 23:34 dvr-movies/
    drwxr-xr-x.   2 chuck chuck  4096 Jun 12  2017 movies/
    drwxr-xr-x.   2 chuck chuck  4096 Jun 12  2017 movies2/
    drwxrwxrwx   31 chuck users  4096 Aug  8  2017 mymovies/
    [chuck@lizum /vie.111]$ sudo mount movies
    [chuck@lizum /vie.112]$ ls -la | grep movies
    drwxr-xr-x.   2 chuck chuck  4096 Nov 10 23:34 dvr-movies/
    drwxrwxrwx  726 chuck users 28672 Feb 15 22:02 movies/
    drwxr-xr-x.   2 chuck chuck  4096 Jun 12  2017 movies2/
    drwxrwxrwx   31 chuck users  4096 Aug  8  2017 mymovies/
    [chuck@lizum /vie.113]$
    

    For you and your local disks (ext format), I would continue to maintain your username as the owner with 755 for directories and 644 for files.

    You're correct, NTFS disks will report as 777. This is because of the mount options which don't restrict anything.

    To verify everything is correct, after all are mounted:

    sudo sh
    chown -R /disks your_username_here
    find /disks -type d -exec chmod 755 {} \;
    find /disks -type f -exec chmod 644 {} \;
    

    Ignore the warnings from the NTFS formatted or change /disks in the find command to be /disks/name-of-ext4-drive(s)

    Please DISABLE Verbose logging until requested

    Please search before posting

    Primary support forums: Linux, Synology, and QNAP

    Please remember to report back. This benefits others.

    Useful links

     Installation and Basic Setup |  Media Preparation (How to name your media files)  |  Linux Permissions 

     Handling TV Specials | Handling Movie extras  |  Nas Compatibility List

     Reporting Plex Server issues | Plex Media Server FAQ | Linux Tips

     

    Other useful guides: Local Subtitles | The Plex "dance" | Synology FAQ | PMS Release Announcements

    Hosts: Fedora, QNAP, Synology, most Linux distros in VM

    No technical support via PM unless offered

    Please remember to mark the appropriate answer(s) which solved your issue.

     
Sign In or Register to comment.