If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Looking for servers

NateAndKate2003NateAndKate2003 Posts: 8Validating, Plex Pass Plex Pass

Yesterday I discovered that I could no longer connect to my ubuntu PMS. A few days ago it was fine. After trying to figure it out for a while, I uninstalled PMS and reinstalled it. No when I am trying to claim my server, it seems like it times out and gets an error. I looked in the Plex Media Server.log and it looks like a timeout. I attached my log. This is rather frustrating.

«1

Answers

  • ChuckPAChuckPA Posts: 22,199Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    I strongly recommend you revert to the public release of PMS.

    You're experiencing a problem with internal communications which is known. 1.11.2 is beta and this type thing does happen.

    Please DISABLE Verbose logging until requested

    Please search before posting

    Primary support: Linux, Synology, and QNAP

    Please remember to report back. This benefits others.

    Useful links

     Installation and Basic Setup |  Media Preparation (How to name your media files)  |  Linux Permissions 

     Handling TV Specials | Handling Movie extras  |  Nas Compatibility

     Reporting Plex Server issues | Plex Media Server FAQ | Linux Tips

     

    Other useful guides: Local Subtitles | The Plex "dance" | Synology FAQ | PMS Release Announcements

    Hosts: Fedora, QNAP, Synology, most Linux distros in VM

    No technical support via PM unless offered

    Please remember to mark the appropriate answer(s) which solved your issue.

     
  • NateAndKate2003NateAndKate2003 Posts: 8Validating, Plex Pass Plex Pass

    Okay. All I did was go to the PMS download page. I didn't know that I downloaded a beta.

  • NateAndKate2003NateAndKate2003 Posts: 8Validating, Plex Pass Plex Pass

    I downloaded PMS again with a stable version. Still can't claim the server. The log is attached. Help would be appreciated. I have no idea why plex started going haywire a few days ago.

  • ChuckPAChuckPA Posts: 22,199Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member
    edited February 14

    I would like you to perform a soft reset. What the soft reset does is remove your username and a few basic network preferences. It will also unlock your server (why you can't claim it) and redo the claiming manually.

    1. Stop PMS
    2. ssh to the machine (192.168.1.6) or open a terminal session on its display/keyboard (console)
    3. sudo sh (jump to root)
    4. cd "/var/lib/plexmediaserver/Library/Application Support/Plex Media Server"
    5. mv Preferences.xml Preferences.xml.prev (Keep it in case needed)
    6. Start PMS
    7. Open http://192.168.1.6:32400/web in a new browser tab
    8. You will see what looks like a first-run setup. This is expected.
    9. Sign in but do not Claim it.
    10. Proceed through the setup again but do not create any new library sections. Skip that part
    11. Continue until you arrive at the Dashboard.
    12. Go to Settings - Server - General
    13. Sign the server into your account (This is the old, manual, way of claiming)
    14. Review the rest of your preferences, particularly networking, because they were reset.

    Please advise me of your progress.

    Please DISABLE Verbose logging until requested

    Please search before posting

    Primary support: Linux, Synology, and QNAP

    Please remember to report back. This benefits others.

    Useful links

     Installation and Basic Setup |  Media Preparation (How to name your media files)  |  Linux Permissions 

     Handling TV Specials | Handling Movie extras  |  Nas Compatibility

     Reporting Plex Server issues | Plex Media Server FAQ | Linux Tips

     

    Other useful guides: Local Subtitles | The Plex "dance" | Synology FAQ | PMS Release Announcements

    Hosts: Fedora, QNAP, Synology, most Linux distros in VM

    No technical support via PM unless offered

    Please remember to mark the appropriate answer(s) which solved your issue.

     
  • NateAndKate2003NateAndKate2003 Posts: 8Validating, Plex Pass Plex Pass

    I followed your procedure, but I had also done this before. One your number 10, I cannot proceed through the setup nor have I been able to since I originally reinstalled. I attached a screen shot. So, since I wasn't able to proceed through setup, I would access the server directly http://192.168.1.6:32400/web and then go to claim the server there. I won't let me do it still.

    I also created another account and did a monthly plex pass to see if that would make any difference (after I generated this attached log). Didn't change anything.

    I don't understand why up until this weekend my plex server worked great. No changes that I am aware of, and then, all of the sudden I can't find the server. To be clear, I uninstalled it and then reinstalled it and since then, I have not been able to get beyond the setup screen.

  • NateAndKate2003NateAndKate2003 Posts: 8Validating, Plex Pass Plex Pass

    Any more guidance here?

  • ChuckPAChuckPA Posts: 22,199Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    Sorry for the delay. I was very busy yesterday (medical) and got behind.

    I'd like to take a very radical step. There are two approaches, We can try both.

    This establishes a SSH tunnel and connects you as if on the machine's actual graphics head & keyboard

    1. SSH tunnel to the PMS server ssh -L 8888:127.0.0.1:32400 ip.of.linux.machine
    2. sign in and let the session sit idle.
    3. In your browser, open a fresh tab to http://127.0.0.1:8888/web
    4. Settings - Server - General and regain control

    For the next procedure, if you have no success

    In that same shell session

    1. stop PMS
    2. cd /var/lib/plexmediaserver
    3. sudo mv Library Library.keep
    4. start PMS
    5. in the browser session above, again go to http://127.0.0.1:8888/web
    6. This will present itself as a new fresh installation.

    If you cannot save settings here, then we have a much more serious problem than I am understanding

    Please DISABLE Verbose logging until requested

    Please search before posting

    Primary support: Linux, Synology, and QNAP

    Please remember to report back. This benefits others.

    Useful links

     Installation and Basic Setup |  Media Preparation (How to name your media files)  |  Linux Permissions 

     Handling TV Specials | Handling Movie extras  |  Nas Compatibility

     Reporting Plex Server issues | Plex Media Server FAQ | Linux Tips

     

    Other useful guides: Local Subtitles | The Plex "dance" | Synology FAQ | PMS Release Announcements

    Hosts: Fedora, QNAP, Synology, most Linux distros in VM

    No technical support via PM unless offered

    Please remember to mark the appropriate answer(s) which solved your issue.

     
  • NateAndKate2003NateAndKate2003 Posts: 8Validating, Plex Pass Plex Pass

    Okay. Sorry to hear about the medical. Hope things are well.

    Here are my results. BTW, I have completely removed Plex in this process before I reached out to you and did a totally new install. It always goes back to the sign-in problem. My network config hasn't changed in any way. My server just stopped connecting to Plex one day. Unless my ISP (MediaCom), I have no idea. I have an old windows laptop sitting on the network, maybe I will try to install it there.

  • ChuckPAChuckPA Posts: 22,199Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    Nate,
    No need to go to such extreme as an old Windows machine. LOL

    Your 'copy.log.zip' shows me PMS is actually running.

    Did you previously have PMS customized to run as a different username or did you have PMS configured to use a directory other than /var/lib/plexmediaserver/Library/Application Support ?

    Everything your logs show me is as if it's looking elsewhere and ignoring everything you're trying to do

    Please do the following: sudo find /etc -name \*.service . See if you find a plexmediserver.service file
    Something isn't right. Ubuntu 15 w/ a 4.2 kernel on the same subnet can't authenticate. I don't accept that for one second.

    Please DISABLE Verbose logging until requested

    Please search before posting

    Primary support: Linux, Synology, and QNAP

    Please remember to report back. This benefits others.

    Useful links

     Installation and Basic Setup |  Media Preparation (How to name your media files)  |  Linux Permissions 

     Handling TV Specials | Handling Movie extras  |  Nas Compatibility

     Reporting Plex Server issues | Plex Media Server FAQ | Linux Tips

     

    Other useful guides: Local Subtitles | The Plex "dance" | Synology FAQ | PMS Release Announcements

    Hosts: Fedora, QNAP, Synology, most Linux distros in VM

    No technical support via PM unless offered

    Please remember to mark the appropriate answer(s) which solved your issue.

     
  • NateAndKate2003NateAndKate2003 Posts: 8Validating, Plex Pass Plex Pass

    Well, I went ahead and put PMS on that windows machine, and so far things are running great. I would like to know what is going on with Ubuntu here though.

    To my knowledge I have never customized to run from a different directory or a different username (I assume you are referring to the user in ubuntu PMS is running as). I set it up almost two years ago, and I have been very pleased with it until recently when one day my server couldn't be found.

    I ran find and here is the PMS service:
    /etc/systemd/system/multi-user.target.wants/plexmediaserver.service

  • ChuckPAChuckPA Posts: 22,199Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    Good on the 'find' results.

    I can't make sense of it either. There's one extremely remote possibility. Is your Ubuntu installation one which you've upgraded from a an older version ? e.g. 14 --> 15 and then 15 -> 16 ?

    Please DISABLE Verbose logging until requested

    Please search before posting

    Primary support: Linux, Synology, and QNAP

    Please remember to report back. This benefits others.

    Useful links

     Installation and Basic Setup |  Media Preparation (How to name your media files)  |  Linux Permissions 

     Handling TV Specials | Handling Movie extras  |  Nas Compatibility

     Reporting Plex Server issues | Plex Media Server FAQ | Linux Tips

     

    Other useful guides: Local Subtitles | The Plex "dance" | Synology FAQ | PMS Release Announcements

    Hosts: Fedora, QNAP, Synology, most Linux distros in VM

    No technical support via PM unless offered

    Please remember to mark the appropriate answer(s) which solved your issue.

     
  • NateAndKate2003NateAndKate2003 Posts: 8Validating, Plex Pass Plex Pass

    I have not touched the system state of the server since I set it up. One day PMS couldn't authenticate. I did totally remove it and reinstall it, but that didn't help. There has to be something I am missing. For now, I am happy that I have PMS up and running on another box.

  • ChuckPAChuckPA Posts: 22,199Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    Authentication fails if it can't get to the internet / has no outbound path (DNS or Gateway invalid).

    Please DISABLE Verbose logging until requested

    Please search before posting

    Primary support: Linux, Synology, and QNAP

    Please remember to report back. This benefits others.

    Useful links

     Installation and Basic Setup |  Media Preparation (How to name your media files)  |  Linux Permissions 

     Handling TV Specials | Handling Movie extras  |  Nas Compatibility

     Reporting Plex Server issues | Plex Media Server FAQ | Linux Tips

     

    Other useful guides: Local Subtitles | The Plex "dance" | Synology FAQ | PMS Release Announcements

    Hosts: Fedora, QNAP, Synology, most Linux distros in VM

    No technical support via PM unless offered

    Please remember to mark the appropriate answer(s) which solved your issue.

     
  • travelisme@gmail.comtravelisme@gmail.com Posts: 4Members

    Just wanted to add that I'm having the same issue with a new install of Mint. I originally tried installing Plex onto a new install of Mythbuntu but could get the new media server added to my account. So reformatted and installed Mint then MythTV with everything working fine. Went to add Plex and received the same error that my server couldn't be claimed. Strange part is that my Samsung TV sees the Plex server and can browse it but need it to show up in the Roku Plex App.

    Have tried all the previous trouble shooting steps listed but still no luck either. Thank you for the insightful help and have to wonder if this is just an Ubuntu issue since I have the identical issue to NateAndKate2003

  • travelisme@gmail.comtravelisme@gmail.com Posts: 4Members

    adding my log as well

  • ChuckPAChuckPA Posts: 22,199Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    @travelisme@gmail.com said:
    adding my log as well

    I would be really helpful to have more than just one file but, based on what was posted, PMS is working.

    Here you see FireFox came in, started streaming, then stopped (?).

    Did it start to play and then stop?

    Feb 19, 2018 18:33:48.870 [0x7fa1fc3ff700] DEBUG - (Capabilities) Platform 'Firefox' not matched by plugin platform requirements
    Feb 19, 2018 18:33:48.871 [0x7fa2067ff700] DEBUG - Completed: [127.0.0.1:50120] 200 GET / (10 live) GZIP 0ms 1217 bytes (pipelined: 7)
    Feb 19, 2018 18:33:48.885 [0x7fa1f9fff700] DEBUG - Request: [127.0.0.1:50198 (Loopback)] GET / (11 live) GZIP
    Feb 19, 2018 18:33:48.885 [0x7fa1f9fff700] DEBUG - (Capabilities) Platform 'Firefox' not matched by plugin platform requirements
    Feb 19, 2018 18:33:48.886 [0x7fa2067ff700] DEBUG - Completed: [127.0.0.1:50198] 200 GET / (10 live) GZIP 0ms 1325 bytes (pipelined: 1)
    Feb 19, 2018 18:33:54.039 [0x7fa205ffe700] DEBUG - handleStreamRead code 2: End of file
    Feb 19, 2018 18:33:54.043 [0x7fa1f8ffd700] DEBUG - Request: [127.0.0.1:50120 (Loopback)] GET /player/proxy/poll?deviceClass=pc&protocolVersion=1&protocolCapabilities=timeline%2Cplayback%2Cnavigation%2Cmirror%2Cplayqueues&timeout=1 (8 live) GZIP
    Feb 19, 2018 18:33:54.043 [0x7fa1f8ffd700] DEBUG - Beginning read from two-way stream.
    Feb 19, 2018 18:34:14.043 [0x7fa2067ff700] DEBUG - handleStreamRead code 2: End of file
    Feb 19, 2018 18:34:14.047 [0x7fa1f8ffd700] DEBUG - Request: [127.0.0.1:50202 (Loopback)] GET /player/proxy/poll?deviceClass=pc&protocolVersion=1&protocolCapabilities=timeline%2Cplayback%2Cnavigation%2Cmirror%2Cplayqueues&timeout=1 (4 live) GZIP
    Feb 19, 2018 18:34:14.047 [0x7fa1f8ffd700] DEBUG - Beginning read from two-way stream.
    Feb 19, 2018 18:34:34.047 [0x7fa205ffe700] DEBUG - handleStreamRead code 2: End of file
    Feb 19, 2018 18:34:34.051 [0x7fa204bff700] DEBUG - Request: [127.0.0.1:50212 (Loopback)] GET /player/proxy/poll?deviceClass=pc&protocolVersion=1&protocolCapabilities=timeline%2Cplayback%2Cnavigation%2Cmirror%2Cplayqueues&timeout=1 (4 live) GZIP
    Feb 19, 2018 18:34:34.051 [0x7fa204bff700] DEBUG - Beginning read from two-way stream.
    Feb 19, 2018 18:34:54.052 [0x7fa2067ff700] DEBUG - handleStreamRead code 2: End of file
    Feb 19, 2018 18:34:54.059 [0x7fa1f8ffd700] DEBUG - Request: [127.0.0.1:50216 (Loopback)] GET /player/proxy/poll?deviceClass=pc&protocolVersion=1&protocolCapabilities=timeline%2Cplayback%2Cnavigation%2Cmirror%2Cplayqueues&timeout=1 (4 live) GZIP
    Feb 19, 2018 18:34:54.059 [0x7fa1f8ffd700] DEBUG - Beginning read from two-way stream.
    Feb 19, 2018 18:35:17.953 [0x7fa1f97fe700] DEBUG - [CompanionProxy] player en1ejuw7hm8x9mvf4e5qjjtj was last refreshed 10 seconds ago
    Feb 19, 2018 18:35:27.954 [0x7fa1f97fe700] DEBUG - [CompanionProxy] player en1ejuw7hm8x9mvf4e5qjjtj was last refreshed 20 seconds ago
    Feb 19, 2018 18:35:37.954 [0x7fa1f97fe700] DEBUG - [CompanionProxy] player en1ejuw7hm8x9mvf4e5qjjtj was last refreshed 30 seconds ago
    Feb 19, 2018 18:35:39.160 [0x7fa200bfd700] DEBUG - Request: [127.0.0.1:50222 (Loopback)] GET /servers (5 live) GZIP
    Feb 19, 2018 18:35:39.163 [0x7fa205ffe700] DEBUG - Completed: [127.0.0.1:50222] 200 GET /servers (5 live) GZIP 2ms 489 bytes
    Feb 19, 2018 18:35:39.163 [0x7fa204bff700] DEBUG - Request: [127.0.0.1:50224 (Loopback)] GET /library/sections (6 live) GZIP
    Feb 19, 2018 18:35:39.164 [0x7fa205ffe700] DEBUG - Completed: [127.0.0.1:50224] 200 GET /library/sections (5 live) GZIP 0ms 475 bytes
    Feb 19, 2018 18:35:39.165 [0x7fa200bfd700] DEBUG - Request: [127.0.0.1:50226 (Loopback)] GET /channels/all (6 live) GZIP
    Feb 19, 2018 18:35:39.166 [0x7fa205ffe700] DEBUG - Completed: [127.0.0.1:50226] 200 GET /channels/all (5 live) GZIP 0ms 387 bytes
    Feb 19, 2018 18:35:47.954 [0x7fa1f97fe700] DEBUG - [CompanionProxy] player en1ejuw7hm8x9mvf4e5qjjtj was last refreshed 40 seconds ago
    Feb 19, 2018 18:35:47.954 [0x7fa1f97fe700] DEBUG - [CompanionProxy] player en1ejuw7hm8x9mvf4e5qjjtj was not refreshed for over 30 seconds, dropping it.
    Feb 19, 2018 18:38:44.961 [0x7fa1ffbfb700] DEBUG - NetworkServiceBrowser: PLAYER departed after not being seen for 181.999922 seconds: 127.0.0.1
    

    Please DISABLE Verbose logging until requested

    Please search before posting

    Primary support: Linux, Synology, and QNAP

    Please remember to report back. This benefits others.

    Useful links

     Installation and Basic Setup |  Media Preparation (How to name your media files)  |  Linux Permissions 

     Handling TV Specials | Handling Movie extras  |  Nas Compatibility

     Reporting Plex Server issues | Plex Media Server FAQ | Linux Tips

     

    Other useful guides: Local Subtitles | The Plex "dance" | Synology FAQ | PMS Release Announcements

    Hosts: Fedora, QNAP, Synology, most Linux distros in VM

    No technical support via PM unless offered

    Please remember to mark the appropriate answer(s) which solved your issue.

     
  • travelisme@gmail.comtravelisme@gmail.com Posts: 4Members

    Thank you for the reply. To be honest, I haven't given PLEX anything to do yet cause I need the server registered for it to show up on our Roku. I will setup a test today and see if it can play locally on the MINT box but as far as I can tell Plex is running fine. It's just uncliamed. Only planned to use Plex with the mythtv bundle plugin to play mythtv recordings via Plex app.

    I did upgrade Plex this morning and unfortunately still can;t register the server. Attached are all the logs. Thank you so much for the help!

  • cshanks62@yahoo.comcshanks62@yahoo.com Posts: 4Members ✭✭

    Ok this is still travelisme@gmail.com but thought I try a complete new Plex account and a completely fresh install of Mythbuntu for a test. Sorry to say that I still cannot claim the plexserver. I did add a library and copied in an AVI file that played fine in the Plex Media Manager. I tailed the plex media log during the entire process and nothing really sticks out as an issue.

    Attached are the logs for the clean install and the video playback. Sometimes you just can't get there from here.

    Thank you to anyone who has an idea on how to get this server claimed.

  • ChuckPAChuckPA Posts: 22,199Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    Mythbuntu is known to have issues.

    Settings - Server - General and sign it in manually.

    The transcoder is playing something.

    Feb 20, 2018 14:02:19.495 [0x7ff1617fd700] DEBUG - Thread: Running async task started by thread 0x7ff1627ff700.
    Feb 20, 2018 14:02:19.495 [0x7ff1617fd700] DEBUG - Request: [127.0.0.1:51438 (Loopback)] POST /video/:/transcode/session/kwvsuld57cy6dfp3x6l3jlc7/05f8c874-3fbe-443a-8bb7-093ab1cd31cc/manifest (11 live) Signed-in
    Feb 20, 2018 14:02:19.496 [0x7ff1617fd700] DEBUG - Transcoder segment range: 0 - 60
    Feb 20, 2018 14:02:19.496 [0x7ff161ffe700] DEBUG - Completed: [127.0.0.1:51438] 200 POST /video/:/transcode/session/kwvsuld57cy6dfp3x6l3jlc7/05f8c874-3fbe-443a-8bb7-093ab1cd31cc/manifest (11 live) 0ms 166 bytes
    Feb 20, 2018 14:02:19.761 [0x7ff1553ff700] DEBUG - Thread: Running async task started by thread 0x7ff167bff700.
    Feb 20, 2018 14:02:19.893 [0x7ff1573fb700] DEBUG - Thread: Running async task started by thread 0x7ff161ffe700.
    Feb 20, 2018 14:02:19.893 [0x7ff1573fb700] DEBUG - Request: [127.0.0.1:51440 (Loopback)] POST /video/:/transcode/session/kwvsuld57cy6dfp3x6l3jlc7/05f8c874-3fbe-443a-8bb7-093ab1cd31cc/manifest (11 live) Signed-in
    Feb 20, 2018 14:02:19.893 [0x7ff1573fb700] DEBUG - Transcoder segment range: 0 - 61
    Feb 20, 2018 14:02:19.894 [0x7ff161ffe700] DEBUG - Completed: [127.0.0.1:51440] 200 POST /video/:/transcode/session/kwvsuld57cy6dfp3x6l3jlc7/05f8c874-3fbe-443a-8bb7-093ab1cd31cc/manifest (11 live) 0ms 166 bytes
    

    Please DISABLE Verbose logging until requested

    Please search before posting

    Primary support: Linux, Synology, and QNAP

    Please remember to report back. This benefits others.

    Useful links

     Installation and Basic Setup |  Media Preparation (How to name your media files)  |  Linux Permissions 

     Handling TV Specials | Handling Movie extras  |  Nas Compatibility

     Reporting Plex Server issues | Plex Media Server FAQ | Linux Tips

     

    Other useful guides: Local Subtitles | The Plex "dance" | Synology FAQ | PMS Release Announcements

    Hosts: Fedora, QNAP, Synology, most Linux distros in VM

    No technical support via PM unless offered

    Please remember to mark the appropriate answer(s) which solved your issue.

     
  • travelisme@gmail.comtravelisme@gmail.com Posts: 4Members

    Ok turns out in my situation that even hard coding the correct DNS servers from my ISP in the static IP, had to leave the server in DHCP mode and the server claimed fine. Sorry for the hassle and thank you ChuckPA for being so nice and helpful.

«1
Sign In or Register to comment.