If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Unable to group library collections together

Excuse if this has been asked before, first time forum user and novice to Plex here:-) My question is regarding collections. I am able to create collections in individual libraries, but, per all the instructions I read, if I create the same name collection in one library (for example "Classic Movies") and also create the same named collection in another library (for example "New Movies") then the movies in both libraries should merge into one collection. However this doesnt work. Each library collection remains separate from each other, albeit with the same collection name.
Am I missing something here?
Also, per all I have read on the subject, there should be some options for creating "in-line" collections options in each library's Advanced Editing window..however, in none of the Plex clients am I able to see any of these options for modifying collection behavior. Am I missing something here too? Are these features "in the works"? Thanks for any help and I am very leased with Plex and consider it a work of art:-)

Answers

  • OttoKernerOttoKerner Posts: 28,329Members, Plex Pass, Plex Ninja Plex Ninja
    Got help? Help others too - by reporting back with your results!
    Have you checked the Documentation before posting a question in the forums?
    Use the SEARCH function before starting a new thread!
    No PMs unless requested, please! Do not use 'verbose' logging
  • viajerozzviajerozz Posts: 11Members ✭✭

    Yes I did. It explains what collections are supposed to do. It doesnt explain why it doesn't do what it is supposed to do. Specifically, why do collections with the same name not merge as they are supposed to do?

  • OttoKernerOttoKerner Posts: 28,329Members, Plex Pass, Plex Ninja Plex Ninja

    Collections are still separated by library.
    However, if you have collections of the same name in several libraries, they will appear on the preplay page of items.

    The following preplay page has items from a tv show, a movie and a music library:

    There is no view mode where you can see all items from all libraries collected.

    You need to use the 'hosted' web app to see the new collections stuff.
    https://app.plex.tv/desktop

    Those features will come later to the other apps.

    Got help? Help others too - by reporting back with your results!
    Have you checked the Documentation before posting a question in the forums?
    Use the SEARCH function before starting a new thread!
    No PMs unless requested, please! Do not use 'verbose' logging
  • viajerozzviajerozz Posts: 11Members ✭✭

    Thanks very much, Otto, for taking the time to assist me. I understand all that you have said, however, for some reason (maybe operator error) I just don't seem to have the same results as you do.
    I am using the web app (not sure what is meant by "hosted") on a Windows 10 PC.
    I have two libraries for this example, Classic Movies and Movies.
    In each library I have a movie "The Time Machine" and in each movie I created a Collection both Collections having the same name "Time Machine"

    I understand that if I select one of the libraries in the main menu and then, select "Collection" from the pull down menu on the right and select the "Time Machine" collection, it will only display the movies pertaining to that library ONLY.
    I also understand from your explanation that, if I go into the individual movie's preplay page, it SHOULD display both movies from both collections as they have the same name. This is where it goes wrong. It doesn't. It still only displays the individual movie in the collection pertaining to that library only.

    In Libraries Classic Movies and Movies both have Collection named "Time Machine"

    Opening library Classic Movies I click on "Time Machine" collection

    Opening library Movies I click on "Time Machine" collection.

    I click on the Movies library's Time Machine collection to open the movie's preplay screen:

    Hope I did this right, first time I have used the forum:-) As you see, in the preplay screen it only displays the movie from the collection pertaining to that individual library and does not display the two movies from two separate libraries, even though they have the same Collection name.
    Is this a user error on my part? Thanks for your input!

  • OttoKernerOttoKerner Posts: 28,329Members, Plex Pass, Plex Ninja Plex Ninja

    @viajerozz said:
    I am using the web app (not sure what is meant by "hosted") on a Windows 10 PC.

    You must load the web app from the link I gave you.
    The one on your computer is too old and it'll get only updated with a new server release.

    see https://support.plex.tv/articles/200288666-opening-plex-web-app/

    Got help? Help others too - by reporting back with your results!
    Have you checked the Documentation before posting a question in the forums?
    Use the SEARCH function before starting a new thread!
    No PMs unless requested, please! Do not use 'verbose' logging
  • viajerozzviajerozz Posts: 11Members ✭✭

    Ok, thanks. I still have the same issue, though, even with the hosted web app.

  • OttoKernerOttoKerner Posts: 28,329Members, Plex Pass, Plex Ninja Plex Ninja

    I have a hunch:
    delete the collection from both libraries.

    Then re-create it,
    but make sure that you don't type in The Time Machine
    but just Time Machine as the name of your collection

    Got help? Help others too - by reporting back with your results!
    Have you checked the Documentation before posting a question in the forums?
    Use the SEARCH function before starting a new thread!
    No PMs unless requested, please! Do not use 'verbose' logging
  • viajerozzviajerozz Posts: 11Members ✭✭

    Thanks but that's how I named it originally, just "Time Machine". I have other collections too with no "The" with the same behavior. I suppose it's not a big issue, I can live with it for sure. I just don't understand why yours works and mine doesnt :-)

  • viajerozzviajerozz Posts: 11Members ✭✭

    May I ask your version of the web app? Mine is 3.35.2

  • viajerozzviajerozz Posts: 11Members ✭✭

    Also, just noticed that little "lock" icon next to the Collection tag in the edit screen for each movie...what is that for? However when I toggle it off, it has no effect on my problem.

  • OttoKernerOttoKerner Posts: 28,329Members, Plex Pass, Plex Ninja Plex Ninja

    What software version is your server?
    The new collection stuff needs 1.11 - that is still a beta.

    Got help? Help others too - by reporting back with your results!
    Have you checked the Documentation before posting a question in the forums?
    Use the SEARCH function before starting a new thread!
    No PMs unless requested, please! Do not use 'verbose' logging
  • viajerozzviajerozz Posts: 11Members ✭✭

    Mine is 1.10.1.4602..that must be it then..I'll see if I can upgrade it..

  • OttoKernerOttoKerner Posts: 28,329Members, Plex Pass, Plex Ninja Plex Ninja

    @viajerozz said:
    Mine is 1.10.1.4602..that must be it then..I'll see if I can upgrade it..

    You can't without Plex Pass.

    Got help? Help others too - by reporting back with your results!
    Have you checked the Documentation before posting a question in the forums?
    Use the SEARCH function before starting a new thread!
    No PMs unless requested, please! Do not use 'verbose' logging
  • viajerozzviajerozz Posts: 11Members ✭✭

    Thanks, Otto, that did it! I wish somewhere in all the directions it might have mentioned I need the new beta version of the server install but, oh well. At least it works somewhat now as does yours. I think it must be a work in progress as it still is buggy and shouldn't only work in the preplay view. It cost me a subscription to the Plex Pass to get the working server version but I was gonna get it anyway. At least now in the preplay view I see other associated movies in the collection..although, in the preplay window, when it says "Movies in Collection" it only shows the OTHER movies in the collection included by the OTHER library. Like I say, a little buggy but I think it will improve. Thanks for your help!

Sign In or Register to comment.