Our forum migration to Discourse is underway and scheduled to last through June 21. During the migration, the forums will be read-only, except for a single temporary forum (contents of which will not be getting transferred). Read our announcement post for more information about the forum migration.
Hey folks, there is a new Podcast category for forums https://forums.plex.tv/categories/podcasts
If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Direct play 3D issues

pitrie17pitrie17 Members, Plex Pass Posts: 29 Plex Pass
edited February 16 in NVIDIA SHIELD

I recently bought the Nvidia Shield and migrating from Roku Premiere+ because the Shield is the only box that I'm aware of that does all flavors of audio. The issue I'm having is that it does not direct play the video correctly. I realize my situation is a bit unique, but the Roku app handles this flawlessly, albeit with only 5.1 audio. I've included three JPGs to help illustrate.

The first is a snapshot from the actual file. You can see that it is a FULL side by side 3D file that I've compressed. Resolution is 3840 x 1080.

The second is from the Roku (without 3D mode turned on). The LG TV interprets the file correctly, and when 3D mode is enabled I have FULL resolution 3D. Problem is Roku only supports 5.1 audio.

The last one is from the Nvidia Shield. Same file, but it is cropping the video and only showing the left half of the video. When 3D mode is enabled it doesn't look accurate either.

Currently on the latest version of Plex on the Shield. Is there something that I'm doing wrong? I am surprised at how much I notice the full audio mix so I'm hoping this is just a bug. Otherwise I'll be going back to Roku and living with 5.1 audio.

Best Answer

  • pitrie17pitrie17 Posts: 29 Plex Pass
    Accepted Answer

    Last update. To keep hardware acceleration turned on (preferred) on the Nvidia shield, I had to edit the __ENCODE_3D.cmd that BD3D2MK3D creates and updated to the following "--frame-packing 6". That essentially sets the file with MONO flags and so the Nvidia shield treats it as such and plays back with hardware acceleration turned on correctly. My TV never automatically switched to the correct 3D mode, so that wasn't an issue for me since I do it manually, but YMMV.

Answers

  • solowtcsolowtc Validating, Plex Pass Posts: 4 Plex Pass

    This is the EXACT same issue I’m currently having, have about 40 full SBS and cannot get a single one to play on shield plex. Only showing the left side of video, even tried Kodi with the plex add on. Let me know if you figure out a solution and I’ll let you know if I find a way to make it work

  • pitrie17pitrie17 Members, Plex Pass Posts: 29 Plex Pass
    edited February 15

    So I've spent some time trying other solutions and I'm almost positive it is an Nvidia Shield issue. Tried Kodi, Plex add on (same as solowtc), and VLC and all do the same thing. Very frustrating that it can't play a file accurately. Glad I'm not the only one.

    I guess it has to be fixed on the Nvidia side so I will see where to contact them and see what progress can be made there.

  • pitrie17pitrie17 Members, Plex Pass Posts: 29 Plex Pass

    @solowtc Here's a thread on Nvidia's forums if you want to post and add your voice there as well. I think the more the merrier.

    https://tinyurl.com/ycdjo4js

  • solowtcsolowtc Validating, Plex Pass Posts: 4 Plex Pass

    Thanks, I will post there as well. I used to use a htpc to play my full sbs files before I knew you could play them in plex. I also have a roku ultra so I tried today with that to see if I could replicate your full sbs video and for some reason all of my files come out horizontally stretched and do not fill the tv like they are supposed to for sbs. Any idea how to get this to work, is it a setting in the roku? I have forced direct on.

  • pitrie17pitrie17 Members, Plex Pass Posts: 29 Plex Pass

    @solowtc What TV do you have and how did you create your full SBS? I had a similar issue. I have an LG oled and I use BD3D2MK3D to take my 3D MKV from MakeMKV and create a full SBS. The LG TV needs a SAR of 1:2 (a setting in BD3D2MK3D). If that is your hardware, then you will be able to update the SAR with some commandline tools, or recompress. But there is no setting in Roku like there is in Kodi to adjust aspect ratio.

  • solowtcsolowtc Validating, Plex Pass Posts: 4 Plex Pass

    @pitrie17 thanks for the help, that was definitely the issue, I changed the SAR settings in BD3D and was able to get the Roku working. I have a Sony tv but it behaves like your LG with the aspect ratio. So I found a work around for getting full SBS 3D on the plex, I used vidcoder to upscale the video to 3840x2160 so plex has no choice but to play it the full size. Was able to watch guardians in 3D with HD audio. Only issue is encoding the file a second time is not preferred, but for now it works. I saw no difference in the picture quality vs the upscaling performed by the Roku.

  • pitrie17pitrie17 Members, Plex Pass Posts: 29 Plex Pass
    edited February 16

    I wonder if that same fix will work for the Nvidia Shield since Roku won't pass 7.1 audio. I'll try that out today.

  • solowtcsolowtc Validating, Plex Pass Posts: 4 Plex Pass

    @pitrie17 Sorry, I wrote that wrong. It works on the shield. I watched guardians on the shield with lossless 7.1 audio.

  • pitrie17pitrie17 Members, Plex Pass Posts: 29 Plex Pass

    @solowtc Here's an update that I learned from the Nvidia forum. If you disable hardware acceleration in Kodi then it plays the 3840x1080 file correctly. I use the Plex add-on in Kodi so I'm still in the Plex environment but have the additional tweaking functionality of Kodi which is helpful for adjusting aspect ratio on a few of my files. Looks like I will be keeping my Nvidia Shield. Happy I have full sbs 3d and HD audio.

  • pitrie17pitrie17 Members, Plex Pass Posts: 29 Plex Pass
    Accepted Answer

    Last update. To keep hardware acceleration turned on (preferred) on the Nvidia shield, I had to edit the __ENCODE_3D.cmd that BD3D2MK3D creates and updated to the following "--frame-packing 6". That essentially sets the file with MONO flags and so the Nvidia shield treats it as such and plays back with hardware acceleration turned on correctly. My TV never automatically switched to the correct 3D mode, so that wasn't an issue for me since I do it manually, but YMMV.

Sign In or Register to comment.