Hey folks, there is a new Podcast category for forums https://forums.plex.tv/categories/podcasts
If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

No 5.1 audio on ChromeCast Ultra

MadsGosvigMadsGosvig Posts: 3Members Plex Pass

Hi,
I have been having 5.1 sound issues since I first started using Plex, and I have tried almost everything.
So I hope someone can shed light on this for me.

My setup:

  • MyCloud PR2100 serving as a Plex server with all my content.
  • Android app where I access content.
  • ChromeCast Ultra hooked to TV via HDMI.
  • TV is 5 year old Panasonic.
  • TV is connected to DVD/5.1 sound system via "headphone audio out" which is 2 channel sound (as I understand)
  • Sound system is Samsung HT-J5500/XE.

The setup can be seen here:

All my movies are played in 2.0 sound using only the front speakers of my sound system.
I have tried movies with different audio "tracks", but nothing works.
I have used a tool called MediaInfo to check my movies.

A specific movie, that I think MUST be able to play 5.1 is this one:

It specificly says that the audio stream is 6 channels AC-3 which I suppose should work with 5.1?

And another think I have been wondering about:
This link:
https://support.plex.tv/articles/212072167-audio-configuration-guide-plex-media-player/

Tells me to go to "Settings -> Audio" where I can config many things about sound.
But I have never seen all these settings, neither on my MyCloud PR2100 (plex server) or the Android App.
Does the link contain outdated information, or where should I see these settings?

On my Andorid App i go to "Settings -> Advanced -> Player (not sure about this name)"
Where I can see "Device support".
Audio passthrough is set to "deactivated" and I can't get it to change to "automatic" every time I click "automatic" and leave settings and return it is defaulted to "deactivated" again.
And "Optional audio support" is only set to AC3 (which matches my movie info)...

Long story short, I have no idea where to go from here, and I can't figure out where the problem lies.
Can anyone help me out?

Answers

  • OttoKernerOttoKerner Posts: 30,857Members, Plex Pass, Plex Ninja Plex Ninja

    @MadsGosvig said:

    • TV is connected to DVD/5.1 sound system via "headphone audio out" which is 2 channel sound (as I understand)

    That's the problem right there.
    How do you expect your sound system to reproduce 6 channels if you only feed it 2 channels?

    And another think I have been wondering about:
    T his link:
    https://support.plex.tv/articles/212072167-audio-configuration-guide-plex-media-player/

    This doesn't apply to the Chromecast.

    Got help? Help others too - by reporting back with your results!
    Have you checked the Documentation before posting a question in the forums?
    Use the SEARCH function before starting a new thread!
    No PMs unless requested, please! Do not use 'verbose' logging
  • BigWheelBigWheel Posts: 10,277Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
    edited February 23

    If your TV can passthrough you can try connecting from TV to Samsung bluray player player with an optical cable. but i have no idea if your tv is capable of that.

    Logs > https://support.plex.tv/articles/201869908-log-files/
  • MadsGosvigMadsGosvig Posts: 3Members Plex Pass

    Thanks for the reply!
    So I bought an optical cable and connected my TV and Samsung blueray player.

    I got sound comming through the cable, and that seems to work fine.
    But when I play a movie from plex there is still no 5.1 audio.
    So I think we are closer to a solution, but there is still missing something that I can't figure out.

    Any more ideas?
    Could it be the Chromecast not supporting the audio format, or could it be the audio format it self??

  • OttoKernerOttoKerner Posts: 30,857Members, Plex Pass, Plex Ninja Plex Ninja

    @MadsGosvig said:
    So I bought an optical cable and connected my TV and Samsung blueray player.

    That doesn't sound right (pardon the pun.)

    I thought you want 5.1 sound out of your soundbar?
    Then you'll have to connect your TV to your soundbar per the optical cable.

    Got help? Help others too - by reporting back with your results!
    Have you checked the Documentation before posting a question in the forums?
    Use the SEARCH function before starting a new thread!
    No PMs unless requested, please! Do not use 'verbose' logging
  • BigWheelBigWheel Posts: 10,277Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    his bluray player is one of those all in one bluray+5.1 speaker systems. it has optical in but i guess his tv cannot passthrough or the chromecast has no way to know it can so it still only outputting the 2.0 audio ( because the tv itself can only do 2.0 )

    there may be some TV setting for it but dunno.

    Logs > https://support.plex.tv/articles/201869908-log-files/
Sign In or Register to comment.