Our forum migration to Discourse is underway and scheduled to last through June 21. During the migration, the forums will be read-only, except for a single temporary forum (contents of which will not be getting transferred). Read our announcement post for more information about the forum migration.
Hey folks, there is a new Podcast category for forums https://forums.plex.tv/categories/podcasts
If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Plex Can't "See" Media in ONE folder - loads all others

ere109ere109 Members Posts: 8 ✭✭

I'm running PMS in a FreeNAS 11.1 jail. I've got my media mounted into the jail at /mnt/video. I can load my /Movies folder, my /TV folder, my /Kids folder no problem. They're all recognised and populate with media. I've also got a folder of music videos, called /Music. When I add that folder to its own library, nothing shows up - even though there are dozens of .avi files. I've tried loading them as TV shows and as personal videos, but Plex refuses to see them.
Does it have something to do with the folder name - Music - causing Plex to hiccup? I haven't tried to change the folder name, yet, because I just assumed it would work if I told it what to do.

Answers

  • tom80Htom80H Members, Plex Pass Posts: 2,273 Plex Pass

    The folder name shouldn't give Plex any hiccups.
    When you're in the library setup dialog where you can specify the folders for your library... when picking the music folder... does Plex show any subsequent folders? If not, this might be linked to a permissions problem.

    how did you name the videos... maybe there's anything in the naming/folder structure (within the music folder), throwing Plex off?!

  • ere109ere109 Members Posts: 8 ✭✭

    Plex doesn't show any folders. It starts at "/config/Plex Media Server" and calls itself root - so I have no access to my /mnt folder. (I've got my config set up in a different directory to allow updates without having to rebuild.) So I can't browse to search folders - have to enter them manually. When I enter:
    /mnt/video/Video/Movies -- It loads all movies without issue. However, when I enter:
    /mnt/video/Video/Music -- I get nothing.

    Perhaps the better fix would be to figure out how to edit the plex starting point so that I can simply browse in - assuming this won't break my existing database, which took a long time to create.

  • tom80Htom80H Members, Plex Pass Posts: 2,273 Plex Pass

    it's not so much about what you can see (without root). it's about what Plex can see... the trick to see THAT is e.g. to use the "browse for media folder" button in the library creation / edit dialog.

    When clicking "browse for media folder" Plex will show the file system as it can see it...

    When going to mnt/video/Video/Music... do you see any subfolders or media in this folder?

  • ere109ere109 Members Posts: 8 ✭✭

    @tom80H said:
    it's not so much about what you can see (without root). it's about what Plex can see...

    When going to mnt/video/Video/Music... do you see any subfolders or media in this folder?

    And that's the problem. Plex can't "see" those folders, but it can blindly access them. My setup goes /mnt/iocage/plex and /mnt/config/plex and /mnt/video. The plex "Browse For Media Folder" button starts in /mnt/config/plex, and won't let me back out to the larger folder tree. So I can manually enter "/mnt/video/etc" but I can't get Plex to "see" any of the files or folders. I just have to tell it they're there, and it finds them. That works for every other folder I've used, and I've probably got 6 libraries connected using the /mnt/video/ location. But this ONE folder refuses to work.
    I suppose I could add a symlink into the /config folder to access all of the other stuff, but I'd love for this to work without jumping through hoops.

  • ere109ere109 Members Posts: 8 ✭✭

    I believe this may have something to do with the line: plexmediaserver_support_path

  • tom80Htom80H Members, Plex Pass Posts: 2,273 Plex Pass

    sounds more like a permission problem.
    I don't remember 100% if PexBSD uses a "plex" user which needs to see / needs to own the media folders in order to get this going -- have you checked that already?

  • justin17sunshinejustin17sunshine Members, Plex Pass Posts: 1 Plex Pass
    edited May 11

    I can't even see the "Add Folders" or "browse for media folders" option. It was there before, but disappeared about a month ago. It started after I moved to a new server (WD My Cloud Home). Is there a setting I need to change?

  • tom80Htom80H Members, Plex Pass Posts: 2,273 Plex Pass

    screenshot please.
    do you use the WD My Cloud Home as storage or do you also run the Plex Server on it?

  • OttoKernerOttoKerner Members, Plex Pass, Plex Ninja Posts: 30,880 Plex Ninja

    @justin17sunshine said:
    I can't even see the "Add Folders" or "browse for media folders" option. It was there before, but disappeared about a month ago. It started after I moved to a new server (WD My Cloud Home). Is there a setting I need to change?

    Your issue is in no way related to that of the thread opener.
    Please don't hijack other people's threads.
    Particularly if they appear in a forum, which has nothing to do with your own server's operating system.

    https://support.plex.tv/articles/115003310834-western-digital-my-cloud-home/

    Got help? Help others too - by reporting back with your results!
    Have you checked the Documentation before posting a question in the forums?
    Use the SEARCH function before starting a new thread!
    No PMs unless requested, please! Do not use 'verbose' logging
Sign In or Register to comment.