Our forum migration to Discourse is underway and scheduled to last through June 21. During the migration, the forums will be read-only, except for a single temporary forum (contents of which will not be getting transferred). Read our announcement post for more information about the forum migration.
Hey folks, there is a new Podcast category for forums https://forums.plex.tv/categories/podcasts
If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Sync items will not transfer

jkbucketheadjkbuckethead Members, Plex Pass Posts: 15 Plex Pass

I have a new laptop, which I purchased mainly to watch videos during an upcoming trip overseas. I loaded the Windows Store Plex app, and had no trouble getting connected to my Plex server. Unfortunately though, after repeated attempts I have not been able to sync a single item.

To start with, my server and player apps are all up to date, as best I can tell, and are signed-in to my plex pass account. I can see the server from the laptop just fine. I can stream videos from the server just fine. I can see my entire media library, and set up a sync just fine. I can even see the sync progress as the files are transcoded, but the files do not transfer. The only error message I get is either Unknown Error or Network Error so I have no idea where to start. Considering everything else works, so clearly the network is too.

My setup is fairly simple. My plex server is running on a not that old (i5) PC in the basement running Windows 10. The server was just updated to version 1.11.3.4803. This is my primary plex server, and it is NOT shared outside of my network. I also have a 2nd plex server running on my synology NAS box which I do share externally for family to use. The laptop is running Windows 10 with the windows store app, version 3.2.20-2599c77. Everything is connected to my home network, the servers are hardwired, the laptop is wifi.

Whenever I try to sync everything works up to the point it should transfer the file to the laptop, then nothing happens and I get the vague error message. I have tried both servers with the same results. I have of course tried different videos. My first choice for storage on the laptop was a large SD card, but I have also tried saving to the default location. I have tried setting up the sync from the laptop, and from the server. Also, rather annoyingly the laptop will repeatedly tell me that media is ready to transfer even though it never will. I have tried just about every reasonable iteration, and nothing seems to work.

Please, I need help or advice to figure this out.

«1

Answers

  • tom80Htom80H Members, Plex Pass Posts: 2,272 Plex Pass
    edited February 24

    sound a bit like the syncing experience with iOS. the server will transcode the video just fine but when it comes to downloading the synced version to the device, things go wrong.
    I've just been playing around with this on my iPad and (still) cannot get it to work.

    2018/02/24 15:07:28.303 (83 MB) (497616) (error) PMKSyncListManager.m:141 | Sync: We got a HTTP error trying to refresh the sync list (Error Domain=NSURLErrorDomain Code=-999 "(null)").
    2018/02/24 15:07:28.369 (83 MB) (497616) (debug) PMKSyncStorageManager.m:207 | Total: 122070 Mb Limit: 0 Mb Used by Sync: 0 Mb Free: 63047 Mb Available: 62847 Mb
    2018/02/24 15:07:28.375 (83 MB) (514608) (debug) PMKSyncListManager.m:106 | Refreshing sync list
    2018/02/24 15:07:28.377 (83 MB) (514572) (debug) PMKNetworkTask.m:224 | Cloud (plex.tv): GET /devices/[MY DEVICE ID]/sync_items
    2018/02/24 15:07:28.382 (83 MB) (497616) (error) PMKSyncListManager.m:141 | Sync: We got a HTTP error trying to refresh the sync list (Error Domain=NSURLErrorDomain Code=-999 "Abgebrochen" UserInfo={NSErrorFailingURLStringKey=https://plex.tv:443/devices/[MY DEVICE ID]/sync_items?X-Plex-Device-Name=[MY DEVICE NAME], NSLocalizedDescription=Abgebrochen, NSErrorFailingURLKey=https://plex.tv:443/devices/[MY DEVICE ID]A/sync_items?X-Plex-Device-Name=[MY DEVICE NAME]}).

    (where "Abgebrochen" is the German translation of "Cancelled"... I had to tinker a little with the log as the iOS log contains images which didn't work well with the forum -- I replaced those with "(error)" and "(debug)").
    The server log is less descriptive (as in I couldn't really put my finger on the point where things go wrong). Server seems to be cycling through a series of "refreshSyncList" events and "garbageCollection", but no obvious errors etc.
    Feb 24, 2018 15:07:27.385 [0x7fa2c03fe700] DEBUG - HTTP 200 response from PUT https://plex.tv/devices/[MY DEVICE ID]/sync_items/25285512/status?auth_token=xxxxxxxxxxxxxxxxxxxx&itemsCompleteCount=1&itemsCount=1&itemsDownloadedCount=0&itemsReadyCount=1&itemsSuccessfulCount=1&state=complete&totalSize=368106934

  • chaosmakerchaosmaker Members, Plex Pass Posts: 537 Plex Pass

    Could you post some logs from both the server and the client?
    The only thing from the description that pops into my head is to make sure all the syncs are empty (you can check on plex web) - you might have to log out from your UWP app remove the device, remove all the syncs and start over

  • jkbucketheadjkbuckethead Members, Plex Pass Posts: 15 Plex Pass

    Attached are logs from my server and laptop (client). I'm quite sure that some of the log files are irrelevant, but I'm not sure which are so I included the whole file as it downloaded.

    Per the post above I did try removing all pending syncs, removing the laptop from my plex devices, and even removed and reinstalled the client. In the end there was no improvement, but the first file I tried to sync did seem to partially transfer before the network error appeared. After than all files seem to go to the error immediately after conversion.

    One new thing did show up today. I'm not sure if it is related, but when I tried sync a file from the laptop rather than the server, I received the following error message when trying to save the sync.

    Unable to save sync item
    Expected X-Plex-Sync-Version:2

    Again, all help is appreciated.

  • gogojuicegogojuice Members, Plex Pass Posts: 41 Plex Pass

    I get that same error. Brand new surface pro. My server is on my imac and I get the same errrors. Looking forward to seeing it resolved

  • chaosmakerchaosmaker Members, Plex Pass Posts: 537 Plex Pass

    Ok can you try something for me. The default Sync storage is somewhere in

    C:\Users\[username]\AppData\Local\Packages\CAF9E577.Plex_aam28m9va5cke
    

    Could you go there and delete everything. Then reopen the app, and try to sync again?

  • jkbucketheadjkbuckethead Members, Plex Pass Posts: 15 Plex Pass

    Still no dice. First, I tried deleting everything from the folder above. Windows wouldn't allow me to delete one folder titled CryptnetUrlCache, but other than that I deleted everything. Unfortunately, this also seemed to prevent Plex from starting. After deleting the folders above it starts to load then stalled at the PLEX loading screen. I then uninstalled and reinstalled, first making sure the folder was removed. The new install still failed to sync anything. Still converts fine, says awaiting transfer for a few seconds then goes to unknown error.

    For grins I tried syncing to my windows 10 desktop. I use this machine all the time manage my plex server via the browser, but I've never tried syncing to this machine. Unfortunately I had the same unknown error issue on this machine as well.

    It seems unlikely that the windows app is completely broken, or there would be even more uproar on this forum than there already is. Also, batting 0 for 2 makes me think it isn't a problem with either of my client computers. Could there be something wrong on the server that only affects downloading?

    Mobile sync is a plex pass feature. I have plex pass, but could there be a problem with Plex not authorizing the transfer?

  • chaosmakerchaosmaker Members, Plex Pass Posts: 537 Plex Pass

    From the logs it looked like there was an issue with the metadata. As it was complaining it couldn't download that. Have you tried syncing different items?
    Sync seems to work on my win 10 desktop, sadly I have no surface to test it there.
    I had a couple of issues where single items wouldn't transfer, forcing the server to re analyse and refresh metadata has helped that issue. Sorry I can't help any further :disappointed:

  • chaosmakerchaosmaker Members, Plex Pass Posts: 537 Plex Pass

    Can you check whether the new server version might have fixed your issue? There was a fix for bad XML production during sync! Hopefully that fixes your issue!

  • stephen.hstephen.h Members, Plex Pass Posts: 9 Plex Pass

    I'm having the exact same problem both before and after the most recent server update to 1.12.0.4829 on a custom Ubuntu server and syncing to a Dell XPS 15 9550. Synced items transcode normally. Then when sync it tries to start syncing an error occurs and the server starts to transcode the last bit of the file and then tries to sync again. This process repeats indefinitely. I have tried several things such as reinstalling the app, changing the sync storage location and clearing the sync storage location among others things, but no luck yet. Would be happy to post the logs if it would be of help. I think the problem might be more widespread than you think, I'm guessing most people just don't take the time to post.

  • chaosmakerchaosmaker Members, Plex Pass Posts: 537 Plex Pass

    I've had the problem myself but usually it shows "metadata error" on the sync page in the app. I could fix it by removing the sync item refreshing the metadata on the server and then setting the sync up again.
    For some reason the UWP app is not very good with dealing with these errors and even though we push Plex to help we don't seem to get much :disappointed:

  • jkbucketheadjkbuckethead Members, Plex Pass Posts: 15 Plex Pass

    @chaosmaker said:
    From the logs it looked like there was an issue with the metadata. As it was complaining it couldn't download that. Have you tried syncing different items?

    Yes, I have tried several different television programs and a movie. Sadly the results have been the same.

  • jkbucketheadjkbuckethead Members, Plex Pass Posts: 15 Plex Pass

    @chaosmaker said:
    For some reason the UWP app is not very good with dealing with these errors and even though we push Plex to help we don't seem to get much :disappointed:

    This got me thinking. Plex doesn't actually have any real support other than users helping users. That really sucks. No support is okay for free software, but once I paid them I kind of expect something more. You think they would at least monitor the plex pass forum.

  • jkbucketheadjkbuckethead Members, Plex Pass Posts: 15 Plex Pass

    @chaosmaker said:
    Can you check whether the new server version might have fixed your issue? There was a fix for bad XML production during sync! Hopefully that fixes your issue!

    I loaded the server update, and rebooted the computer hosting the server. Still, nothing will transfer to my laptop or my desktop.

    Plex won't provide support via email, but maybe I'll get somewhere asking for a refund on my plex pass. The only reason I got it was for mobile sync so if sync isn't working they aren't providing any value.

  • MovieFan.PlexMovieFan.Plex Members, Plex Pass, Plex Ninja Posts: 17,623 Plex Employee

    @jkbuckethead said:
    This got me thinking. Plex doesn't actually have any real support other than users helping users. That really sucks. No support is okay for free software, but once I paid them I kind of expect something more. You think they would at least monitor the plex pass forum.

    We do monitor the forums, but there are a lot of thread for us to go through. We provide the same level of help for all our users, paid or free.

    @jkbuckethead said:
    I loaded the server update, and rebooted the computer hosting the server. Still, nothing will transfer to my laptop or my desktop.

    We are aware that mobile sync is broken in the Windows App. As you have found, there hasn't been an update for this app in a while. Unfortunately, I do not have any information on when an update to the app may happen to address this issue, as well as other issues with the app that have come up since the last update.

  • jkbucketheadjkbuckethead Members, Plex Pass Posts: 15 Plex Pass

    @MovieFan.Plex said:

    We are aware that mobile sync is broken in the Windows App. As you have found, there hasn't been an update for this app in a while. Unfortunately, I do not have any information on when an update to the app may happen to address this issue, as well as other issues with the app that have come up since the last update.

    Thanks for your response. I know that mobile sync used to work with windows 10 as I was able to sync my windows 10 surface in the past. Do you at least know what broke sync for windows?

    If it was a plex update, can I at least back the server or player app to make sync work. Mobile sync is my primary concern so I don't mind temporarily sacrificing some newer features to get it working.

  • MovieFan.PlexMovieFan.Plex Members, Plex Pass, Plex Ninja Posts: 17,623 Plex Employee
    edited March 1

    Considering the app hasn't been updated in a long while, it was most likely a PMS update, but I have no idea which version. You can try downgrading to an earlier version, but I can't point you to a specific version. We also don't offer the older versions. Check your upgrades folder in your PMS appdata folder.

    Edit - We are looking to see what might have caused the issue, so it is not being ignored, just not a quick and easy thing to find.

  • MovieFan.PlexMovieFan.Plex Members, Plex Pass, Plex Ninja Posts: 17,623 Plex Employee

    Well good news. We think we found the issue. It's on our backend so you don't need to update anything. You may need to recreate the sync job, put files should start transferring.

  • stephen.hstephen.h Members, Plex Pass Posts: 9 Plex Pass

    Wow that is wonderful news! I'm testing it out now and, so far, all seems to be back to normal. I no longer receive the "Unable to save sync item Expected X-Plex-Sync-Version:2" error message when trying to sync. I will report back if I still have any issues. Thank you very much for taking the time to figure this one out :)

  • stephen.hstephen.h Members, Plex Pass Posts: 9 Plex Pass

    It works!
    It appears that this has simultaneously fixed the semi-related issue I was having with sync on Android which was causing my Pixel to repeatedly crash/restart during every background sync attempt about every 3 minutes once unlocked.

  • MovieFan.PlexMovieFan.Plex Members, Plex Pass, Plex Ninja Posts: 17,623 Plex Employee

    @stephen.h said:
    It works!
    It appears that this has simultaneously fixed the semi-related issue I was having with sync on Android which was causing my Pixel to repeatedly crash/restart during every background sync attempt about every 3 minutes once unlocked.

    That's odd. Nothing was changed related to Android, so if this somehow fixed things for you, horray for magical fixes.

«1
Sign In or Register to comment.