If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

New Buffering/Lag issues with Chromecast

2

Answers

  • mastersengirmastersengir Posts: 14Members, Plex Pass Plex Pass

    Have tested it on both ultra and normal chromecast and it seems to be only the normal chromecast for me that stutters

  • DafreakzoDafreakzo Posts: 178Members, Plex Pass Plex Pass

    @mastersengir said:
    Have tested it on both ultra and normal chromecast and it seems to be only the normal chromecast for me that stutters

    I'm using the first gen Chromecast as well and it's def stuttering.

  • JesperhkJesperhk Posts: 1Members, Plex Pass Plex Pass

    I have multiple users who complain about these buffering/lag problems when they cast from iPhone/android to Chromecast aswell, is it possible to roleback chromecast versions?

  • SensMediaSensMedia Posts: 3Members, Plex Pass Plex Pass

    Hello, I also have been having issues with this, for about the same time.
    This is what i have done, to try to sort it out
    Casting to google chrome cast over the internet, with any device be it android, windows pc, or apple, the video would start to stutter every 8 minutes if subtitles where on, disabling the subtitles poses no problem, and the video has no stutter.
    I have tried downgrading the plex server, and it proved ineffective.
    I also tried multiple versions of plex apps that start the cast in android and the result was again the same. :(
    I have been watching my plex server when the stutter starts, to see if its some sort of over load, but its doing basically nothing.
    I have a 200Mb upload line so the issue cannot be with the upload.
    I finally ran out of ideas, for what's going on.

    This is hopping that someone finds a solution for it.

    Best Regards.

  • DafreakzoDafreakzo Posts: 178Members, Plex Pass Plex Pass
    edited April 16

    Yeah, this happens for me when no sub titles are enabled.

  • Dom CDom C Plex Employee Posts: 1,232Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    Just to confirm - is this on a local network? Does reducing the quality improve the situation? Is the Chromecast wired/wireless?

  • SensMediaSensMedia Posts: 3Members, Plex Pass Plex Pass

    In my situation, its on local network, or via the internet, if i switch to lower quality say 720p 2MB, sometimes it will not stutter, but this wasn't an issue before, i could easely play a 6Mbit file with out a problem.
    My chromecast are wireless

  • DafreakzoDafreakzo Posts: 178Members, Plex Pass Plex Pass

    My server is hardwired into our network but this seems to only happen on my Chromecast devices via wifi. As @SensMedia stated, this didn't happen prior to the update.

  • AsunzsAsunzs Posts: 5Members, Plex Pass Plex Pass

    I also have problems with chromecast 2 & ultra on wifi.
    But on local networks (wifi) it works fine but immediately I'm out of the house and want to watch a movie at my boyfriend a film works 15 min before it has buffer problems and series is after 7 min .. and that's tested today on the ultra ... so hope the buffer problem disappears.

  • KTKRadioKTKRadio Posts: 7Members, Plex Pass Plex Pass

    I'm having the same issue. The problem starts after about 15-20 minutes and then I have to recast the movie to continue watching. No problem what so ever on any other platform or device.

  • jeanfrgros@gmail.comjeanfrgros@gmail.com Posts: 1Members, Plex Pass Plex Pass

    Experiencing the same issue as KTKRadio. Being on a local network or not, wired or not, using either a chromecast gen 2 or chromecast Ultra. It doesn't matter whether the file is being direct streamed or transcoded, after approximatelly 15-20 minutes the video playback will start stuttering/buffering every 1-2 seconds. Stoping the playback and resuming fixes the issue until it comes back after another 15-20 minutes.

  • Jonathan-458Jonathan-458 Posts: 13Members, Plex Pass Plex Pass

    Same issue here.

    When casting externaly both Chromecast 1 & 2 start buffering without any clear reason after 15-20min, after restarting or down or upgrading the quality it seems to work fine for another 15-20min before the same thing starts happening.

    No one has a chromecast ultra to test though.

    I'm having this issue for about a few months now, the problem doesn't seem to arise when using Emby or Qnap Video streams via CC or when using Plex on Xbox or PlayStation.

  • mattrakmattrak Posts: 20Members, Plex Pass Plex Pass
    edited May 4

    Same issue here. Stuttering/buffering non stop after 10 minutes, unwatchable. Then I disable direct play, after a lot of seeking through the episode, I was able to get subtitles sets to "always burn" by the server and I watched 48 minutes without issue. The server was transcoding

  • el_crossoel_crosso Posts: 2Members

    The same exact issue as stated earlier. After 10-15 minutes the content starts buffering and Plex eventually will stop. Scaling down doesn't work or without subs, its still doing it.

  • el_crossoel_crosso Posts: 2Members

    Most recent app update has not fixed the issue.

  • mattrakmattrak Posts: 20Members, Plex Pass Plex Pass

    I try to watch an episode with this new version, it starts buffering after 20 minutes, never recover. Had to stop and restart to resume

  • DafreakzoDafreakzo Posts: 178Members, Plex Pass Plex Pass
    edited May 22

    I never experienced this issue with sub titles. But can confirm that this is no longer happening under the circumstances provided in the op post. Thanks guys! Now get going on the Google Assistant voice support for Google Home devices that everyone is asking for. Thanks again!

  • GibbssGibbss Posts: 5Members ✭✭

    Is anyone still experiencing issues with buffering? I'm not using any subtitles, just using the Plex app on my iPhone 7 and casting it to my Chromecast. Watching videos in a browser window on my PC yields much better results.

  • eliferelifer Posts: 15Members ✭✭

    I'm still having problems, even with the new 3.52 Chromecast client.
    I tried a few cases and have buffering with and without subtitles (I haven't modified my Chromecast.xml file).
    Sometimes it starts after 15-20 min, sometimes after 2 min (this usually happens when I managed to finish an episode, and so the next one starts buffering right at the beginning)
    I checked the Now Playing tab in my server and noticed that in all cases the video stream says DirectStream. For some videos the audio is transcoded from AC3 to AAC, and for others it's also DirectStreamed. Either way it buffers, so it doesn't make a difference.
    If I wait for a really long time the video eventually continues. Otherwise I need to stop and start, as other people mentioned.
    When it's buffering the server is not doing much. CPU usage (and especially the Plex transcoding process) is next to idle.
    The logs don't seem to show much, other than it's buffering.
    Is this what others are still experiencing?

2
Sign In or Register to comment.