If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

SRT external subtitles won't display on Nvidia Shield TV unless I set burn to "Always"

Ranger34Ranger34 Posts: 12Members ✭✭
edited February 26 in NVIDIA SHIELD

In the past this has not been a problem, but recently my Shield TV will only show my subtitles if I set burn subtitles to "Always".

The subtitles are in an external SRT format. I have had no trouble with them on other plex clients i.e. the Web or my Android phone. What I mean to say is that on any other device, I can set burn subtitles to "only image formats" and they work. It is only on the Shield that I must set it to "Always".

My Server is being hosted on the Shield device.

Answers

  • Ranger34Ranger34 Posts: 12Members ✭✭
    edited February 26

    I have tried resetting my Shield to factory settings and that did not help.

  • inkubuxinkubux Posts: 11Members, Plex Pass Plex Pass

    I have a similar issue, to fix it I need to select the subtitle after starting to play then exit and close the app... restart the app and the external subtitles will be there...

  • Ranger34Ranger34 Posts: 12Members ✭✭

    Hmm that didn't work for me. I selected the subtitle and restarted the app, then went back and resumed the movie. Still nothing. Although this is strange, when I select my external SRT I see the chapter title on the bottom of the screen, instead of actual dialogue.

  • Ranger34Ranger34 Posts: 12Members ✭✭
    edited March 29

    Found the perfect temporary solution. Ditch the Android Plex Media Player and use the Plex Kodi add-on. It is a million times more responsive, the thumbnails actually work, and lo and behold, the subtitles work flawlessly. I've set the Plex Kodi-addon to automatically launch when I launch Kodi, so it's really no different except for the icon. And the interface is 10 times better. For those experiencing bugs with Plex on the Shield, I recommend installing Kodi and then the Plex addon. You won't look back.

    I hope they fix this soon, I like the Android TV version of Plex a I need the srt subs to work.

  • number8.1number8.1 Posts: 95Members ✭✭

    @Ranger34 said:
    Found the perfect solution. Ditch the Android Plex Media Player and use the Plex Kodi add-on. It is a million times more responsive, the thumbnails actually work, and lo and behold, the subtitles work flawlessly. I've set the Plex Kodi-addon to automatically launch when I launch Kodi, so it's really no different except for the icon. And the interface is 10 times better. For those experiencing bugs with Plex on the Shield, I recommend installing Kodi and then the Plex addon. You won't look back.

    Are you having plex server on shield as well?

  • Ranger34Ranger34 Posts: 12Members ✭✭

    Yes, my Server is also on the Shield TV.

  • mtappertmtappert Posts: 58Members, Plex Pass Plex Pass

    I have a server on PC and a Synology NAS and the ONLY way I can get .srt files to work on the Shield, or any android device is to burn them in. I have contacted Plex about 20 times since this issue started (with the move to Exo Player v2. This is killing my and my family's Plex viewing experience because we ALWAYS use subtitles. Please, please android app team fix this.. and let us know how long till it's fixed.

Sign In or Register to comment.