If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Cannot play 4k content on Chromecast Ultra after latest Plex Server update

pankrashkin.andrey@gmail.compankrashkin.andrey@gmail.com Posts: 4Members, Plex Pass Plex Pass

Hello everyone!

I'm having a problem with playing 4k video on my Chromecast Ultra after latest update to version

Now every time I try playng video on Chromecast it just stops playing and displays "Ready to Cast" screen.
I'm playing the same video file I've played on it before: 4k, HEVEC, 67825 kbps. Detailed info is on screenshot below:

What am I doing wrong? What happened?


  • gjas18gjas18 Posts: 11Members, Plex Pass Plex Pass

    Same problem here with version of Plex Server

    Codec HEVC
    Bitrate 57400 kbps
    Bit Depth 10
    Chroma Subsampling 4:2:0
    Color Primaries bt2020
    Color Range tv
    Color Space bt2020nc
    Color Trc smpte2084
    Frame Rate 23.976 fps
    Height 2160
    Level 5.1
    Profile main 10
    Ref Frames 1

  • chrisallenchrisallen New ZealandPosts: 668Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    Hey guys, could you please provide your Plex Media Server logs that cover your playback attempts? this will help us understand why your 4K files are not playing.


    (no private messages for support unless requested, please)

  • flaviosantiniflaviosantini Posts: 21Members, Plex Pass Plex Pass

    I'm also having the same issue. This is frustrating.

    Here is the zip for the Log Files.

  • flaviosantiniflaviosantini Posts: 21Members, Plex Pass Plex Pass

    One important thing to mention, it always stop at the same time, although each file has its own sweet (bitter?) spot.
    Coco always stops at 14 seconds
    Thor Ragnarok at 47 seconds
    Daddy's Home 2 at 30 something seconds

    But for each movie, always at the same time. I can't also play those files on an Apple TV 4K.

    This makes me think it must be something related, yes with the latest upgrade from Google but also, with something that Plex is trying to send to Chromecast.

    More info: I have downgraded the Plex Server to 1.9 (the oldest I have on my Windows PC) and the problem still occurs.

    The only way to bypass the problem is if I change the Profile to force Transcoding from HEVC to 264 (? - I think this is the one...)

    Come one guys! We're counting on you!

  • flaviosantiniflaviosantini Posts: 21Members, Plex Pass Plex Pass

    @chrisallen no comments?

    Come on Plex folks, help us out here!

  • gjas18gjas18 Posts: 11Members, Plex Pass Plex Pass
    edited March 17

    Here are my log files after trying to play 2 different 4k movies that both stop after playing for a few seconds. This is with the latest Plex Server 12.1 and Android app to a Chromecast Ultra running firmware 113131.

  • gjas18gjas18 Posts: 11Members, Plex Pass Plex Pass

    Looking at the logs myself this seems to be when it has the issue. It chunks the first bit of playback then errors out:

    Mar 16, 2018 21:18:50.111 [0x7f33bc3ff700] INFO - [Chromecast] [Player] Playback is ready

    Mar 16, 2018 21:19:43.995 [0x7f33b67fe700] ERROR - Failed to delete session directory (boost::filesystem::remove: No such file or directory: "/var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Cache/Transcode/Sessions/plex-transcode-zn8g1809lpp7ezovr9et808i-2d9e562c-8cdc-4b6b-91b4-f9463ccaef1b/chunk-00132")
    Mar 16, 2018 21:19:44.727 [0x7f33be3fd700] INFO - [Chromecast] [Player] Stopping playback. DashPlayer: false
    Mar 16, 2018 21:19:44.772 [0x7f33c6ffe700] INFO - [Chromecast] [Player] removing src attribute
    Mar 16, 2018 21:19:44.817 [0x7f33c1fff700] INFO - [Chromecast] [Player] Removing media element
    Mar 16, 2018 21:19:50.210 [0x7f33da7fc800] WARN - Timed out waiting for server to finish.

  • jake1829jake1829 Posts: 1Members, Plex Pass Plex Pass

    Yep same issue here all my 4K content will stop playing after a min or less - files that use to stream with no issues before


  • HerrMossbergHerrMossberg Posts: 1Members

    Same problem here, 4k content stops streaming after less than a minute.

  • gjas18gjas18 Posts: 11Members, Plex Pass Plex Pass

    When I watch the server activity while it does this it looks like it's transcoding hevc to h264.

Sign In or Register to comment.