Our forum migration to Discourse is underway and scheduled to last through June 21. During the migration, the forums will be read-only, except for a single temporary forum (contents of which will not be getting transferred). Read our announcement post for more information about the forum migration.
Hey folks, there is a new Podcast category for forums https://forums.plex.tv/categories/podcasts
If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Plex Will not Start

RatokaRatoka Members, Plex Pass Posts: 17 Plex Pass

When upgrading FreeNAS to U2, Plex will no longer start with the following error:
Mar 01, 2018 11:29:12.047 [0x80a2c6f00] INFO - Plex Media Server v1.11.3.4803-c40bba82e - FreeBSD PC amd64 - build: freebsd-x86_64 freebsd - GMT -08:00
Mar 01, 2018 11:29:12.047 [0x80a2c6f00] ERROR - Failed to determine system locale: locale::facet::_S_create_c_locale name not valid. Defaulting to en-US.
Mar 01, 2018 11:29:12.047 [0x80a2c6f00] INFO - FreeBSD version: 11.1-STABLE (FreeBSD 11.1-STABLE #0 r321665+de6be8c8d30(freenas/11.1-stable): Tue Feb 20 02:38:09 UTC 2018 root@gauntlet:/freenas-11-releng/freenas/_BE/objs/freenas-11-releng/freenas/_BE/os/sys/FreeNAS.amd64), language: en-US
Mar 01, 2018 11:29:12.047 [0x80a2c6f00] INFO - Processor AMD FX(tm)-6300 Six-Core Processor
Mar 01, 2018 11:29:12.047 [0x80a2c6f00] INFO - /usr/local/share/plexmediaserver-plexpass/Plex_Media_Server
Mar 01, 2018 11:29:12.044 [0x80a218000] WARN - Default locale is invalid; falling back on classic+UTF-8
Mar 01, 2018 11:29:12.053 [0x80a218000] INFO - SQLITE3:0x10, 283, recovered 784 frames from WAL file /config/Plex Media Server/Plug-in Support/Databases/com.plexapp.plugins.library.db-wal
Mar 01, 2018 11:29:12.207 [0x80a218000] INFO - SQLITE3:0x10, 283, recovered 901 frames from WAL file /config/Plex Media Server/Plug-in Support/Databases/com.plexapp.plugins.library.blobs.db-wal
Mar 01, 2018 11:29:12.227 [0x80a218000] ERROR - HttpServer: Error binding acceptor: Can't assign requested address
Mar 01, 2018 11:29:12.228 [0x80a218000] ERROR - Error: Unable to set up server: listen: Can't assign requested address (N5boost16exception_detail10clone_implINS0_19error_info_injectorINS_6system12system_errorEEEEE)

I can revert to U1, and Plex will again start. Is there anything that can be tweaked on the Plex side, or is there additional information that I can provide to the FreeNAS team for help on the server side?

I found a topic about setting EnableIPv6 to 0, but I did not have this setting in my preference file. Adding the preference made no difference for me.

Thank you in advance!

Answers

  • gbooker02gbooker02 Members, Plex Employee, Plex Pass, Plex Ninja Posts: 696 Plex Employee

    HttpServer: Error binding acceptor: Can't assign requested address

    You likely have something already running on the port or you may be missing the loopback interface.

Sign In or Register to comment.