Hey folks, there is a new Podcast category for forums https://forums.plex.tv/categories/podcasts
If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Can't Direct Play, Direct Stream or Transcode 1080p on Apple TV

thehills.housethehills.house Posts: 3Validating, Plex Pass Plex Pass

Hello All,

I have searched these forums for days and cannot find what my issue is so here goes.

Here is my setup:

Server: SSDNodes KVM-XL
PMS: v1.12.0.4829
RAM: 16GB
HD: 80GB SSD
CPU: 4core vcpu
Unixbench Score: 3920.9
Dropbox Mounted using RClone

Client with Issues
Apple TV 4K
tvOS: 11.2.6
Plex App: v1.24.1 (8229)

My current issues:
1. Most of my media is in .mkv containers but is H.264 and AAC so my server should be able to handle at least 1 DirectSteam at 1080p of that content, however on ATV when trying to play a video I get the 'This server is not powerful enough to convert video'. After following the forms here, I looked at my plex logs and I did see that my transcode speed was <1 so I assumed that my server was in fact not powerful enough despite 1080p content working on other devices (iOS, Chrome, etc). So how do I determine if my VPS is in fact powerful enough and it's more related to my configuration of PMS or RClone?

  1. Since it seemed my server was not powerful enough I decided to convert 1 of my .mkv files to .m4v to get the server to support direct play and lessen the strain on the server. Once I converted the file I can successfully get direct play on my Mac but the ATV app hangs and the stream doesn't even start when trying to do Direct Play.

I am at a loss as to how to proceed with these issues. I would be happy to upload any logs or run any tests.

Thanks for any help here.

Answers

  • T'hain Esh KelchT'hain Esh Kelch Posts: 426Members ✭✭✭

    You should try and remux the file instead of converting it, so you can figure out if the codecs you are using for the original file is the problem.

  • thehills.housethehills.house Posts: 3Validating, Plex Pass Plex Pass
    edited March 10

    @T'hain Esh Kelch said:
    You should try and remux the file instead of converting it, so you can figure out if the codecs you are using for the original file is the problem.

    Thank you for the suggestion. So I remuxed one of my MKV files into an m4v file using Subler and was able to get the server to try and direct play it (As opposed to before where direct play wouldn't even start). It runs sometimes but when it does it hangs every so often and then there are types where it won't even play. My local internet speeds are 250 - 300 mbps so I know its not connection issues.

    When I tail the Plex Media Server.log file every so often I get this line.

    Failed to stream media, client probably disconnected after 5275648 bytes: 32 - Broken pipe

    So would you say this is an issue with the media or with the server?

  • T'hain Esh KelchT'hain Esh Kelch Posts: 426Members ✭✭✭

    You mention your Internet speed, so are you streaming over the Internet? Otherwise that is completely irrelevant.

    And based on your error, it is neither media or server - it is the client, or your network.

  • thehills.housethehills.house Posts: 3Validating, Plex Pass Plex Pass

    Yes, I am streaming over the internet. Since PMS is running on a VPS to have better global network support than running it locally.

    SSDnodes has their data center in Dallas.

    So does that mean its the ATV client? Is there any way to confirm that, and if so what are my options? I know people are successful at doing this using ATV.

  • trudgetrudge Posts: 2,275Members, Plex Pass Plex Pass

    setup a small local server with a local test file that doesnt play from the remote server and see if it's any different.

  • TwistedEndzTwistedEndz Posts: 292Members, Plex Pass Plex Pass

    im also having problems with ssdnodes kvm server mine is in canada and it used to work good but now it wont play **** . ither server is not powerful enough or not enough bandwidth

Sign In or Register to comment.