Our forum migration to Discourse is underway and scheduled to last through June 21. During the migration, the forums will be read-only, except for a single temporary forum (contents of which will not be getting transferred). Read our announcement post for more information about the forum migration.
Hey folks, there is a new Podcast category for forums https://forums.plex.tv/categories/podcasts
If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

[PMP2.6-2.9] Pause OSD not hiding on resuming playback

dan-the-man-dan-the-man- Members, Plex Pass Posts: 453 Plex Pass
edited April 23 in Plex Media Player

Plex Media Player version: 2.6.- 2.9 - Win10 -

issue created here https://github.com/plexinc/plex-media-player/issues/703

This issue did not happen on versions before 2.6

when pausing a playing video, the OSD comes up as normal, however when resuming the video, the OSD is stuck on the screen (nearly everytime - sometimes if you do pause/play quick enough it will go away)

i have tested it on 2 different PMP installs, and i can reproduce it using the MCE remote, space on the keyboard and P on the keyboard to play pause.

Tagged:

Best Answer

  • dan-the-man-dan-the-man- Members, Plex Pass Posts: 453 Plex Pass
    Accepted Answer

    thankyou, this is fixed in the Plex Media Player version: 2.10.0.849 release

«1

Answers

  • darciliciousdarcilicious Members, Plex Pass Posts: 935 Plex Pass

    Happens on macOS too.

  • AchillesAchilles Members, Plex Pass, Plex Ninja Posts: 2,270 Plex Ninja

    Out of curiousity, are you using the Plex screensaver and having to enter your username PIN?

  • dan-the-man-dan-the-man- Members, Plex Pass Posts: 453 Plex Pass

    @Achilles said:
    Out of curiousity, are you using the Plex screensaver and having to enter your username PIN?

    no to both

  • darciliciousdarcilicious Members, Plex Pass Posts: 935 Plex Pass

    No to both

  • jfgilliamjfgilliam Members, Plex Pass Posts: 106 Plex Pass

    I OSD will not go away if your mouse leaves the window from the top or bottom. Move it out on the left or right sides and it does.

    I think the problem is PMP is not getting a mouse exiting event when you move the mouse out of the frame from the top or the bottom. I'm a developer and I see this in a program I'm writing. I don't know how to fix it (windows bug maybe?)


    Plex Pass User Since October 2017, BETA Channel
    Clients: Roku Preview, AppleTV, iOS, Androd, LG TV, XBOX ONE
    Hardware Transcoding, HDHomeRun Prime and Quatro. Only Prime enabled for the DVR.
    Windows 10 Home 64-Bit, 512GB SSD, 2TB HD, 16GB RAM
    CPU - AMD FX(tm)-8350 Eight-Core 4.00 Ghz
    GPU - AMD R9-7970 280X

  • Defunct4Defunct4 Members, Plex Pass Posts: 5 Plex Pass

    This also happens on Xbox one with the media remote. Using the pause/play button, the OSD stays on screen. If you use the select button to pause/play the OSD goes away (as it should). This is very annoying. Please fix.

  • darciliciousdarcilicious Members, Plex Pass Posts: 935 Plex Pass

    I OSD will not go away if your mouse leaves the window from the top or bottom. Move it out on the left or right sides and it does.

    THANK YOU. This work around works on PMP running on macOS as well.

  • dan-the-man-dan-the-man- Members, Plex Pass Posts: 453 Plex Pass

    @jfgilliam said:
    I OSD will not go away if your mouse leaves the window from the top or bottom. Move it out on the left or right sides and it does.

    I think the problem is PMP is not getting a mouse exiting event when you move the mouse out of the frame from the top or the bottom. I'm a developer and I see this in a program I'm writing. I don't know how to fix it (windows bug maybe?)

    Im not running a mouse on any of my HTPCs just a standard remote, so using the mouse to fix it is not a solution, the only workaround is to press the back button to make the OSD disappear on resuming playback

    i will probably downgrade back to 2.5 for now

  • Stig N. OlsenStig N. Olsen Members, Plex Pass Posts: 16 Plex Pass
    edited March 13

    Same happens to me to on both installations of PMP 2.6.
    I've tried with and without mouse disabled but that don't impact the behavior.
    Couldn't find any flag in config file to set timeout of OSD either so think reverting to 2.5 is the best option at the moment.

    Anyone know if downgrading is a problem?

  • dan-the-man-dan-the-man- Members, Plex Pass Posts: 453 Plex Pass

    this is not fixed on the 2.7 release :/

    it is super annoying because if you use a MCE remote the only option is to stop playback and restart it to get rid of it, as for some strange reason the back button on the MCE remote will quit playback instead of removing the OSD like the backspace/esc on the keyboard

  • Stig N. OlsenStig N. Olsen Members, Plex Pass Posts: 16 Plex Pass

    I'm still on version 2.5 because of this and I hope we get a moderator or bug hunter through this post so that it can get confirmed as a bug.

  • Stig N. OlsenStig N. Olsen Members, Plex Pass Posts: 16 Plex Pass

    Maybe tag it with #Problem and #Bug but I'm not sure these are being used?

  • generatorgenerator Members, Plex Pass Posts: 85 Plex Pass

    Same problem for me, OSD doesn't auto hide on resume most of the times. The mouse cursor shouldn't be the issue since I'm only using a remote control.

  • dan-the-man-dan-the-man- Members, Plex Pass Posts: 453 Plex Pass

    this pause OSD bug introduced in 2.6 is still not fixed in 2.8, pretty disappointing,

    log attached from 2.8 reproducing the issue.

    there is no other issues with the OSD in terms of Skipping forward back etc, that disappears correctly, its only when paused does this happen.

  • Stig N. OlsenStig N. Olsen Members, Plex Pass Posts: 16 Plex Pass

    I see that the OSD bug still isn't solved in the new version 2.8. Could a moderator confirm this as a bug?

  • Defunct4Defunct4 Members, Plex Pass Posts: 5 Plex Pass

    Still a problem with Xbox media remote. Pressing the pause button pauses playback and shows the OSD. Pressing it again resumes playback but leaves the OSD on screen. The only way to remove it is to re-pause and use the select button (instead of pause button) to resume. Very annoying.

  • shark2kshark2k Members, Plex Pass Posts: 161 Plex Pass

    For those using PMP on a computer (I use it on Windows 7, so not sure about embedded platforms and whatnot) but I am experiencing this also, however I have a work-a-round for those that don't have a mouse attached. If I use the pause/play buttons on my remote, the OSD does not hide. However, if I use the enter/OK button on the remote (when the OSD is up) to resume, the OSD will hide like it's supposed to.

    I can clarify that if it's not clear for anyone.

    Hopefully they will resolve this in the next release so it works like it used to, as it's annoying not being able to resume by just pressing play.

    -Shark2k

  • dan-the-man-dan-the-man- Members, Plex Pass Posts: 453 Plex Pass

    this is still broken in the 2.9 release

    would be nice you guys addressed this since it was something that used to work perfectly fine until the 2.6 release onwards

  • Stig N. OlsenStig N. Olsen Members, Plex Pass Posts: 16 Plex Pass

    Still broken after three releases? Would be nice if someone in the developer team addressed this.

  • tonidiekservertonidiekserver Members, Plex Pass Posts: 1 Plex Pass

    Same problem on windows 10 when pause with space button.

«1
Sign In or Register to comment.