Our forum migration to Discourse is underway and scheduled to last through June 21. During the migration, the forums will be read-only, except for a single temporary forum (contents of which will not be getting transferred). Read our announcement post for more information about the forum migration.
Hey folks, there is a new Podcast category for forums https://forums.plex.tv/categories/podcasts
If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Some Movies Won't Play

Brian_BurdetteBrian_Burdette Members, Plex Pass Posts: 5 Plex Pass

Hello -

I recently upgraded to Plex pass. This week I imported some new movies into my account that are new to market.

When I try and play some them, I just get a "Playback Error: An Error Occurred Loading Items to Play" error.

The weird thing is it's only some files, and there doesn't seem to be any rhyme or reason - it's not all files, some new work, some old work, some new don't work, some old don't work.

ALL files, however, work fine when played through iTunes (locally) as well as over AppleTV via Wi-Fi (with iTunes as media server).

Not sure how to proceed with diagnosing and fixing the issue since there is no other info.

Any thoughts from anyone?

Answers

  • tom80Htom80H Members, Plex Pass Posts: 2,273 Plex Pass

    reproduce the error, wait a moment (~1 min), download logs (Settings > Server > Help > Download Logs) and upload them here.

  • Brian_BurdetteBrian_Burdette Members, Plex Pass Posts: 5 Plex Pass

    Here you go. Thank you. The file I tried to watch was "Thor: Ragnarok".

  • tom80Htom80H Members, Plex Pass Posts: 2,273 Plex Pass

    you should try to repair your library... the log reports some issues with that (at least with 2 lines which keep causing trouble) -- however that should not be what's stopping the server from playing your video.

    Plex is searching the Thor movie in /Volumes/BACKUP 1/Movies but fails to find it. Is that where your movies are stored? Can you confirm the file is named Thor - Ragnarok.m4v?

    BACKUP 1 sounds like you're using an external disk... could it be your Mac / Plex temporarily lost connection to that drive?

  • Brian_BurdetteBrian_Burdette Members, Plex Pass Posts: 5 Plex Pass

    Thank you - it's possible connection was lost, but unlikely. All my movies are stored in that folder, and some play while others do not.

    Even within the same "batch" of movies - I uploaded 5 new ones including Thor, Coco, Home Again, etc., Some work, and some don't.

    Yes, file name is correct.

    Are there steps to repairing a library? I am considering possibly removing the library entirely and starting over, but I would prefer to not if at all possible.

  • tom80Htom80H Members, Plex Pass Posts: 2,273 Plex Pass

    Here’s the link on how to repair the database:
    https://support.plex.tv/articles/201100678-repair-a-corrupt-database/
    On macOS there also used to be a direct option to repair the database from within Plex Web.

    Depending on how you formatted your drive the movie being not accessible could also be related to a permissions problem.

  • Brian_BurdetteBrian_Burdette Members, Plex Pass Posts: 5 Plex Pass

    Okay, so update:

    This morning I tried a different drive, different location, different movie file. Same problem. I copied the working file (again, working correctly in iTunes), into a new folder on the new drive. Then I just added that new, single file into Plex in a new library called "New Test".

    Attached is an updated log file. Can anyone provide any more insight? Lots of my older stuff is working and some of the newer stuff. This is confusing and frustrating!

  • Brian_BurdetteBrian_Burdette Members, Plex Pass Posts: 5 Plex Pass

    Another update: repairing library using steps above seems to have worked so far. Will check and see how things work over the next few days but it's looking better so far!

    The only piece of the instructions that didn't work was the instruction to delete the following two files:

    com.plexapp.plugins.library.db-shm
    com.plexapp.plugins.library.db-wal

    Terminal said file wasn't found, but even without that piece, the movies did start working.

    Thanks to all for help!

Sign In or Register to comment.