Our forum migration to Discourse is underway and scheduled to last through June 21. During the migration, the forums will be read-only, except for a single temporary forum (contents of which will not be getting transferred). Read our announcement post for more information about the forum migration.
Hey folks, there is a new Podcast category for forums https://forums.plex.tv/categories/podcasts
If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

PMS daily crash after a Full Server Reinstall from Backup, New Quadro GPU

kabbaniokabbanio Members, Plex Pass Posts: 20 Plex Pass
edited March 19 in Windows

Never had issues before with my server (2-3 years)...until an unfortunate Hardware failure 3 weeks ago and inevitable Re installation of OS and Plex Server. Luckily right before the wipe, i managed to backup the Plex Server directory (Where DB resides) and copy the files back, post re-installation, it recognized the "orphan" server and adopted it :)
Unfortunately, since that fresh install, i get s PMS crash once or twice a day and i have no clue why. nothing really changed in Library structure, even drives are labeled the same. Locations are the same.
I've even updated the server version (so 2 iterations, same results)..
One exceptional change: Not all TV metadata gets refreshed properly...

System:
Windows 10 Enterprise 64bit, Ver 1709
GPU: Quadro P5000 running driver 388.16
MB: Asus Rampage 5, Edition 10, Bios 1801
CPU: i7 5820k @ 3.3 Ghz
RAM: 32 Gigs
RAID: RocketRaid 644
Storage: 2 x Mobius Raid 5 Array @ 22TB each

Best Answers

  • kabbaniokabbanio Members, Plex Pass Posts: 20 Plex Pass
    Accepted Answer

    Ok, so I ran the server for 48 hours with Hardware Acceleration on Off with no crashes.
    Then i uninstalled the Nvidia QNF driver and did a clean install of their ODE driver and switched on Hardware Acceleration and ran this for 72 hours now...no crashes. Server running smoothly. will keep this for a bit and post findings if i encounter a crash.

  • sa2000sa2000 Members, Plex Pass, Plex Ninja, Plex Team Member Posts: 31,470 Plex Team Member
    Accepted Answer

    @kabbanio said:

    @sa2000 said:

    @kabbanio said:
    sorry about. forgot to upload them. i just did

    what time was the crash?
    Logs cover Mar 19, 2018 22:21:21 to Mar 20, 2018 00:01:53
    No evidence of a server crash during this period

    Note that crash reporting logs get updated after the server restarts after a crash
    The last crash report upload log was for 13th march

    I'm not exactly sure, but i think it was around 3 pm on the 19th.

    Thanks - logs were collected over 7 hours later and have long lost what was recorded then.
    I am surprised there was no attempt to upload the crash reports. This should have happened on the restart following the 3pm crash. Is crash reporting enabled in server settings ?

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    Please do not send logs by Private Message unless specifically requested to
     
«1

Answers

  • dirtycajunricedirtycajunrice Validating, Plex Pass Posts: 169 Plex Pass

    Please remember to mark the appropriate answer(s) which solved your issue.

    My Setup:
    Plex Media Server: Ubuntu 16.04 VM
    Servers: 2x R620 each with 2x Xeon E5-2670 @ 2.60GHz / 96GB RAM
    Storage (SAN): Ubuntu 16.04 using NFS with 160TB (192TB / 2 RAID6 Pools MDADM > LVM > EXT4)
    Clients: iOS, WebUI, Nvidia Shield, Roku

  • sa2000sa2000 Members, Plex Pass, Plex Ninja, Plex Team Member Posts: 31,470 Plex Team Member

    @kabbanio said:
    Never had issues before with my server (2-3 years)...until an unfortunate Hardware failure 3 weeks ago and inevitable Re installation of OS and Plex Server. Luckily right before the wipe, i managed to backup the Plex Server directory (Where DB resides) and copy the files back, post re-installation, it recognized the "orphan" server and adopted it :)
    Unfortunately, since that fresh install, i get s PMS crash once or twice a day and i have no clue why. nothing really changed in Library structure, even drives are labeled the same. Locations are the same.
    I've even updated the server version (so 2 iterations, same results)..
    One exceptional change: Not all TV metadata gets refreshed properly...

    System:
    Windows 10 Enterprise 64bit, Ver 1709
    GPU: Quadro P5000 running driver 388.16
    MB: Asus Rampage 5, Edition 10, Bios 1801
    CPU: i7 5820k @ 3.3 Ghz
    RAM: 32 Gigs
    RAID: RocketRaid 644
    Storage: 2 x Mobius Raid 5 Array @ 22TB each

    Appear to be hardware acceleration related crashes. There is one crash in module nvcuvid.dll

    Will look further - please disable hardware transcoding or look into the drivers until i have more feedback

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    Please do not send logs by Private Message unless specifically requested to
     
  • dane22dane22 Members, Plex Pass, Plex Ninja Posts: 10,923 Plex Ninja

    I hate bugs - Tommy Lee Jones, MIB
    Join me in developing: epg-dk, str2utf-8, remidx, ExportTools, WebTools
    Support the Samsung Client:Donate
    Guides I use: Media Naming Guide, Local subtitles, Log-Files, QNAP FAQ, The Plex Dance

    NO Support via PM, unless called by me

  • sa2000sa2000 Members, Plex Pass, Plex Ninja, Plex Team Member Posts: 31,470 Plex Team Member

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    Please do not send logs by Private Message unless specifically requested to
     
  • johnm_ColaSCjohnm_ColaSC Members, Plex Pass, Plex Ninja, TunerTester Posts: 2,521 Plex Ninja

    I did it earlier

    Primary Plex Media Server
    Windows 10 Pro
    Intel Core i5-3570K, 32GB RAM
    Post Processing with MCEBuddy 2.4.7 & Comskip 0.81.093
    Test Servers: MacBook Pro, Nvidia Shield TV (16GB), Windows Laptop, Ubuntu VM
    HDHR Connect (2), HDHR Dual, HDHR Extend, HDHR Prime
    Clients - Windows, iOS, Roku, Samsung TV, Fire TV, Nvidia Shield

  • kabbaniokabbanio Members, Plex Pass Posts: 20 Plex Pass
    edited March 14

    @sa2000 said:

    @kabbanio said:
    Never had issues before with my server (2-3 years)...until an unfortunate Hardware failure 3 weeks ago and inevitable Re installation of OS and Plex Server. Luckily right before the wipe, i managed to backup the Plex Server directory (Where DB resides) and copy the files back, post re-installation, it recognized the "orphan" server and adopted it :)
    Unfortunately, since that fresh install, i get s PMS crash once or twice a day and i have no clue why. nothing really changed in Library structure, even drives are labeled the same. Locations are the same.
    I've even updated the server version (so 2 iterations, same results)..
    One exceptional change: Not all TV metadata gets refreshed properly...

    System:
    Windows 10 Enterprise 64bit, Ver 1709
    GPU: Quadro P5000 running driver 388.16
    MB: Asus Rampage 5, Edition 10, Bios 1801
    CPU: i7 5820k @ 3.3 Ghz
    RAM: 32 Gigs
    RAID: RocketRaid 644
    Storage: 2 x Mobius Raid 5 Array @ 22TB each

    Appear to be hardware acceleration related crashes. There is one crash in module nvcuvid.dll

    Will look further - please disable hardware transcoding or look into the drivers until i have more feedback

    Thanks. ok, i'll disable HW acceleration. The Quadro 5000 is a replacement of the 980 Ti (on the pre-crash system) , given it's multiple NVenc engines and unlimited Trancoding streams (Vs only 2 in the 980 Ti). I hope it's not that ...

  • sa2000sa2000 Members, Plex Pass, Plex Ninja, Plex Team Member Posts: 31,470 Plex Team Member

    @kabbanio said:

    @sa2000 said:

    @kabbanio said:
    Never had issues before with my server (2-3 years)...until an unfortunate Hardware failure 3 weeks ago and inevitable Re installation of OS and Plex Server. Luckily right before the wipe, i managed to backup the Plex Server directory (Where DB resides) and copy the files back, post re-installation, it recognized the "orphan" server and adopted it :)
    Unfortunately, since that fresh install, i get s PMS crash once or twice a day and i have no clue why. nothing really changed in Library structure, even drives are labeled the same. Locations are the same.
    I've even updated the server version (so 2 iterations, same results)..
    One exceptional change: Not all TV metadata gets refreshed properly...

    System:
    Windows 10 Enterprise 64bit, Ver 1709
    GPU: Quadro P5000 running driver 388.16
    MB: Asus Rampage 5, Edition 10, Bios 1801
    CPU: i7 5820k @ 3.3 Ghz
    RAM: 32 Gigs
    RAID: RocketRaid 644
    Storage: 2 x Mobius Raid 5 Array @ 22TB each

    Appear to be hardware acceleration related crashes. There is one crash in module nvcuvid.dll

    Will look further - please disable hardware transcoding or look into the drivers until i have more feedback

    Thanks. ok, i'll disable HW acceleration. The Quadro 5000 is a replacement of the 980 Ti (on the pre-crash system) , given it's multiple NVenc engines and unlimited Trancoding streams (Vs only 2 in the 980 Ti). I hope it's not that ...

    This is the support article for hardware transcoding
    https://support.plex.tv/articles/115002178853-using-hardware-accelerated-streaming/

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    Please do not send logs by Private Message unless specifically requested to
     
  • sa2000sa2000 Members, Plex Pass, Plex Ninja, Plex Team Member Posts: 31,470 Plex Team Member

    @kabbanio said:

    @sa2000 said:

    @kabbanio said:
    Never had issues before with my server (2-3 years)...until an unfortunate Hardware failure 3 weeks ago and inevitable Re installation of OS and Plex Server. Luckily right before the wipe, i managed to backup the Plex Server directory (Where DB resides) and copy the files back, post re-installation, it recognized the "orphan" server and adopted it :)
    Unfortunately, since that fresh install, i get s PMS crash once or twice a day and i have no clue why. nothing really changed in Library structure, even drives are labeled the same. Locations are the same.
    I've even updated the server version (so 2 iterations, same results)..
    One exceptional change: Not all TV metadata gets refreshed properly...

    System:
    Windows 10 Enterprise 64bit, Ver 1709
    GPU: Quadro P5000 running driver 388.16
    MB: Asus Rampage 5, Edition 10, Bios 1801
    CPU: i7 5820k @ 3.3 Ghz
    RAM: 32 Gigs
    RAID: RocketRaid 644
    Storage: 2 x Mobius Raid 5 Array @ 22TB each

    Appear to be hardware acceleration related crashes. There is one crash in module nvcuvid.dll

    Will look further - please disable hardware transcoding or look into the drivers until i have more feedback

    Thanks. ok, i'll disable HW acceleration. The Quadro 5000 is a replacement of the 980 Ti (on the pre-crash system) , given it's multiple NVenc engines and unlimited Trancoding streams (Vs only 2 in the 980 Ti). I hope it's not that ...

    There are some changes being done to the transcoder and i will make a build available to you to try to see if it stops the crashes

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    Please do not send logs by Private Message unless specifically requested to
     
  • kabbaniokabbanio Members, Plex Pass Posts: 20 Plex Pass

    @sa2000 said:

    @kabbanio said:

    @sa2000 said:

    @kabbanio said:
    Never had issues before with my server (2-3 years)...until an unfortunate Hardware failure 3 weeks ago and inevitable Re installation of OS and Plex Server. Luckily right before the wipe, i managed to backup the Plex Server directory (Where DB resides) and copy the files back, post re-installation, it recognized the "orphan" server and adopted it :)
    Unfortunately, since that fresh install, i get s PMS crash once or twice a day and i have no clue why. nothing really changed in Library structure, even drives are labeled the same. Locations are the same.
    I've even updated the server version (so 2 iterations, same results)..
    One exceptional change: Not all TV metadata gets refreshed properly...

    System:
    Windows 10 Enterprise 64bit, Ver 1709
    GPU: Quadro P5000 running driver 388.16
    MB: Asus Rampage 5, Edition 10, Bios 1801
    CPU: i7 5820k @ 3.3 Ghz
    RAM: 32 Gigs
    RAID: RocketRaid 644
    Storage: 2 x Mobius Raid 5 Array @ 22TB each

    Appear to be hardware acceleration related crashes. There is one crash in module nvcuvid.dll

    Will look further - please disable hardware transcoding or look into the drivers until i have more feedback

    Thanks. ok, i'll disable HW acceleration. The Quadro 5000 is a replacement of the 980 Ti (on the pre-crash system) , given it's multiple NVenc engines and unlimited Trancoding streams (Vs only 2 in the 980 Ti). I hope it's not that ...

    There are some changes being done to the transcoder and i will make a build available to you to try to see if it stops the crashes

    Thanks. That would be very helpful.
    So far, since i disabled HW acceleration, it's been actually stable.
    I also noticed that Nvidia has 2 sets of drivers for Quadros.
    ODE: Optimal Driver for Enterprise
    QNF: Quadro New Feature Driver (Which i had been using)
    within the next 48 hours, if still stable on Offlined Hardware Acceleration, i will install the ODE driver and switch on Hardware Acceleration and monitor it. Will report findings.

  • kabbaniokabbanio Members, Plex Pass Posts: 20 Plex Pass
    Accepted Answer

    Ok, so I ran the server for 48 hours with Hardware Acceleration on Off with no crashes.
    Then i uninstalled the Nvidia QNF driver and did a clean install of their ODE driver and switched on Hardware Acceleration and ran this for 72 hours now...no crashes. Server running smoothly. will keep this for a bit and post findings if i encounter a crash.

  • sa2000sa2000 Members, Plex Pass, Plex Ninja, Plex Team Member Posts: 31,470 Plex Team Member

    Thanks for the feedback

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    Please do not send logs by Private Message unless specifically requested to
     
  • kabbaniokabbanio Members, Plex Pass Posts: 20 Plex Pass

    @sa2000 said:
    Thanks for the feedback

    Oh well. i had hoped Nvidia's ODE driver was the solution (QNF being the culprit) but i just experienced my first crash in 48 hours of smooth running. Seems Plex and quadro drivers dont play well together ATM when it comes to Hardware Acceleration. I hope something can be done otherwise that Quadro 5000 Card would have gone to pseudo waste with its unlimited streams and dual Transcoders (Still use it for encoding Media).

  • sa2000sa2000 Members, Plex Pass, Plex Ninja, Plex Team Member Posts: 31,470 Plex Team Member

    Logs zip please And I will look for the dumps

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    Please do not send logs by Private Message unless specifically requested to
     
  • sa2000sa2000 Members, Plex Pass, Plex Ninja, Plex Team Member Posts: 31,470 Plex Team Member

    cannot find any crash reports after the two that were uploaded 11th March and 13th March - which were as being reported in the original logs

    Do you have crash reporting enabled?

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    Please do not send logs by Private Message unless specifically requested to
     
  • kabbaniokabbanio Members, Plex Pass Posts: 20 Plex Pass

    sorry about. forgot to upload them. i just did

  • sa2000sa2000 Members, Plex Pass, Plex Ninja, Plex Team Member Posts: 31,470 Plex Team Member

    @kabbanio said:
    sorry about. forgot to upload them. i just did

    what time was the crash?
    Logs cover Mar 19, 2018 22:21:21 to Mar 20, 2018 00:01:53
    No evidence of a server crash during this period

    Note that crash reporting logs get updated after the server restarts after a crash
    The last crash report upload log was for 13th march

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    Please do not send logs by Private Message unless specifically requested to
     
  • kabbaniokabbanio Members, Plex Pass Posts: 20 Plex Pass

    @sa2000 said:

    @kabbanio said:
    sorry about. forgot to upload them. i just did

    what time was the crash?
    Logs cover Mar 19, 2018 22:21:21 to Mar 20, 2018 00:01:53
    No evidence of a server crash during this period

    Note that crash reporting logs get updated after the server restarts after a crash
    The last crash report upload log was for 13th march

    I'm not exactly sure, but i think it was around 3 pm on the 19th.

  • sa2000sa2000 Members, Plex Pass, Plex Ninja, Plex Team Member Posts: 31,470 Plex Team Member
    Accepted Answer

    @kabbanio said:

    @sa2000 said:

    @kabbanio said:
    sorry about. forgot to upload them. i just did

    what time was the crash?
    Logs cover Mar 19, 2018 22:21:21 to Mar 20, 2018 00:01:53
    No evidence of a server crash during this period

    Note that crash reporting logs get updated after the server restarts after a crash
    The last crash report upload log was for 13th march

    I'm not exactly sure, but i think it was around 3 pm on the 19th.

    Thanks - logs were collected over 7 hours later and have long lost what was recorded then.
    I am surprised there was no attempt to upload the crash reports. This should have happened on the restart following the 3pm crash. Is crash reporting enabled in server settings ?

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    Please do not send logs by Private Message unless specifically requested to
     
  • kabbaniokabbanio Members, Plex Pass Posts: 20 Plex Pass

    @sa2000 said:

    @kabbanio said:

    @sa2000 said:

    @kabbanio said:
    sorry about. forgot to upload them. i just did

    what time was the crash?
    Logs cover Mar 19, 2018 22:21:21 to Mar 20, 2018 00:01:53
    No evidence of a server crash during this period

    Note that crash reporting logs get updated after the server restarts after a crash
    The last crash report upload log was for 13th march

    I'm not exactly sure, but i think it was around 3 pm on the 19th.

    Thanks - logs were collected over 7 hours later and have long lost what was recorded then.
    I am surprised there was no attempt to upload the crash reports. This should have happened on the restart following the 3pm crash. Is crash reporting enabled in server set.

    Yes, they are. but i was not around and my wife restarted the the server hence the missed opportunitiy. Usually, i would have copies the logs before restarting.

    I'll send across cleaner, fresher logs on the next crash. sorry about that.

  • sa2000sa2000 Members, Plex Pass, Plex Ninja, Plex Team Member Posts: 31,470 Plex Team Member

    @kabbanio said:

    @sa2000 said:

    @kabbanio said:

    @sa2000 said:

    @kabbanio said:
    sorry about. forgot to upload them. i just did

    what time was the crash?
    Logs cover Mar 19, 2018 22:21:21 to Mar 20, 2018 00:01:53
    No evidence of a server crash during this period

    Note that crash reporting logs get updated after the server restarts after a crash
    The last crash report upload log was for 13th march

    I'm not exactly sure, but i think it was around 3 pm on the 19th.

    Thanks - logs were collected over 7 hours later and have long lost what was recorded then.
    I am surprised there was no attempt to upload the crash reports. This should have happened on the restart following the 3pm crash. Is crash reporting enabled in server set.

    Yes, they are. but i was not around and my wife restarted the the server hence the missed opportunitiy. Usually, i would have copies the logs before restarting.

    I'll send across cleaner, fresher logs on the next crash. sorry about that.

    and also before restarting the server look for dmp files / zip files within the subfolders for the version you are on
    %LOCALAPPDATA%\Plex Media Server\Crash Reports

    There was no evidence of an attempt to upload dmp files - so may be they did not get created or it crashed in a way that stopped the breakpad crash reporting software from creating the dmp file

    The Crash Reports folders get emptied of dmp / zip files when processed

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    Please do not send logs by Private Message unless specifically requested to
     
«1
Sign In or Register to comment.