If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Looping 'Starting PMS'

XAPBobXAPBob Posts: 6Members ✭✭

Setting up a PMS on a fresh Debian installation, using docker…
Other docker containers are behaving as they should, but the PMS official build (plexinc/pms-docker) is failing to start. The docker logs show:

Plex Media Server first run setup complete
[cont-init.d] 40-plex-first-run: exited 0.
[cont-init.d] 50-plex-update: executing... 
[cont-init.d] 50-plex-update: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.
Starting Plex Media Server.
Starting Plex Media Server.

The last line then repeats indefinitely…

Looking at the PMS log in the config directory it shows nothing obvious to me:

Mar 13, 2018 21:49:42.738 [0x7f9dfa7fe700] INFO - Plex Media Server v1.12.0.4829-6de959918 - ubuntu docker x86_64 - build: linux-ubuntu-x86_64 ubuntu - GMT 00:00
Mar 13, 2018 21:49:42.740 [0x7f9dfa7fe700] INFO - Linux version: 4.9.0-4-amd64 (#1 SMP Debian 4.9.65-3+deb9u1 (2017-12-23)), language: C
Mar 13, 2018 21:49:42.740 [0x7f9dfa7fe700] INFO - Processor AMD Phenom(tm) II X6 1100T Processor
Mar 13, 2018 21:49:42.740 [0x7f9dfa7fe700] INFO - /usr/lib/plexmediaserver/Plex Media Server

I have tried starting the container as both root and as a docker user (clearing out the config each time), and both behave the same.
I have tried both bridge and host networking, and both behave the same.

Clearly I am doing something wrong, but I can’t currently spot it at all - hints/ideas/pointers all welcome.

Additional system notes:
Debian 9.3: 4.9.0-4-amd64 #1 SMP Debian 4.9.65-3+deb9u1
Docker package: 17.12.1~ce-0~debian

version: '2'
    container_name: plex
    image: plexinc/pms-docker
    restart: unless-stopped
      - 32400:32400/tcp
      - 3005:3005/tcp
      - 8324:8324/tcp
      - 32469:32469/tcp
      - 1900:1900/udp
      - 32410:32410/udp
      - 32412:32412/udp
      - 32413:32413/udp
      - 32414:32414/udp
      - TZ=Europe/London
      - PLEX_CLAIM=claim-######
      - ADVERTISE_IP=http://<HostIP>:32400/
    hostname: mediaserver
      - /storage/Plex/dB:/config
      - /storage/Plex/transcode:/transcode
      - /storage/Plex/media:/data


  • XAPBobXAPBob Posts: 6Members ✭✭

    After revising the "perfect media server" article, and it's 18 month followup I spotted that they used a raw disk for their config directory.
    Doesn't look like mergerFS and the config directory play well together, so I've just pointed at exactly the same location, but on the underlying filesystem.

    I now have a login - so moving in the right direction...

    Need to work out migration of the library data from the old Windows Plex backup to the new Docker based system.

Sign In or Register to comment.