If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Android tv Leelbox Q3 can't connect to local server

JoanmayJoanmay Posts: 9Members ✭✭

So. I get an error pop-up when I play any content saying: The connection with the PMS have been lost... Showing the buttons Retry or Cancel.

Obviously retry gets me nowhere.

My set up is:

PMS runs in an Ubuntu server connected to an small switch and then my router.

It has fixed local ip and is running with a DMZ exception so ports aren't a troubble (although in this case the connectivity troubble happens inside my LAN)

Router is Mitrastar HGW-2501GN-R2

The small switch is TP-LINK SG1008D and also from the switch goes a cable to my android tv model Leelbox Q3.

This set up have been tested and worked in 2 smart tv's

Default ports are 32400.

Where is the troubble??


  • JoanmayJoanmay Posts: 9Members ✭✭


    The music-only streaming is working.

    After allowing insecure connections inside the local network the reproduction of a movie started though after a few seconds it got stuck, I thought was because it was set as 4k and my tv is 1080p, I stopped it, but nevermore started a reproduction of movie anymore.

    I have tried choosing different qualities but I reached nothing more. I don't see anything in configuration of the app that could be causing an issue.

    The device has dual band wifi, and supports 4k in its specs. It appears to be enough powerful to run this task.

    Could it be something of the Android version or any complement of the SO I should update? It runs Android 6.0.1 kernel 3.10.33

    Any help would be awesome.

  • JoanmayJoanmay Posts: 9Members ✭✭

    I hate when this happens but I could solve it.

    I had to switch to mobile view first then go to Settings>Advanced> Turn on the Android media player. And it is working now.

Sign In or Register to comment.