If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

OpenPHT 1.9 based on LibreELEC 8.2 MULTIPLE DEVICES AML S805 S905 S912 RPi WeTek ODRIOD

13»

Comments

  • prisoner881prisoner881 Posts: 23Members, Plex Pass Plex Pass
    edited April 11

    @treboR2Robert said:

    @prisoner881 said:
    I have to unfortunately announce the audio sync/lag bug is still present in the 1.9 build :-( . I was hoping it was squashed.

    In case anyone doesn't know of the bug, the audio gradually falls out of sync with the video, usually with HEVC streams and not with H.264 streams. Stopping and restarting the video re-sync's things but they will gradually fall out of sync again, especially if you pause the video and unpause it.

    Is that just on the Odroid C2 ? Or does it affect all s905 / s905x devices ?

    If you read the RasPlex forums you'll see tons of posts concerning it and it's been going on for almost a year. Given the number of people who've reported it I would imagine it extends beyond just one type of device.

    However, based on what I've seen with my own setup, the problem seems to happen when playing HEVC content and not H.264 content. Could be it happens with H.264 and I haven't noticed since I've converted most of my library to HEVC.

    I have three embedded players: two ODroid C2's and one semi-retired RPi2+. The latter can't play HEVC @ 1080p so it's been converted to a RetroPie setup. I never noticed the audio drift problem on the RPi but then again I never played HEVC content on it either.

  • prisoner881prisoner881 Posts: 23Members, Plex Pass Plex Pass

    I also seem to recall one of the RasPlex developers stating they were aware of the issue and the entire audio subsystem required rewriting to address it. But that was almost a year ago if I recall correctly. No idea where the "fix" stands now.

  • treboR2RoberttreboR2Robert Posts: 296Members, Plex Pass Plex Pass

    @prisoner881 said:

    @treboR2Robert said:

    @prisoner881 said:
    I have to unfortunately announce the audio sync/lag bug is still present in the 1.9 build :-( . I was hoping it was squashed.

    In case anyone doesn't know of the bug, the audio gradually falls out of sync with the video, usually with HEVC streams and not with H.264 streams. Stopping and restarting the video re-sync's things but they will gradually fall out of sync again, especially if you pause the video and unpause it.

    Is that just on the Odroid C2 ? Or does it affect all s905 / s905x devices ?

    If you read the RasPlex forums you'll see tons of posts concerning it and it's been going on for almost a year. Given the number of people who've reported it I would imagine it extends beyond just one type of device.

    However, based on what I've seen with my own setup, the problem seems to happen when playing HEVC content and not H.264 content. Could be it happens with H.264 and I haven't noticed since I've converted most of my library to HEVC.

    Stange ive used rasplex exclusively for years and never really had any problems.

    Obviously everything was x264 or h264.

    I wouldnt have thought the raspberry pi would have enough power to play hevc stuff anyway because of the lack of h265 hardware decoder.

    Your odroid c2 has h265 hardware decoding though right ?

    treboR2Robert    AKA    Mr. Grumpy


    PMS ( FreeNAS 9.10.2-U6 ) ( manual jail )    Plex for LG (OLED B7)     Rasplex ( Raspberry Pi 3 model B x2¦ ( Raspberry Pi 2 model B x2 )           

  • coz2001coz2001 Posts: 284Members, Plex Pass Plex Pass
  • OmegaRed1723OmegaRed1723 Posts: 321Members, Plex Pass Plex Pass
    edited April 13

    What a pleasant surprise! I have a NUC7i5BNH gathering dust waiting for a build of LibreELEC/OpenPHT that can handle passthrough audio. Can't wait to try the x86 version of this release!

    Update 4/13/18: I installed the Generic x86 version of this release on the NUC. Unfortunately, the Kaby Lake passthrough audio problems persist. After looking into this further, it seems that the LibreELEC patch for this won’t be pushed until version 9.0 is released.

  • prisoner881prisoner881 Posts: 23Members, Plex Pass Plex Pass

    @treboR2Robert said:

    Your odroid c2 has h265 hardware decoding though right ?

    It does which makes the problem all the more bizarre.

  • prisoner881prisoner881 Posts: 23Members, Plex Pass Plex Pass

    @veisen said:
    Cec working good hdr working good and if atmos working on the libreelec in this build must working 2 bcs all libraries are from last build of libreelec

    Are you aware of the audio sync/lag issue? If so, do you have any ideas about what's required to fix it?

  • LiveForTechnologyLiveForTechnology Posts: 3Members

    Hi awesome job on this! I'm really surprised nobody has asked but is there a build (or a plan) for the rockchip (RK3229) v88 boxes or will one of these builds work on them? TIA!

  • FamilyCaveFamilyCave Posts: 2Members

    Does this update look at the new collections feature and VC-1 codex jitter?

  • garnutsgarnuts Posts: 27Members ✭✭

    @FamilyCave said:
    Does this update look at the new collections feature and VC-1 codex jitter?

    I tried it and it still does have the VC-1 jitter :/

  • FamilyCaveFamilyCave Posts: 2Members

    @garnuts said:
    I tried it and it still does have the VC-1 jitter :/

    Oh that's unfortunate... I've installed it and will try it out tonight

  • JingxJingx Posts: 1Members

    Great to see that the development is not dead. But i fail to see the benefits of upgrading to 1.9. Can someone post a changelog pls?
    thx

  • BeireBeire Posts: 9Members, Plex Pass Plex Pass
    edited April 21

    I tried this on a mecool m8s pro l s912 box. It boots but pht never starts. Stuck at the splash screen showing libreelec build number.

    SSH does not work. Can I access any relevant logs in this state?

    *edit: i found this thread discussing the same problem:

    https://forum.libreelec.tv/thread/10409-openpht-plex-home-theater-1-9-for-s905-s805-s912-wetek-play-2-and-other-devices/?pageNo=7

    Seems i'll have to wait

  • kras12kras12 Posts: 5Validating, Plex Pass Plex Pass
    edited April 22

    Does anyone know if it is already possible to build version 2.0 from https://github.com/RasPlex/OpenPHT-Embedded/tree/openpht-2.0 ?

  • prisoner881prisoner881 Posts: 23Members, Plex Pass Plex Pass

    @kras12 said:
    Does anyone know if it is already possible to build version 2.0 from https://github.com/RasPlex/OpenPHT-Embedded/tree/openpht-2.0 ?

    If someone will give me some tips on how to compile this I'll try it. Plex for Kodi is OK but I prefer OpenPHT far better...if the audio lag issue wasn't so annoying.

  • kras12kras12 Posts: 5Validating, Plex Pass Plex Pass

    @prisoner881 said:

    @kras12 said:
    Does anyone know if it is already possible to build version 2.0 from https://github.com/RasPlex/OpenPHT-Embedded/tree/openpht-2.0 ?

    If someone will give me some tips on how to compile this I'll try it. Plex for Kodi is OK but I prefer OpenPHT far better...if the audio lag issue wasn't so annoying.

    Ok, I builded it, but it's not really working yet.

  • prisoner881prisoner881 Posts: 23Members, Plex Pass Plex Pass

    @kras12 said:

    @prisoner881 said:

    @kras12 said:
    Does anyone know if it is already possible to build version 2.0 from https://github.com/RasPlex/OpenPHT-Embedded/tree/openpht-2.0 ?

    If someone will give me some tips on how to compile this I'll try it. Plex for Kodi is OK but I prefer OpenPHT far better...if the audio lag issue wasn't so annoying.

    Ok, I builded it, but it's not really working yet.

    What's not working? Is there anything I can help test?

13»
Sign In or Register to comment.