If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Plex: Brilliant but so frustrating

Currently, Plex has ruined my weekend with the kids as I'm mad that Plex has fallen over on the ONE night I needed it.

Anyway, Plex had been running faultlessly. My films are on an old HP WMS, I was running Plex from my PC and I could access all my films from my Samsung TV. Until tonight!

I have spent the last two hours running up & down the stairs between my PC & my TV with zero results. This site is great but seems to go from the banal to the complicated very quickly leaving me way out of my depth. So here goes:

When I open Plex on my Samsung TV it says Server can't be reached
I've tried to follow all the advice about firewalls, VPN's etc. (I think) but I keep asking, if it worked before, why should I be making any changes.

I just don't get all this "Are you logged in" nonsense. My TV has Plex running. My PC also has Plex running and will run films no problem. It's just my TV can't connect to the films.#

Now I'm new to all of this so could someone please provide a step by step way to sort out connecting problems

I absolutely love Plex but my inability to fix it when it falls over means I may have to look elsewhere as tonight has been a nightmare.

Thanks for listening & for any help you can offer

Best Answers

  • ms3arsms3ars Posts: 95Members, Plex Pass Plex Pass
    Accepted Answer

    Check your server’s network settings -
    Secure Connections should be set to Preferred

  • My-Media-ServerMy-Media-Server Posts: 19Members ✭✭
    Accepted Answer

    Thanks. But how exactly do I do that?

Answers

  • ms3arsms3ars Posts: 95Members, Plex Pass Plex Pass
    Accepted Answer

    Check your server’s network settings -
    Secure Connections should be set to Preferred

  • My-Media-ServerMy-Media-Server Posts: 19Members ✭✭
    Accepted Answer

    Thanks. But how exactly do I do that?

  • My-Media-ServerMy-Media-Server Posts: 19Members ✭✭

    ms3ars. OK, I found it and it was set to prefered. However, my TV just wont conne
    ct

  • ms3arsms3ars Posts: 95Members, Plex Pass Plex Pass

    Is the firmware on your TV up to date? If not, then update it

  • My-Media-ServerMy-Media-Server Posts: 19Members ✭✭

    @ms3ars said:

    Is the firmware on your TV up to date? If not, then update it

    Yes it appears to be up to date

Sign In or Register to comment.