Our forum migration to Discourse is underway and scheduled to last through June 21. During the migration, the forums will be read-only, except for a single temporary forum (contents of which will not be getting transferred). Read our announcement post for more information about the forum migration.
Hey folks, there is a new Podcast category for forums https://forums.plex.tv/categories/podcasts
If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

"there was an unexpected error loading this library" in certain views

sobo7sobo7 Members Posts: 9 ✭✭

Hey there,

I'm running in to issues with the default view in my TV Shows library:

When I try to view "All, TV Shows, By Title" - the default view when I click on the library, I get an unexpected error.
When I try to view "Seasons, By Season" I get an unexpected error.

When I try to view "All, Episodes, By Show" I can see all my episodes.
When I try to view "Folders, TV Shows" I can see all the folders.
When I try to view "Discover, TV Shows" I can see the shows.
Home ("Discover, All Libraries") view shows the most recently added TV Shows in the RECENTLY ADDED TV category.

Database has been optimized after my import of the TV Shows library.

attached are logs. I stopped and restarted the server, looked at the default home view, then clicked on my "TV Shows" library.
Time of request was approximately May 08, 2018 10:12:47

I'm not seeing RAM usage spike, and RAM still shows 3GB free.

TV Shows library stats: 3018 episodes, 105 shows.

server info:
Plex Media Server v1.12.3.4973-215c28d86 - FreeBSD PC amd64 - build: freebsd-x86_64 freebsd
FreeBSD version: 11.1-RELEASE-p7
Processor Intel(R) Core(TM) i5 CPU 760 @ 2.80GHz
8GB RAM

Best Answers

  • OttoKernerOttoKerner Members, Plex Pass, Plex Ninja Posts: 30,881 Plex Ninja
    Accepted Answer

    @sobo7 said:
    nothing shows as corrupt, and the only items that show up as malformed are these:
    Plex Media Server.4.log:Jun 09, 2018 18:35:29.755 [0x80b1b0100] WARN - HTTP error requesting GET (0, No error) ( malformed)

    No, that doesn't relate to the database.

    I'd try the repair procedure, nonetheless.
    Give it enough time upon the next server start to re-create the index tables which got chopped by the repair process.

    Got help? Help others too - by reporting back with your results!
    Have you checked the Documentation before posting a question in the forums?
    Use the SEARCH function before starting a new thread!
    No PMs unless requested, please! Do not use 'verbose' logging
  • sobo7sobo7 Members Posts: 9 ✭✭
    Accepted Answer

    @OttoKerner said:

    I'd try the repair procedure, nonetheless.
    Give it enough time upon the next server start to re-create the index tables which got chopped by the repair process.

    I don't know why, but repairing the database worked. Holy moly, first time I've been able to list all of my movies in weeks! thanks, @OttoKerner

Answers

  • sobo7sobo7 Members Posts: 9 ✭✭

    additional info:

    the above viewing was via the chrome web browser.

    when browsing the tv library via the ios plex app, I can see the tv shows.
    when browsing the tv library via the appletv plex app, I cannot.

  • sol_slsol_sl Members, Plex Pass Posts: 10 Plex Pass

    Having the same issue trying to browse music => Albums by Title. Any luck finding a solution?

  • C.a.T.C.a.T. Members, Plex Pass Posts: 5 Plex Pass

    disable collections: show collections

  • sobo7sobo7 Members Posts: 9 ✭✭

    @C.a.T. said:
    disable collections: show collections

    Hey, not a bad workaround for the web view. I'll have to see if this fixes my appleTV view.

  • sobo7sobo7 Members Posts: 9 ✭✭

    @C.a.T. said:
    disable collections: show collections

    helps in web view, but I often have to go in and toggle showing collections when moving from library to library.

    does not help on the appleTV view of all movies or shows

  • OttoKernerOttoKerner Members, Plex Pass, Plex Ninja Posts: 30,881 Plex Ninja

    Verify your databases are not damaged
    1. activate debug logging (not 'verbose'!)
    2. quit Plex Server
    3. wait 1 minute
    4. start Plex Server
    5. wait 5 minutes
    6. fetch log files and attach them here

    Or inspect them yourself. Take a look at the Plex Media Server.log file and seek for messages about database corrupt or malformed.

    If you find these, you may have to repair your database.
    https://support.plex.tv/hc/en-us/articles/201100678-Repair-a-Corrupt-Database
    beware: the repair instructions need two extra commands inserted, if your server is on version 1.13.1 or above

    Got help? Help others too - by reporting back with your results!
    Have you checked the Documentation before posting a question in the forums?
    Use the SEARCH function before starting a new thread!
    No PMs unless requested, please! Do not use 'verbose' logging
  • sobo7sobo7 Members Posts: 9 ✭✭

    @OttoKerner said:
    Verify your databases are not damaged
    1. activate debug logging (not 'verbose'!)
    2. quit Plex Server
    3. wait 1 minute
    4. start Plex Server
    5. wait 5 minutes
    6. fetch log files and attach them here

    Or inspect them yourself. Take a look at the Plex Media Server.log file and seek for messages about database corrupt or malformed.

    If you find these, you may have to repair your database.
    https://support.plex.tv/hc/en-us/articles/201100678-Repair-a-Corrupt-Database
    beware: the repair instructions need two extra commands inserted, if your server is on version 1.13.1 or above

    I have attached the log files from five minutes after restart.

    nothing shows as corrupt, and the only items that show up as malformed are these:

    Plex Media Server.4.log:Jun 09, 2018 18:35:29.755 [0x80b1b0100] WARN - HTTP error requesting GET  (0, No error) (<url> malformed)
    Plex Media Server.5.log:Jun 09, 2018 13:21:32.346 [0x80acc6100] WARN - HTTP error requesting GET  (0, No error) (<url> malformed)
    Plex Media Server.5.log:Jun 09, 2018 13:21:32.887 [0x80b1af200] WARN - HTTP error requesting GET  (0, No error) (<url> malformed)
    Plex Media Server.5.log:Jun 09, 2018 18:06:17.648 [0x80bd2f300] WARN - HTTP error requesting GET  (0, No error) (<url> malformed)
    Plex Media Server.5.log:Jun 09, 2018 18:06:17.653 [0x80b1b0600] WARN - HTTP error requesting GET  (0, No error) (<url> malformed)
    Plex Media Server.5.log:Jun 09, 2018 18:11:03.993 [0x80b1afc00] WARN - HTTP error requesting GET  (0, No error) (<url> malformed)
    
  • OttoKernerOttoKerner Members, Plex Pass, Plex Ninja Posts: 30,881 Plex Ninja
    Accepted Answer

    @sobo7 said:
    nothing shows as corrupt, and the only items that show up as malformed are these:
    Plex Media Server.4.log:Jun 09, 2018 18:35:29.755 [0x80b1b0100] WARN - HTTP error requesting GET (0, No error) ( malformed)

    No, that doesn't relate to the database.

    I'd try the repair procedure, nonetheless.
    Give it enough time upon the next server start to re-create the index tables which got chopped by the repair process.

    Got help? Help others too - by reporting back with your results!
    Have you checked the Documentation before posting a question in the forums?
    Use the SEARCH function before starting a new thread!
    No PMs unless requested, please! Do not use 'verbose' logging
  • sobo7sobo7 Members Posts: 9 ✭✭
    Accepted Answer

    @OttoKerner said:

    I'd try the repair procedure, nonetheless.
    Give it enough time upon the next server start to re-create the index tables which got chopped by the repair process.

    I don't know why, but repairing the database worked. Holy moly, first time I've been able to list all of my movies in weeks! thanks, @OttoKerner

Sign In or Register to comment.