If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Transcoding vs Direct Play

TheCli3ntTheCli3nt Posts: 69Members, Plex Pass Plex Pass

All of my videos are processed through ffmpeg before being added to PMS with the following commands:

1st Pass:
ffmpeg -i $file -c:v libx264 -level:v 3.1 -b:v 1000k -minrate 800k -maxrate 1000k -bufsize 1835k -c:a aac -strict -2 $file2

2nd Pass:
ffmpeg -i $file2 -c:a copy -c:v copy -movflags faststart $file3

And while I hardly ever see transcoding (unless Auto Quality Adjustment kicks in) on every other device, every single video my brother tries to watch on his PS4 is transcoded (see attached image).

Is there a better set of ffmpeg commands to prevent this?

PS4 is hardwired to the modem (speed test results in pic #2)
PMS is hardwired to the modem (speed test results in pic #3)

Jay "The Cli3nt" Bishop
Father, Geek, Gamer, Bleeder
Blogger
TheCli3nt.com
jay@thecli3nt.com

Plex Media Server:

Hardware:
* Server 1:
-- Intel Core i5-4590 CPU @ 3.30GHz × 4, 4GB DDR3, Root: 500GB, Media: 21.5TB OS: Ubuntu 16.04.1 64-bit

  • Server 2:
    -- AMD FX-8320 @ 3.5GHz × 8, 16GB DDR3, Root: 1TB, Media: 12.6TB, OS: Ubuntu 17.04 64-bit

Clients:
-- PlayStation 3 & 4
-- Xbox 360 & One
-- Roku Stick, Express+, 3 and Premiere
-- Windows 10 PC (Windows 10 Plex app and Chrome web browser)
-- Android Tablets & Phones

Answers

  • laniaxlaniax Posts: 1Members

    I've had a similar issue (transcoding H264 to H264 on the playstation 4). I solved it by increasing the H264 level inside the PS4 Plex settings from 4.1(?) to 5.0. Although this might cause some files not to play.

    You could try processing your files to a lower H264 level so they will play on the default settings, i've never tried this myself though.

    Also: anything with softsubs will always transcode for me.

Sign In or Register to comment.