Our forum migration to Discourse is underway and scheduled to last through June 21. During the migration, the forums will be read-only, except for a single temporary forum (contents of which will not be getting transferred). Read our announcement post for more information about the forum migration.
Hey folks, there is a new Podcast category for forums https://forums.plex.tv/categories/podcasts
If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Plex on Pi3 not updating metadata, posters etc since about 5 days ago

bengt_abengt_a Members, Plex Pass Posts: 20 Plex Pass

Hi, my Plex servier running on a Pi3 with Stretch has stopped updating metadata since about 5 days ago.
I have run apt-get update and upgrade just now to make sure I have the latest version, but it is still not updating. What could be the reason for this?

Best Answer

  • bengt_abengt_a Members, Plex Pass Posts: 20 Plex Pass
    Accepted Answer

    Ohooo! I all of a sudden realized that perhaps those logs wouldn't be too scary after all. And I saw an ERROR in the log saying Error creating directory "/var/lib/plexmediaserver/Library/..."
    I checked, and a bit down in the hierarchy the owner of the directories wasn't plex, but root, and the permissions were 755. So I changed the owner to Plex with chown -R plex /var/lib/plexmediaserver/*.
    After that it seems like it started to work. :)

Answers

  • uglymagoouglymagoo Members, Plex Pass, Plex Ninja, TunerTester Posts: 1,083 Plex Ninja

    Mostly likely a network or DNS issue. Your Pi3 is not able to communicate with plex.tv. Please check the network, reboot the Pi3 and post the server logs, if the issue still remains.

    https://support.plex.tv/articles/200250417-plex-media-server-log-files/

    Official instructions for Plex Media Server on the Raspberry Pi 2 and 3 / Banana Pi / ODROID / many more : armhf and arm64 Debian Repository
    My PMS hardware: RPi 2, NVIDIA Shield TV, Intel Xeon

  • bengt_abengt_a Members, Plex Pass Posts: 20 Plex Pass
    edited May 20

    Hi uglymagoo!
    Thanks for the response. I have been juggling the amazing weather with some troubleshooting, including removing and adding the firewall, configuring a new router, etc. But the problem remains. I have attached the logs. I hope you find something useful. :smiley:

    The Pi3 is connected to the network, and it can reach the outside world fine. (Deluge (for downloading linux distributions ;), ping etc works without any problems.)

  • bengt_abengt_a Members, Plex Pass Posts: 20 Plex Pass
    Accepted Answer

    Ohooo! I all of a sudden realized that perhaps those logs wouldn't be too scary after all. And I saw an ERROR in the log saying Error creating directory "/var/lib/plexmediaserver/Library/..."
    I checked, and a bit down in the hierarchy the owner of the directories wasn't plex, but root, and the permissions were 755. So I changed the owner to Plex with chown -R plex /var/lib/plexmediaserver/*.
    After that it seems like it started to work. :)

Sign In or Register to comment.