If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Linux Mint + Plex + PIA = Indirect Relay, help?

AlucardD20AlucardD20 Posts: 6Members ✭✭

I am beyond ready to just forget everything because it's been driving me nuts for days.

So I have PMS installed on my Linux Mint Laptop, media is on an external drive. Its all setup, seems to have found all the items when searching and no issues with that.

I also have PIA set up on my laptop, set the port forwarding, set up the local correctly. I followed the various directions and read the thousands upon thousands of posts, from here, reddit and even blogs about setting up port forwarding on my router, and assigning it its own iP Address and the port. I've done it all.

When I connect with my Roku devices I am able to only get Relay, but the playback quality under the settings allows me to have a pretty decent viewing experience over wifi.

BUT my apple tv, which is hardwired to the network, the same network that my PMS server laptop is connected to, works slow, gets a relay, but only allows me to stream at .7mbps, 320p for home streaming and internet streaming. IF I attempt to change these things, it just reverts back to this, which leads to a choppy horrible blurry experience for something that's directly connected. I've tried everything.

I did notice under the settings while looking at the AppleTv Plex, that under debugging > Enable Log Download it showed the local IP address but a port of 32500/logging NOT the 32400 in which my PIA and Laptop are set for.

Is this the issue???

Best Answer

  • AlucardD20AlucardD20 Posts: 6Members ✭✭
    Accepted Answer

    close or delete this thread, I'm just revamping back to windows. Linux was a poor choice for me. thanks everyone.

Answers

  • AlucardD20AlucardD20 Posts: 6Members ✭✭

    no ideas here? okay.

  • ChuckPAChuckPA Posts: 22,245Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member
    edited May 13

    I'm sorry but it is the weekend here.

    Please attach your logs showing the information you've posted above. I need to see what's happening but from your description:

    1. Firewall
    2. Routing table
    3. Incorrect network adapter chosen by PMS (which happens with VPNs)

    Edit: Deferring to UglyMagoo

    Please DISABLE Verbose logging until requested

    Please search before posting

    Primary support: Linux, Synology, and QNAP

    Please remember to report back. This benefits others.

    Useful links

     Installation and Basic Setup |  Media Preparation (How to name your media files)  |  Linux Permissions 

     Handling TV Specials | Handling Movie extras  |  Nas Compatibility

     Reporting Plex Server issues | Plex Media Server FAQ | Linux Tips

     

    Other useful guides: Local Subtitles | The Plex "dance" | Synology FAQ | PMS Release Announcements

    Hosts: Fedora, QNAP, Synology, most Linux distros in VM

    No technical support via PM unless offered

    Please remember to mark the appropriate answer(s) which solved your issue.

     
  • uglymagoouglymagoo Posts: 974Members, Plex Pass, Plex Ninja, TunerTester Plex Ninja
    edited May 13

    @AlucardD20 said:
    no ideas here? okay.

    Your internet access is tunneled through PIA, right? This is a problematic setup. Essentially, you have to at least setup port forwarding with PIA. According to their docs, you can only forward one port. plex.tv has to be able to contact your server from outside. Did you setup this port forwarding correctly and specify it manually in the plex server settings?

    The most problematic part is to have a local iptables rule to forward connections on this PIA forwarded port to Plex port 32400. You cannot change the port plex is listening on. It's always 32400 on your laptop. So a local iptables rule is required. You could also just use the Plex docker container with bridge networking and use the Docker publish syntax to map that PIA port to port 32400 of your Plex Docker container.

    And another remark: If you already use this forwarded port for some other software, you just cannot use Plex efficiently with this network setup.

    https://helpdesk.privateinternetaccess.com/hc/en-us/articles/219460187-How-do-I-enable-port-forwarding-on-my-VPN-

    Official instructions for Plex Media Server on the Raspberry Pi 2 and 3 / Banana Pi / ODROID / many more : armhf and arm64 Debian Repository
    My PMS hardware: RPi 2, NVIDIA Shield TV, Intel Xeon

  • AlucardD20AlucardD20 Posts: 6Members ✭✭

    I’ve done the port forwarding as per the PIA website and the various articles. I still get relay. I think I am giving up on Plex. Relay .7 kB 320p when I am clearly hardwired into my network. Just plain silly and unbearable to watch. The software was great for me when I had windows, but I don’t anymore. Yeah my decision I know, poor one? Depends on who you ask. But I can’t get it to work, so I give up. I’ll look for another way to send my stuff to my TV, there is tons of software. I’ll pay for one that works if need be, I guess. Thanks for helping

  • ChuckPAChuckPA Posts: 22,245Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    Respectfully, what is your mastery level with Linux?
    Windows does a lot for you. Linux does not.

    Please DISABLE Verbose logging until requested

    Please search before posting

    Primary support: Linux, Synology, and QNAP

    Please remember to report back. This benefits others.

    Useful links

     Installation and Basic Setup |  Media Preparation (How to name your media files)  |  Linux Permissions 

     Handling TV Specials | Handling Movie extras  |  Nas Compatibility

     Reporting Plex Server issues | Plex Media Server FAQ | Linux Tips

     

    Other useful guides: Local Subtitles | The Plex "dance" | Synology FAQ | PMS Release Announcements

    Hosts: Fedora, QNAP, Synology, most Linux distros in VM

    No technical support via PM unless offered

    Please remember to mark the appropriate answer(s) which solved your issue.

     
  • uglymagoouglymagoo Posts: 974Members, Plex Pass, Plex Ninja, TunerTester Plex Ninja
    edited May 16

    @AlucardD20 said:
    I’ve done the port forwarding as per the PIA website and the various articles. I still get relay. I think I am giving up on Plex. Relay .7 kB 320p when I am clearly hardwired into my network. Just plain silly and unbearable to watch.

    @uglymagoo said:
    The most problematic part is to have a local iptables rule to forward connections on this PIA forwarded port to Plex port 32400. You cannot change the port plex is listening on. It's always 32400 on your laptop. So a local iptables rule is required.

    Did you do this? Please post your iptables rules, so we can make sure it is OK. Without this special rule Plex CANNOT work, as it is not available form outside, the connection of <your-PIA-forwarded-port> to Plex port 32400 is missing! To test your setup: Just connect to https://<your-PIA-external-IP>:<your-PIA-forwarded-Port>/web in your browser. Plex has to come up if you did everything correct.

    Official instructions for Plex Media Server on the Raspberry Pi 2 and 3 / Banana Pi / ODROID / many more : armhf and arm64 Debian Repository
    My PMS hardware: RPi 2, NVIDIA Shield TV, Intel Xeon

  • AlucardD20AlucardD20 Posts: 6Members ✭✭

    @ChuckPA said:
    Respectfully, what is your mastery level with Linux?
    Windows does a lot for you. Linux does not.

    @uglymagoo said:

    @AlucardD20 said:
    I’ve done the port forwarding as per the PIA website and the various articles. I still get relay. I think I am giving up on Plex. Relay .7 kB 320p when I am clearly hardwired into my network. Just plain silly and unbearable to watch.

    @uglymagoo said:
    The most problematic part is to have a local iptables rule to forward connections on this PIA forwarded port to Plex port 32400. You cannot change the port plex is listening on. It's always 32400 on your laptop. So a local iptables rule is required.

    Did you do this? Please post your iptables rules, so we can make sure it is OK. Without this special rule Plex CANNOT work, as it is not available form outside, the connection of <your-PIA-forwarded-port> to Plex port 32400 is missing! To test your setup: Just connect to https://<your-PIA-external-IP>:<your-PIA-forwarded-Port>/web in your browser. Plex has to come up if you did everything correct.

    Iptables is well beyond what I understand, I am sure with some research I might be able to figure it out. My Linux is basic. I am not sure why this issue is being weird, because I had this same set up just recently on a desktop, also hardwired in, with PIA and it worked fine.. since I had to start over and rebuild it on a laptop, it stopped working

  • AlucardD20AlucardD20 Posts: 6Members ✭✭
    edited May 17

    WELL, I must be messing something up somewhere, because I completely turned off the PIA and exited it.. to see if I can access the PMS and I am still getting indirect.. so it must be a setting on the linux laptop

    EDIT: Nevermind, I fixed that issue. IT works fine when off now.

  • AlucardD20AlucardD20 Posts: 6Members ✭✭
    Accepted Answer

    close or delete this thread, I'm just revamping back to windows. Linux was a poor choice for me. thanks everyone.

Sign In or Register to comment.