If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

upgrade to plexmediaserver_1.13.0.5023 : fail to start service, b/c file not found [solved]

KrysstofKrysstof Posts: 4Members ✭✭

Hi
I'm running on ubuntu 17.10 and was seeing a 1.13 plex upgrade
I tried my usual "wget http://.....deb" then "sudo apt install .....deb", but after that the service didn't start

I looked in the log and journalctl -u plexmediaserver said
"
...Started Plex Media Server for Linux.
.../bin/sh: 1: /usr/lib/plexmediaserver/Plex Media Server: not found
...plexmediaserver.service: Main process exited, code=exited, status=127/n/a
"

went round and round until it hit me... that's not the file that is not found, but the interpreter... I downloaded the wrong version (32 bits instead of 64)

I've seen quite a few question like that in the forum here : make sure you get the right package when installing manually (a bit surprised the dependency to that lib "/lib/ld-linux.so.2" that was missing was not checked in the .deb as "wrong distro dude", I guess I'm too used to RPM at work)

i've seen also that the repository for ubuntu 16+ seems to have been fixed, thanks for that, it seems to work

Best Answer

Answers

Sign In or Register to comment.