Hey folks, there is a new Podcast category for forums https://forums.plex.tv/categories/podcasts
If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Linux Server very slow

NinjinerNinjiner Posts: 7Members, Plex Pass Plex Pass

Hello Together
Since some time i have installed a Linux Ubuntu 18.04 VM on my ESX.
I installed Plex via rpm.
I mounted (smb) a folder from my qnap NAS to this machine.
I have the problem, that my Plex Server is loading viedos very slow so it loads for 5 minutes, then i watch 3 minutes and it starts loading again.
Sometimes Plex web app even sais to me that the server is down, but i see that it is online and plex is running.

Has anyone an idea what i am missing?

Best Answer

  • NinjinerNinjiner Posts: 7Members, Plex Pass Plex Pass
    Accepted Answer

    I think I found a solution, i am now using nfs instead of samba, and it works quite well now.
    I will watch my System and report if it slows down again, but for now its better.
    Thank you for your help @ChuckPA

Answers

  • ChuckPAChuckPA Posts: 22,836Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    Need to know more:

    1. How many VCPUs are you giving it?
    2. Log files please (Settings - Server - Help - Download Logs (Attach the ZIP it gives you)

    Please DISABLE Verbose logging until requested

    Please search before posting

    Primary support: Linux, Synology, and QNAP

    Please remember to report back. This benefits others.

    Useful links

     Installation and Basic Setup |  Media Preparation (How to name your media files)  |  Linux Permissions 

     Handling TV Specials | Handling Movie extras  |  Nas Compatibility

     Reporting Plex Server issues | Plex Media Server FAQ | Linux Tips

     

    Other useful guides: Local Subtitles | The Plex "dance" | Synology FAQ | PMS Release Announcements

    Hosts: Fedora, QNAP, Synology, most Linux distros in VM

    No technical support via PM unless offered

    Please remember to mark the appropriate answer(s) which solved your issue.

     
  • NinjinerNinjiner Posts: 7Members, Plex Pass Plex Pass
    Accepted Answer

    I think I found a solution, i am now using nfs instead of samba, and it works quite well now.
    I will watch my System and report if it slows down again, but for now its better.
    Thank you for your help @ChuckPA

  • NinjinerNinjiner Posts: 7Members, Plex Pass Plex Pass

    Ok it was just temporary. I still have the problems discribed above.
    Find my logs attached.

  • ChuckPAChuckPA Posts: 22,836Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    You keep dropping internet connectivity.

    May 26, 2018 23:26:07.343 [0x7f57927fe700] DEBUG - HTTP requesting GET http://plex.tv/pms/:/ip
    May 26, 2018 23:26:07.344 [0x7f5789ffb700] DEBUG - NAT: UPnP, attempting port mapping.
    May 26, 2018 23:26:07.427 [0x7f57927fe700] DEBUG - HTTP 200 response from GET http://plex.tv/pms/:/ip
    May 26, 2018 23:26:07.427 [0x7f57927fe700] DEBUG - PublicAddressManager: Got public IP from http://plex.tv: xxx.1xx.1xx.7x
    May 26, 2018 23:26:27.163 [0x7f57957ff700] DEBUG - EventSource: Failure in IdleTimeout (0 - Success).
    May 26, 2018 23:26:27.163 [0x7f57957ff700] DEBUG - MyPlex: We appear to have lost Internet connectivity, resetting device URL cache.
    May 26, 2018 23:26:27.163 [0x7f57957ff700] ERROR - EventSource: Retrying in 15 seconds.
    May 26, 2018 23:26:29.579 [0x7f578cfff700] DEBUG - NetworkServiceBrowser: SSDP departed after not being seen for 20.566419 seconds: 192.168.1.1
    May 26, 2018 23:26:29.579 [0x7f578cfff700] DEBUG - NetworkServiceBrowser: SSDP departed after not being seen for 20.773464 seconds: 192.168.1.200
    May 26, 2018 23:26:29.805 [0x7f578cfff700] DEBUG - NetworkServiceBrowser: SSDP arrived: 192.168.1.200 (http://127.0.0.1:58080/53d0c2310c.xml)
    May 26, 2018 23:26:29.805 [0x7f5788fff700] DEBUG - HTTP requesting GET http://127.0.0.1:58080/53d0c2310c.xml
    May 26, 2018 23:26:29.805 [0x7f5788fff700] ERROR - Error issuing curl_easy_perform(handle): 7
    May 26, 2018 23:26:29.806 [0x7f5788fff700] WARN - HTTP error requesting GET http://127.0.0.1:58080/53d0c2310c.xml (0, No error) (Failed connect to 127.0.0.1:58080; Connection refused)
    

    Please DISABLE Verbose logging until requested

    Please search before posting

    Primary support: Linux, Synology, and QNAP

    Please remember to report back. This benefits others.

    Useful links

     Installation and Basic Setup |  Media Preparation (How to name your media files)  |  Linux Permissions 

     Handling TV Specials | Handling Movie extras  |  Nas Compatibility

     Reporting Plex Server issues | Plex Media Server FAQ | Linux Tips

     

    Other useful guides: Local Subtitles | The Plex "dance" | Synology FAQ | PMS Release Announcements

    Hosts: Fedora, QNAP, Synology, most Linux distros in VM

    No technical support via PM unless offered

    Please remember to mark the appropriate answer(s) which solved your issue.

     
  • NinjinerNinjiner Posts: 7Members, Plex Pass Plex Pass

    But I alsow expirience this in LAN, so while it looses internet connection it should be able to play movies localy, shouldnt it?

  • ChuckPAChuckPA Posts: 22,836Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    Did you configure LAN to play without authentication? (Settings - Server - Network)

    If not, playback will pause while it re-authenticates. PMS does not cache any credentials locally yet. Everything, because of how a PlexPass is handled, must be authenticated through Plex.tv.

    Please DISABLE Verbose logging until requested

    Please search before posting

    Primary support: Linux, Synology, and QNAP

    Please remember to report back. This benefits others.

    Useful links

     Installation and Basic Setup |  Media Preparation (How to name your media files)  |  Linux Permissions 

     Handling TV Specials | Handling Movie extras  |  Nas Compatibility

     Reporting Plex Server issues | Plex Media Server FAQ | Linux Tips

     

    Other useful guides: Local Subtitles | The Plex "dance" | Synology FAQ | PMS Release Announcements

    Hosts: Fedora, QNAP, Synology, most Linux distros in VM

    No technical support via PM unless offered

    Please remember to mark the appropriate answer(s) which solved your issue.

     
  • NinjinerNinjiner Posts: 7Members, Plex Pass Plex Pass

    No I did not configure that.
    So it is my internet connection.
    But that is kind of strange, because everything else in the network stays connected and I never had problems before.

  • ChuckPAChuckPA Posts: 22,836Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    I cannot explain what is happening or what might have changed for you.
    I can only tell you what the log files are telling me.
    It might be the connection from you through your ISP to Plex.tv has been having problems or is now routed differently and in such a way that it doesn't work well.

    I do suggest you make the entry 192.168.1/24 in the "List of IP addresses and networks that are allowed without auth" if you're using a known-secure LAN (all wired or otherwise AES-encrypted WiFi) as a test. This will allow you to verify whether the problem is rooted in the server's inability to authenticate or the client (players). If this corrects the problem then the problem is from your server -> Plex.tv. If it does not correct the slowness then the problem is entirely on your LAN itself.

    Please DISABLE Verbose logging until requested

    Please search before posting

    Primary support: Linux, Synology, and QNAP

    Please remember to report back. This benefits others.

    Useful links

     Installation and Basic Setup |  Media Preparation (How to name your media files)  |  Linux Permissions 

     Handling TV Specials | Handling Movie extras  |  Nas Compatibility

     Reporting Plex Server issues | Plex Media Server FAQ | Linux Tips

     

    Other useful guides: Local Subtitles | The Plex "dance" | Synology FAQ | PMS Release Announcements

    Hosts: Fedora, QNAP, Synology, most Linux distros in VM

    No technical support via PM unless offered

    Please remember to mark the appropriate answer(s) which solved your issue.

     
  • NinjinerNinjiner Posts: 7Members, Plex Pass Plex Pass

    I now gave my LAN access without login and it still keeps failing.
    My server disconnects (in the PLex server list), although it is online and i can access it via ssh and download stuff (it has internet connetction)

  • ChuckPAChuckPA Posts: 22,836Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    Please clarify:

    @Ninjiner said:
    I now gave my LAN access without login and it still keeps failing.
    My server disconnects (in the PLex server list), although it is online and i can access it via ssh and download stuff (it has internet connetction)

    Which client(s) keep disconnecting?
    What do you mean by "disconnect"? Playback stops on local devices?

    Please DISABLE Verbose logging until requested

    Please search before posting

    Primary support: Linux, Synology, and QNAP

    Please remember to report back. This benefits others.

    Useful links

     Installation and Basic Setup |  Media Preparation (How to name your media files)  |  Linux Permissions 

     Handling TV Specials | Handling Movie extras  |  Nas Compatibility

     Reporting Plex Server issues | Plex Media Server FAQ | Linux Tips

     

    Other useful guides: Local Subtitles | The Plex "dance" | Synology FAQ | PMS Release Announcements

    Hosts: Fedora, QNAP, Synology, most Linux distros in VM

    No technical support via PM unless offered

    Please remember to mark the appropriate answer(s) which solved your issue.

     
  • NinjinerNinjiner Posts: 7Members, Plex Pass Plex Pass

    I start either the Plex Media Client or go to the web application. Then like normally it searches for server.
    The first thing here my server is displayed as offline even if can clearly verify that it is only and can ping my local router and other services like google or else.
    The second thing ist
    And last but not least one good thing, since I desabled authentification for the LAN the Playback doesn't fail so many times anymore.
    But still my server very often claims to be offline...

    Hope my description helps you.

Sign In or Register to comment.