Hey folks, there is a new Podcast category for forums https://forums.plex.tv/categories/podcasts
If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Cannot play 5.1 content on new Windows HTPC

AgentDrTranAgentDrTran Posts: 101Members, Plex Pass Plex Pass

I have a new Windows PC with an 8th Gen Intel i3 and a motherboard that says it supports up to 7.1 audio. When plugging the machine into either my TV or my Vizio soundbar, Windows will only show stero as an option and no matter what I choose in plex it will downmix to stero. What do I do to enable 5.1 on Windows? I've updated the BIOS and graphics drivers on the PC and all other device's firmwares are up to date.

«1

Answers

  • OttoKernerOttoKerner Posts: 30,839Members, Plex Pass, Plex Ninja Plex Ninja

    @AgentDrTran said:
    I have a new Windows PC with an 8th Gen Intel i3 and a motherboard that says it supports up to 7.1 audio.

    This usually refers to the on-board analog audio output.
    Do you have your speakers connected to these analog audio outputs on the back of your PC?

    Please detail which type of connection is between your PC and your TV. (HDMI, optical, coax)

    How are the speakers/soundbar connected?
    directly to the PC or daisy-chained to the TV? Again, which type of connection?

    Got help? Help others too - by reporting back with your results!
    Have you checked the Documentation before posting a question in the forums?
    Use the SEARCH function before starting a new thread!
    No PMs unless requested, please! Do not use 'verbose' logging
  • AgentDrTranAgentDrTran Posts: 101Members, Plex Pass Plex Pass
    edited May 28

    @OttoKerner said:

    @AgentDrTran said:
    I have a new Windows PC with an 8th Gen Intel i3 and a motherboard that says it supports up to 7.1 audio.

    This usually refers to the on-board analog audio output.
    Do you have your speakers connected to these analog audio outputs on the back of your PC?

    Please detail which type of connection is between your PC and your TV. (HDMI, optical, coax)

    How are the speakers/soundbar connected?
    directly to the PC or daisy-chained to the TV? Again, which type of connection?

    The PC is connected to the TV with HDMI, and the soundbar is connected to the TV with HDMI (ARC) as well. The built-in roku, my Switch, and my Chromecast can all play 5.1. The soundbar doesn't support 4K passthrough which is why the PC is plugged into the TV.

    edit: I've tried contacting both Vizio and MSI but neither were helpful - Vizio told me it was a PC issue and MSI told me it was a soundbar issue.

  • OttoKernerOttoKerner Posts: 30,839Members, Plex Pass, Plex Ninja Plex Ninja

    Try this:
    put PMP into its 'fullscreen mode'

    Click on your user name, top, right
    Settings
    Audio
    Device Type = HDMI
    Channels = 5.1
    Device = try 'Autoselect' first

    Then activate the checkbox for 'Dolby Digital' below and all other formats for which your soundbar has support.
    Keep in mind that not all of the higher-quality codecs are supported over a HDMI-ARC connection.

    Got help? Help others too - by reporting back with your results!
    Have you checked the Documentation before posting a question in the forums?
    Use the SEARCH function before starting a new thread!
    No PMs unless requested, please! Do not use 'verbose' logging
  • AgentDrTranAgentDrTran Posts: 101Members, Plex Pass Plex Pass
    edited May 28

    @OttoKerner said:
    Try this:
    put PMP into its 'fullscreen mode'

    Click on your user name, top, right
    Settings
    Audio
    Device Type = HDMI
    Channels = 5.1
    Device = try 'Autoselect' first

    Then activate the checkbox for 'Dolby Digital' below and all other formats for which your soundbar has support.
    Keep in mind that not all of the higher-quality codecs are supported over a HDMI-ARC connection.


    It looks like plex is playing 5.1 now, but I can't hear anything except the clicks in the UI. What other connection method should I use? My soundbar has optical and ARC. Would the optical/laser connection be better?

  • OttoKernerOttoKerner Posts: 30,839Members, Plex Pass, Plex Ninja Plex Ninja

    @AgentDrTran said:

    Output driver : null doesn't look like it has the right device.
    Can you try and select a particular sound interface under
    Settings - Audio - 'Device'
    (it should have 'HDMI' in its name, I suppose.)

    A second thing to try would be:
    'Device Type' = Optical
    Channels = 5.1
    Only a checkmark in 'Dolby Digital' below

    Got help? Help others too - by reporting back with your results!
    Have you checked the Documentation before posting a question in the forums?
    Use the SEARCH function before starting a new thread!
    No PMs unless requested, please! Do not use 'verbose' logging
  • AgentDrTranAgentDrTran Posts: 101Members, Plex Pass Plex Pass
    edited May 28

    @OttoKerner said:

    @AgentDrTran said:

    Output driver : null doesn't look like it has the right device.
    Can you try and select a particular sound interface under
    Settings - Audio - 'Device'
    (it should have 'HDMI' in its name, I suppose.)

    A second thing to try would be:
    'Device Type' = Optical
    Channels = 5.1
    Only a checkmark in 'Dolby Digital' below

    screenshot (this still shows as null when playing a video):

    screenshot after switching to optical:

    Thanks for your help, by the way.

  • OttoKernerOttoKerner Posts: 30,839Members, Plex Pass, Plex Ninja Plex Ninja
    edited May 28

    @AgentDrTran said:
    screenshot after switching to optical:

    This looks like expected (mostly).
    Does your PC have several HDMI outputs?

    You didn't mention if you now hear audio or not.

    As a last resort, try the optical connection between TV and soundbar.

    Got help? Help others too - by reporting back with your results!
    Have you checked the Documentation before posting a question in the forums?
    Use the SEARCH function before starting a new thread!
    No PMs unless requested, please! Do not use 'verbose' logging
  • OttoKernerOttoKerner Posts: 30,839Members, Plex Pass, Plex Ninja Plex Ninja

    Was the TV switched on, when you started PMP?

    Got help? Help others too - by reporting back with your results!
    Have you checked the Documentation before posting a question in the forums?
    Use the SEARCH function before starting a new thread!
    No PMs unless requested, please! Do not use 'verbose' logging
  • AgentDrTranAgentDrTran Posts: 101Members, Plex Pass Plex Pass

    @OttoKerner said:
    Was the TV switched on, when you started PMP?

    sorry, should have been clear - I did not hear anything. And yes the TV was turned on when PMP was started. My PC has one HDMI out. I'll try the optical connection again.

  • OttoKernerOttoKerner Posts: 30,839Members, Plex Pass, Plex Ninja Plex Ninja

    Do you have several player softwares running at the same time? They might fight over the HDMI port.

    Do also not set Windows' default audio output to the HDMI audio.

    Got help? Help others too - by reporting back with your results!
    Have you checked the Documentation before posting a question in the forums?
    Use the SEARCH function before starting a new thread!
    No PMs unless requested, please! Do not use 'verbose' logging
  • AgentDrTranAgentDrTran Posts: 101Members, Plex Pass Plex Pass

    @OttoKerner said:
    Do you have several player softwares running at the same time? They might fight over the HDMI port.

    Do also not set Windows' default audio output to the HDMI audio.

    I only have Plex running. and here's my windows
    . What do I set the default as? I can't choose the disabled one.

  • AgentDrTranAgentDrTran Posts: 101Members, Plex Pass Plex Pass
    edited May 30

    I've tried the optical cable and still nothing from Windows or Plex. I get the same error as before with the Optical option in Plex:

    When selecting Basic I get this (no audio):

  • AgentDrTranAgentDrTran Posts: 101Members, Plex Pass Plex Pass

    Other observation:

    Turning off exclusive mode forced (working) stero audio, turn off exclusive mode with Optical gave me this:

  • OttoKernerOttoKerner Posts: 30,839Members, Plex Pass, Plex Ninja Plex Ninja

    Could you use a different test video?
    The one you have uses multi-channel flac (flac is not very widely supported).
    Pick one with a AC3 or maybe a DTS (normal) audio track.

    Got help? Help others too - by reporting back with your results!
    Have you checked the Documentation before posting a question in the forums?
    Use the SEARCH function before starting a new thread!
    No PMs unless requested, please! Do not use 'verbose' logging
  • AgentDrTranAgentDrTran Posts: 101Members, Plex Pass Plex Pass
    edited May 31

    @OttoKerner said:
    Could you use a different test video?
    The one you have uses multi-channel flac (flac is not very widely supported).
    Pick one with a AC3 or maybe a DTS (normal) audio track.

    does this work? there was still no audio.

  • OttoKernerOttoKerner Posts: 30,839Members, Plex Pass, Plex Ninja Plex Ninja

    Please get the PMP logfile and attach it.

    Another idea:
    While in full screen, go to settings - main
    Scroll down to the bottom
    There should be a checkbox labeled 'OpenGL' (or similar). Toggle it, then restart PMP and try again.

    Got help? Help others too - by reporting back with your results!
    Have you checked the Documentation before posting a question in the forums?
    Use the SEARCH function before starting a new thread!
    No PMs unless requested, please! Do not use 'verbose' logging
  • AgentDrTranAgentDrTran Posts: 101Members, Plex Pass Plex Pass

    Here's the logs. Enabling webgl presented the same issue.

    logs.zip 461.8K
  • OttoKernerOttoKerner Posts: 30,839Members, Plex Pass, Plex Ninja Plex Ninja

    Repeat the above tests with 'Exclusive mode' disabled.

    Got help? Help others too - by reporting back with your results!
    Have you checked the Documentation before posting a question in the forums?
    Use the SEARCH function before starting a new thread!
    No PMs unless requested, please! Do not use 'verbose' logging
  • AgentDrTranAgentDrTran Posts: 101Members, Plex Pass Plex Pass


    Tried this time with it disabled, same thing

  • AgentDrTranAgentDrTran Posts: 101Members, Plex Pass Plex Pass

    bumping to see if anyone else is able to help out here

«1
Sign In or Register to comment.