Our forum migration to Discourse is underway and scheduled to last through June 21. During the migration, the forums will be read-only, except for a single temporary forum (contents of which will not be getting transferred). Read our announcement post for more information about the forum migration.
Hey folks, there is a new Podcast category for forums https://forums.plex.tv/categories/podcasts
If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

How can I get Sonos to connect with Plex?

thomas_e_pearson@hotmail.comthomas_e_pearson@hotmail.com Members Posts: 3 ✭✭

I have unsuccessfully followed all of the detailed instructions on setting the appropriate port on my router and cannot get Plex to allow remote access which I think must happen to connect with Sonos. As a long time Sonos user Plex is missing out if they can't work with Sonos to get Plex to act as a music source seamlessly. I have the premium version.

Answers

  • WoolnutWoolnut Members, Plex Pass Posts: 38 Plex Pass

    I don't recall having to do anything special in order to get my Sonos speakers to work with Plex. I pretty much opened up the Sonos App, clicked on the Add Services menu and selected Plex. From here all i needed to do was to login with my Plex account and everything just started working... Does this process not work for you?

    Server: Intel i5 6th Gen; 16GB DDR3, 3TB RAID 5;
    Devices: iPhone X; iPad; iPhone 6 Plus; iPhone 6s; Samsung S7;

  • virgiliomivirgiliomi Members, Plex Pass Posts: 77 Plex Pass

    Having your Plex server work with remote access is unfortunately a requirement for Plex to work with Sonos. You might need to create a port forward manually in your router rather than relying on Universal Plug and Play (UPnP) to automatically create one (personally, UPnP is a security risk IMHO, so I have it disabled in my router anyway).

    If you look at the Remote Access settings for your server, there should be a link to detailed instructions on how to set up a port forward. They can't give specific settings for every router in existence, but their general directions should be enough to point the way. There are other sites that do have specific settings for every router, if you search. :)

Sign In or Register to comment.