If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Some H264 Movies Not Playing

"An error occurred loading this content"
I've been using Plex Media Server with the Plex app on my ATV2 for quite a while without problem. Since I upgraded PMS to 0.9.5, however, I've run into a pretty major issue: some h264 mp4 and m4v files won't play unless I have the video playback set to 1.5 mbps or lower. Anything higher than that and I get "An error occurred loading this content."

Mac Mini 1.83 GHz Intel Core 2 Duo
PMS 0.9.5-dc1de23
Plex for ATV2 0.8.3
ATV 4.3 (2557)

I've attached my ATV2 syslog, truncated down to my most recent attempt to play an h264 file, my PMS log, and the mediainfo for the video file (127 Hours). Again, this is just one example -- it happens on others as well. Not all, though. I think perhaps files over a certain size. I'm still trying to isolate it.

I see I'm not the only one who has experienced this issue, so any help you can give would be greatly appreciated!




  • hoofdpijnhoofdpijn Posts: 1Members
    edited November 2011
    I'm using this exact combination and am experiencing the same issue. I can upload my logs as well if that would help. All of my media files were transcoded with handbrake using the same settings so the files are all the same (mp4). I've not been able to find a rhyme or reason for which ones work, and which don't. I hadn't tried restricting the playback to see if that fixes it.

    I do have xbmc installed and the files all work in that application. As well, the Plex client on my Roku box works just fine. I'm brand new to the appleTV as I've only had it for a couple of days but I'll be glad to help in terms of providing info or testing in any way I can.
  • baabaa Posts: 3,954Members, Plex Pass, Forum Moderator Forum Mod
    As far as I remember, there were a couple of threads, just after the release of PMS 9.5.
    I did not hear/read any feedback from the dev side... so I can only hope that they got it captured :-)
    What I think to know: Whenever PMS is NOT transcoding the content (...and aTV natively like to play h264), then it wouldn't work. Driving down the quality - which in turn applies the need for PMS to transcode - helps being able replay the movie.
    So... I will wait for the 0.9 betas and then have another look...

    Plex @ aTV - think different: PlexConnect

    -> the missing link between Plex Media Server and your AppleTV - 2 or 3, jailbroken or not.

    plex forums: [PlexConnect] -- github: [latest Sources], [Wiki] -- donations (paypal): [US-$][EUR]

  • jeffkosjeffkos Posts: 4Members
    Here are some better logs. I recreated the issue with three consecutive movies (127 Hours, The Abyss, 13 Going on 30 (don't judge me, I have teenage girls)). I then tried the movie 300 and it worked (also H264). Help please!


    Plex Media Server.txt



  • brj8826brj8826 Posts: 56Members, Plex Pass
    edited December 2011
    Just wanted to add that I'm experiencing the same issues with MP4s/M4Vs, also transcoded in Handbrake with the iPad settings.

    Client version 0.8.3
    PMS 0.9.5
  • jigzatjigzat Posts: 42Members, Plex Pass Plex Pass

    I was experiencing something similar, I ended up with a lot of unplayable h.264 movies that used to work just fine . After trying a lot of things I used an app called BatChmod (OSX) and changed permissions, erased ACLs and extended attributes then I restarted and everything was fixed.

Sign In or Register to comment.